phpmyadmin password

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.

phpmyadmin password

Postby crming » Thu Aug 28, 2008 12:55 am

#1045 - Access denied for user 'admin'@'localhost' (using password: YES)
crming
New here
 
Posts: 2
Joined: Sun Aug 10, 2008 1:40 pm
NAS Model: TS-101/TS-201

Re: phpmyadmin password

Postby ApacheSwiss » Thu Aug 28, 2008 5:17 am

crming wrote:#1045 - Access denied for user 'admin'@'localhost' (using password: YES)


the username for MySQL admintrator account is "root" and the default password is "admin".
btw.
SETUP:
- QNAP TS-119 Version 4.1 RC
ApacheSwiss
Know my way around
 
Posts: 179
Joined: Fri Jan 18, 2008 7:53 pm
NAS Model: TS-109/209 Pro II

Re: phpmyadmin password

Postby GMAN20 » Sun Aug 31, 2008 8:56 pm

I've got the same problem. Just enabled the Web server and MySQ.

Tried to access the phpMyadmin screen which loads up ok but I enter a username of root and password of admin and it fails:-

#1045 - Access denied for user 'root'@'localhost' (using password: YES)

Any ideas?
GMAN20
Starting out
 
Posts: 13
Joined: Sat Aug 30, 2008 4:51 am
NAS Model: TS-109/209 Pro

Re: phpmyadmin password

Postby GMAN20 » Sun Aug 31, 2008 9:03 pm

Solved

Leave the password blank :)
GMAN20
Starting out
 
Posts: 13
Joined: Sat Aug 30, 2008 4:51 am
NAS Model: TS-109/209 Pro

Re: phpmyadmin password

Postby fribse » Tue Sep 02, 2008 10:24 pm

If you loose the password, you can reset it via the adminwebinterface.
Oh, and remember to set the password if you have it blank :mrgreen:
Best regards
Fribse

NO, RAID is NOT backup - Use RAID-Certified 24x7 drives for raid
HOWTO's:
Make automatic backup of ALL MySQL databases http://forum.qnap.com/viewtopic.php?f=32&t=15628
Beaf up security on Apache with customized.conf http://forum.qnap.com/viewtopic.php?f=32&t=15540

NAS TS-659 Pro w. 6x 1TB| Joomla, MySQL
SERVERS VMWare 5.1.0 | OES11 GroupWise 2014 | PS3 60GB (upgraded to 500 GB) | Nintendo Wii | Revo Pico RadioStation | 3 Windows 7 Ent PC's
NET FritzBox 7390 | HP Procurve 1800-24G | EdgeCore ES4308 (POE)
User avatar
fribse
Experience counts
 
Posts: 1824
Joined: Mon Feb 11, 2008 2:50 am
Location: Greve, Denmark
NAS Model: TS-659 Pro

Re: phpmyadmin password

Postby samuelthan » Sat Oct 01, 2011 10:30 pm

I had this problem after i first install phpmyadmin.
Found out that i forgot to ENABLE MySql Server :)

Once i tick that box ... APPLY it ....
Reenter the default password and username. I'm logged in to PhpmyAdmin
samuelthan
First post
 
Posts: 1
Joined: Wed Sep 21, 2011 10:04 pm
NAS Model: TS-859U-RP+

Re: phpmyadmin password

Postby meanderingthemaze » Sat Sep 08, 2012 4:54 am

I am having the same issue, cannot log in to phpMyAdmin.
Web Server Enabled - CHECK (default ports)
MySQL Server Enabled - CHECK (I even re-initialized the database and reset root password to default)
phpMyAdmin Updated to most recent version - CHECK
QNAP Updated to most recent version - CHECK

Errors I'm getting:
#2013 Cannot log in to the MySQL server

Login without a password is forbidden by configuration (see AllowNoPassword)


Weird thing is that the user and password lines of the config.inc.php file seem to be commented out. Also, there is no line to set the AllowNoPassword feature. So, this is making me think that maybe I'm in the wrong config file. I tried uncommenting the user/pass lines and that didn't fix it either.

I think I'm going to try to uninstall and reinstall the whole thing next. Hopefully that fixes whatever bug I've got. Any other ideas?
meanderingthemaze
Getting the hang of things
 
Posts: 77
Joined: Sat Aug 01, 2009 6:11 am
NAS Model: TS-419P

Re: phpmyadmin password

Postby meanderingthemaze » Sat Sep 08, 2012 5:28 am

Still not letting me in after a removal and reinstall of phpMyAdmin...same errors.
meanderingthemaze
Getting the hang of things
 
Posts: 77
Joined: Sat Aug 01, 2009 6:11 am
NAS Model: TS-419P

Re: phpmyadmin password

Postby meanderingthemaze » Sat Sep 08, 2012 5:33 am

Wow lucked out and a hail mary guess got me back in. I had to change the host in the config.inc.php file from 127.0.0.1 to localhost. Check this line if you're having issues too:
Code: Select all
$cfg['Servers'][$i]['host'] = 'localhost';
meanderingthemaze
Getting the hang of things
 
Posts: 77
Joined: Sat Aug 01, 2009 6:11 am
NAS Model: TS-419P

Re: phpmyadmin password

Postby themole » Sun Jul 13, 2014 12:44 am

*snip*

See reason attached to post.
Last edited by forkless on Sun Jul 13, 2014 1:06 am, edited 1 time in total.
Reason: Removed for destructive nature of the method used
themole
New here
 
Posts: 2
Joined: Tue May 28, 2013 2:57 am
NAS Model: TS-x19P II

Re: phpmyadmin password

Postby doktornotor » Sun Jul 13, 2014 12:47 am

Who the ** revived the 6 years old thread with completely broken advise? The default password is NOT blank and there's zero reason to allow blank passwords anywhere. If you forgot the MySQL password, use the MySQL password reset function from the GUI!

Moderators, lock the corpse please. Doing more harm than good with random "advise" on "fixing" the issue. :roll: :x
Warning: offensive signature and materials damaging QNAP reputation follow:
QNAP's FW security issues
QNAP's hardware compatibility list madness
QNAP's new logo competition
Dear QNAP, kindly fire your clueless incompetent forum "admin" And while at it, don't forget the webmaster!
User avatar
doktornotor
Ask me anything
 
Posts: 6858
Joined: Tue Apr 24, 2012 5:44 am
NAS Model: Not Selected


Return to Web Server & Applications (Apache + PHP + MySQL / SQLite)

Who is online

Users browsing this forum: No registered users and 4 guests