Page 1 of 1

re-authorize smtp server in Notification Center.

Posted: Mon Nov 04, 2019 4:55 pm
by keith.uk
The Notification Center won't let me send emails. It says that I need to re-authorize the Gmail account that I have set up. If I open QAgent, there is no way to select the existing account to re-authorize it. It takes me directly to the create account page. Is this a bug or is there another way to do it?
Cheers
qnap authorization expired.jpg

Re: re-authorize smtp server in Notification Center.

Posted: Thu Nov 19, 2020 10:44 am
by josh.willett
Hi Keith, did you ever find a resolution to this?
I am having the exact same issue.

Re: re-authorize smtp server in Notification Center.

Posted: Thu Nov 19, 2020 11:27 am
by Mousetick
Google uses special per-app auth tokens rather simple passwords for extra security. If your email account were properly configured it would look like this in Notification Center (second from top):
gmailnotif.png
I guess yours got invalidated by a "firmware" update.

My advice:
1. Trash your current email (click on trash icon on far right side).
2. Re-create the Gmail service provider (click '+ Add SMTP service' button above).
3. In the panel that pops up, select 'Gmail' (first choice), then click on Email field.
4. Another browser window will pop up. You'll be asked to sign-in with Google or to select your Google account if you're already signed in.
5. Then you'll be asked to authorize 'QTS' to send email on your behalf.

Re: re-authorize smtp server in Notification Center.

Posted: Fri Nov 20, 2020 6:39 am
by josh.willett
Thanks Mousetick.
I should have been clearer though, my issue does not relate to relaying through gmail but rather is a custom service that was running fine relaying through ISP mail server before this authorisation thing popped up.
I then deleted it and setup a 365 relay but the same exclamation appeared asking for authorisation.

Re: re-authorize smtp server in Notification Center.

Posted: Fri Nov 20, 2020 5:04 pm
by Mousetick
josh.willett wrote:
Fri Nov 20, 2020 6:39 am
I then deleted it and setup a 365 relay but the same exclamation appeared asking for authorisation.
I don't know what you're referring to by '365'.

Have you tried to recreate a custom SMTP service like the one you had before, going through your ISP mail server?
You fill in the parameters exactly as you would when specifying an outgoing mail server in a desktop mail client like Outlook or Thunderbird.

Re: re-authorize smtp server in Notification Center.

Posted: Sat Nov 21, 2020 9:30 am
by josh.willett
Was just a custom smtp service through office 365.

I have tried recreating through the ISP mail server and recreating through office 365 - About 5 secs after you recreate them the exclamation appears wanting authorisation again but giving no indication on how I am supposed to do this
The settings are all good, it's just the NAS that complains and wants 'authorisation'.
It used to work just fine from the NAS as well.

Re: re-authorize smtp server in Notification Center.

Posted: Tue Dec 22, 2020 3:38 am
by JamesBev
Was this ever sorted and do you have a fix? I have the exact same issue. Multiple NAS drives all previously sending out email alerts fine. Now I need to authorise each one and they fail to authorise. Tried deleting them and adding a new mail server as mentioned above. Very frustrating

Re: re-authorize smtp server in Notification Center.

Posted: Wed Jan 13, 2021 11:39 pm
by marsar
Same here, office365 SMTP servers don't seem to work for whatever reasons. I tried with per-app passwords, still no luck.

Re: re-authorize smtp server in Notification Center.

Posted: Wed Jan 13, 2021 11:55 pm
by dolbyman
report to qnap via ticket to get them to fix it