can't change webserver ssl port from 8081 to 443

Discussion on setting up QNAP NAS products.
arnaudmc
New here
Posts: 3
Joined: Tue Jan 19, 2010 11:05 pm

can't change webserver ssl port from 8081 to 443

Post by arnaudmc » Tue Jan 19, 2010 11:21 pm

Hello,

I have a TS-239 Pro with 3.2.1 Build 1231T firmware.
I want to set the ssl port of the admin panel to 81 -> success.
Next, I want to set the ssl port of web server to the classic 443 port, but I can't change it, it stay to the default 8081 port.
It seem to be impossible to change ssl web server port to anything else than the 8081 default port.
In the configuration page, the port is set to 443 but when I scan port and try to connect to the ssl webserver, it shows than the port stay to 8081. And there is 8081 in the apache-ssl.conf config files.

any idea ?

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: can't change webserver ssl port from 8081 to 443

Post by schumaku » Wed Jan 20, 2010 6:38 am

It's a known bug ... sorry, no better message for now.

-Kurt.

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 7:09 pm

Is it a problem in newest FW3.7.3 as well? I can not change the port over the web interface.

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: can't change webserver ssl port from 8081 to 443

Post by schumaku » Mon Oct 15, 2012 7:19 pm

Well, by default 443 is in use by the NAS Admin Web UI - so change that one first, so 443 will be available...

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 7:40 pm

Hmm it seems it is not working.
Port 443 set in Home>> Genaral Settings >> System Administartion
Changing port in Home>> Network Services >> Web Server to 443 has no effect.
After page reload it comes back to 8081.
I tried to change apache-ssl.conf as follows:

Code: Select all

Listen 443
...
<VirtualHost _default_:443>


After login to Administration page it comes back to 8081 and apache-ssl.conf is overwritten as well.

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: can't change webserver ssl port from 8081 to 443

Post by schumaku » Mon Oct 15, 2012 7:43 pm

jdebs wrote:Port 443 set in Home>> Genaral Settings >> System Administartion
Changing port in Home>> Network Services >> Web Server to 443 has no effect.
Told U - you cant have both on the same port...

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 9:08 pm

I misunderstood than your message. Now it works! Thanks.

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 9:47 pm

One more issue. If I change ports. All my web pages *.domain.net are not working. What is the impact of this port to my domain settings. Please help me to understand this more precisely.
Required ports on router are forwarded.
Jacek

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: can't change webserver ssl port from 8081 to 443

Post by schumaku » Mon Oct 15, 2012 9:51 pm

As long as the cirect ports are used, say https://whatever.domain.net goes ot 443/TCP (default for https), or https://whatever.domain.net:[admin-SSL-port] is leading tot tthe NAS eb UI, and must be used in the QNAP Apps for example, too.

In case there are Web Sever Virtusl Hosts - be aware you need to configure the port here accordingly, too. Probably you still have the 8081 there for https?

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 10:11 pm

what about sites on 80 port (http://www.mydomain.net)? All of them are not working. The page is loading and loading.
I have several sub domains in Virtual host defined. Mostly working on port 80. All these had problems.
Port 80 defined as default in WebServer
Jacek

User avatar
schumaku
Guru
Posts: 43664
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: can't change webserver ssl port from 8081 to 443

Post by schumaku » Mon Oct 15, 2012 10:13 pm

But we haven't tocuhed the port 80 here at all, have we?

jdebs
Getting the hang of things
Posts: 88
Joined: Wed Jan 25, 2012 5:21 pm
Location: Germany

Re: can't change webserver ssl port from 8081 to 443

Post by jdebs » Mon Oct 15, 2012 10:36 pm

Exactly! But it seems not to be working after my changes on 443 and 8081. I will check again...

...
I did it. It works everything. It seems that I had to met the time when my IP has been changing.
Thanks for clarification and quick reply!
Jacek

conandrum
Getting the hang of things
Posts: 99
Joined: Mon Dec 22, 2008 9:46 pm

Re: can't change webserver ssl port from 8081 to 443

Post by conandrum » Thu Apr 24, 2014 9:28 am

I found the problem...

Go in phpMyAdmin, find your wordpress database, open wp_options table, and modify the following 2 rows to reflect the correct path to wordpress.
1 0 siteurl
37 0 home

After you do this, MAKE SURE you delete cookies and history for the site.
VOILA!
TS509 firmware v4.2.6
RAID 5 10TB (single disk volume 5x Hitachi HUA723020ALA640 MK7O)
Windows 10.

prkirby
New here
Posts: 3
Joined: Thu Feb 16, 2017 10:38 pm

Re: can't change webserver ssl port from 8081 to 443

Post by prkirby » Sat Feb 25, 2017 3:29 pm

Hey Guys,

I am having the same issue that OP stated, except I have changed the admin panel to use ssl port 8081 (and disable https connection for that matter), and I still can't get the web server to change secure port to 443.

Every time I try to change it, it just reverts back to 8081. Any help would be greatly appreciated, as I need to change this port for ownCloud to function properly.

jrb
Starting out
Posts: 37
Joined: Thu Feb 03, 2011 5:40 am

Re: can't change webserver ssl port from 8081 to 443

Post by jrb » Thu Oct 15, 2020 5:27 am

Has anyone found a solution to this problem?

Locked

Return to “Turbo Station Installation & Setup”