[FIXED]file copy issue: TS 209 freezes with CPU

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

[FIXED]file copy issue: TS 209 freezes with CPU

Post by caseman » Sat Jan 05, 2008 6:40 pm

Dear support,

I have a serious file copy issue. I have checked the forum but have not found anything useful yet.
I connect to my TS-209 from my Windows XP via fileshare to /public using admin. When I copy my movies to the TS-209, everything looks fine. During the copy process, SMBD runs at ca 60%-70% CPU and PDFlush at 10%-15% but suddenly Windows reports "Delayed Write Failed" and the copy process fails.
At this moment, the 209 has nearly 100% CPU for SMBD (user guest). After a while, the CPU is divided into 70% SMBD (user guest) and 30% SMBD (user admin). Again, after some time, CPU goes down to idle and I can resume copying, but the one file where the error occurred was not copied (naturally). Sometimes the copy process fails every 5-10 minutes, then again it works for 1 hour.
I only own the QNAP for 3 days now. Please help me with this issue, I do not want to have to return the 209 to the vendor.

Technical details:
TS-209 with 1.1.4-1207T
2 x Seagate ST3500320AS SD15 (500GB) in Raid 1, pre-installed by the QNAP vendor

Network
100MB network with a D-Link switch, speeds achieved are okay with 65-70Mbit/s.

Computer
Windows XP SP2 with current patches and hotfixes, language English
Marvel Yukon onboard network adapter
I use TotalCommander for the copying.

Thanks
Carsten
Last edited by caseman on Sat Jan 26, 2008 4:32 pm, edited 1 time in total.

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Mon Jan 07, 2008 10:32 pm

Hello?

Any supporters around?

Regards
Carsten

User avatar
AndyChuo
Experience counts
Posts: 2396
Joined: Thu Sep 13, 2007 11:56 am
Location: Taipei, Taiwan

Re: file copy issue: TS 209 freezes with CPU

Post by AndyChuo » Tue Jan 08, 2008 11:29 am

Hi caseman,

Could you please fill out an online support form first and our ppl will try to assist you asap.

can you observe any other abnormal processes ?

Andy
=============================================================>>>
TS-659-Pro [RAID6] rtorrent+SABnzbdplus+SickBeard+Couchpotato [Best PVR] Plex+PMS [Ultimate Streamer]
Apple iPad [Best Tablet] HTC One M8 [Mobile Phone] Samsung UA46ES6100 [My Screen] KRK Rokit 6 [Audio Speakers]
Chrome Cast [Screen Casting] Philips Hue [Personal Lighing]
Buffalo WZR-1750DHP [My Wifi Hub] D-Link DGS-1005D [Gbit Network]
=============================================================>>>

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Tue Jan 08, 2008 2:57 pm

Hi Andy,

I have opened a request yesterday. All other processes seem to run normally as far as I can judge that. Actually, I am happy with the 209 except for this major flaw and some minor things which I will summarize at a later stage in a new forum entry.

Regards
Carsten

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Wed Jan 09, 2008 3:20 pm

Dear Support,

I have filled out the support form two days ago and I have not heard anything yet. I only have one more week left to return the device to the vendor. Please help quickly.

Thank you
Carsten

User avatar
AndyChuo
Experience counts
Posts: 2396
Joined: Thu Sep 13, 2007 11:56 am
Location: Taipei, Taiwan

Re: file copy issue: TS 209 freezes with CPU

Post by AndyChuo » Wed Jan 09, 2008 4:16 pm

They will contact you by email today, sorry man.
=============================================================>>>
TS-659-Pro [RAID6] rtorrent+SABnzbdplus+SickBeard+Couchpotato [Best PVR] Plex+PMS [Ultimate Streamer]
Apple iPad [Best Tablet] HTC One M8 [Mobile Phone] Samsung UA46ES6100 [My Screen] KRK Rokit 6 [Audio Speakers]
Chrome Cast [Screen Casting] Philips Hue [Personal Lighing]
Buffalo WZR-1750DHP [My Wifi Hub] D-Link DGS-1005D [Gbit Network]
=============================================================>>>

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Thu Jan 10, 2008 5:16 pm

Good morning Andy,

sorry to disappoint you but nobody contacted me yesterday.

Regards
Carsten

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Fri Jan 11, 2008 2:44 pm

Good morning Andy,

sorry to disappoint you again but nobody contacted me yesterday or the day before.

Regards
Carsten

phibes4000
Getting the hang of things
Posts: 89
Joined: Sat Jan 12, 2008 5:04 am

Re: file copy issue: TS 209 freezes with CPU

Post by phibes4000 » Sat Jan 12, 2008 5:14 am

I'm having the same problem. The smbd process is running at close to 100%; perhaps it's timing out. I'm using the TS-209 to replace openfiler on a linux machine, so the problem is on the server, not client side.

I'm running slimserver on mine, which may (unlikely) be contributing. A lot of people buy the unit for this, I'm surprised QNAP haven't acted on the feature requests to include it as a standard option.

I have found my 209 unreliable for large movements of data from an XP Pro machine.

This would seem to be a bug in the qnap implementation (fixed by firmware) rather than problems with our specific units. They've probably gone quiet because they don't know how to fix the problem (yet).

I'm experimenting with turning the iTunes Server off, as the mt-daapd process seems to hog RAM - was taking 49mb - prob scanning my library.

Check out the poll I've posted - viewtopic.php?f=13&t=2389

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Sun Jan 13, 2008 12:52 am

After days of being ignored by the support, I have done several tests. I have changed various characteristics of accessing the 209 via SMB (Win XP file share). I have
- changed Win XP network speed to 10 MB FD because I thought that maybe the SMBD is overloaded with information: problem persists
- switched of flow control: problem persists
- deactivated Kaspersky Anti-Virus: problem persists

This morning I have copied several GB of files to the 209 with no problem. Surprise for me, because the number of processes seems to have trippled over night. All of a sudden the problems start again. Then there is a ZIP file on the 209 which I cannot unzip with right-click and “Extract here” (function of Winrar), that is: one file is extracted and CPU rockets to 99%. After everything is normal again, a double-click on this extracted MP3 file and CPU rockets. Selecting the file for deletion and CPU rockets. Half an hour later the file can be deleted without problems. Naturally, I tested the zip file on the local disk and there was no problem whatsoever.

Maybe it is because the hard drives are not supported, maybe the software Raid is buggy, maybe the SMBD is buggy, I do not know. So far the support ignored me. They do not even tell me if the installed disks are supported or not.
Another thing, but minor: when accessing the configuration webpage with IE6, it reacts very slowly but everything is fine with Firefox.

I have resetted the settings and am now waiting for the Raid1 resync. Then I will do a check disc. After some more tests, I will probably reinstall firmware 1.1.4 and test some more. Then I will return the 209 to the vendor.
:(

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Mon Jan 14, 2008 4:28 am

One day of tests later I come to the following conclusions:
The problems I experience are probably the results only of the buggy or otherwise improper implementation of the SMB. The 209 uses version 3.0.23d and 3.0.27 has already been released. Maybe an upgrade could fix this?
All other functions seem to work flawlessly, as far as I have tested them. I have copied more than 100 GB to the 209 today and had no problems but filename errors in FTP due to non-ASCII characters.
As a paying customer, I have one request and one demand:
I demand to receive an immediate answer whether the hard drives are supported or not and
I request that the support or Quality Assurance (or Development) department take a look at the SMB implementation. I do not seem to be the only one having problems with using file shares from Windows XP.

Carsten

happyguy
Getting the hang of things
Posts: 71
Joined: Wed Jan 16, 2008 12:18 am
Location: United States

Re: file copy issue: TS 209 freezes with CPU

Post by happyguy » Wed Jan 16, 2008 12:57 am

I'm getting the same issue on multiple Win XP Pro SP2 machines connected to a TS-209 Pro (firmware 1.1.3 Build 1101T). My TS-209 Pro is set up in RAID-1 with two ST3750640AS drives (we might be using the same family of Seagate drives?). Gonna try updating the firmware, though I don't think that's going to do anything..in which case I'll submit a support ticket to QNap & see what they say.

Seems to happen during large file transfers, for us typically when running ntbackup from the XP machines to the TS-209 Pro.

First we get:
(event ID 26)
Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file \Device\WinDfs\Z:0000000000028dde\192.168.x.x\xxx.xxx. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

Followed by:
(event ID 50)
{Delayed Write Failed} Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

I did dig up this Microsoft article on the subject:
http://support.microsoft.com/kb/822219/en-us

Incidently I used to have this same problem when running large network transfers to an old Snap Server NAS device (also Linux-based like the TS-209). At the time disabling Opportunistic Locking on all the Win XP Pro machines fixed the problem, though I have not gotten around to trying that here..and to be honest, doing that on all the connected Win XP Pro machines was a big hassle.

I'm suspicious that the problem has something to do with:
- Linux/Windows Samba compatibility?
- Perhaps the NAS drive's filesystem format (Win XP tends to play nice with other NTFS-formatted drives).
- Maybe the TS-209 just needs to be able to disable opportunistic locking on the server side (does Linux even support Windows' implementation of this??).
- Weird issue with the Seagate drives?

phibes4000
Getting the hang of things
Posts: 89
Joined: Sat Jan 12, 2008 5:04 am

Re: file copy issue: TS 209 freezes with CPU

Post by phibes4000 » Wed Jan 16, 2008 4:01 am

it's a server-side problem per my earlier post. i have samsung disks. it's highly unlikely that a sata compliant drive will be incompatible. it has nothing to do with the client. i had some luck by disabling things like itunes server, ftp, multimedia server etc to free up resources. try running a minimal setup while running top to confirm resources are free.

Hopefully a fix is coming...

it looks from this forum as if support is very basic and slow. I like the possibilities of the device but would not recommend buying one in its current flimsy form...

caseman
Starting out
Posts: 20
Joined: Sat Jan 05, 2008 2:38 am

Re: file copy issue: TS 209 freezes with CPU

Post by caseman » Thu Jan 17, 2008 1:51 am

I would like to correct your statement that the "support is very basic and slow". Telling me to open an online support form and then ignoring everything, even the attempts of the frustrated users to help themselves, makes this support practically non-existant. This reminds me of the Simpsons episode when Homer is replaced by this wooden bird picking at a keyboard every couple of seconds...

phibes4000
Getting the hang of things
Posts: 89
Joined: Sat Jan 12, 2008 5:04 am

Re: file copy issue: TS 209 freezes with CPU

Post by phibes4000 » Thu Jan 17, 2008 5:10 am

ATTN QNAP SUPPORT.

Please answer the following.

Have you tested this product for heavy use, or are we doing this for you?
How many support staff do you employ? Is their role solely support, or is this mixed with other duties?
Are support staff trained to provide Level 2 and 3 support?
Do you have a guaranteed response time to support cases?

Post Reply

Return to “File Sharing”