Linux Station Installation failure

Discussion about various official QPKG software applications. Login required to view the contents.
Locked
felipe64

Linux Station Installation failure

Post by felipe64 » Tue Nov 22, 2016 3:22 am

QNAP has suggested that I had nothing to do after a long day at work, it decided to prevent him from rebooting to Linux Station.

So after many atempts to restart it, a full reinstallation is required.
BUT the installation failed.

In the installation log, there is an error at 57%:
/var/log/container-station/ubuntu-hd.log
Exception: Failed to install built-in packages: qnap-desktop-meta-xenial

Does someone has this error, and how it can be solved?

I tried to look to the distro.py file to edit it manually (since my QNAP suggested I had nothing to do) but i coulnd't locate it. Does someone know where this file is located?
Many Thanks.

felipe64

Re: Linux Station Installation failure

Post by felipe64 » Tue Nov 22, 2016 3:36 am

for my information, the file is located under /share/CACHEDEV1_DATA/.qpkg/ubuntu-hd/middleware_ubuntu_hd/ubuntu_1604
I will try to remove the qnap-desktop-meta-xenial from the distro.py file to see if installation proceed. (it seems that i have nothing to do tonight. :evil: )

felipe64

Re: Linux Station Installation failure

Post by felipe64 » Tue Nov 22, 2016 6:27 am

Does someone know how is mounted /nas_share on Linux Station ?

Without installation of qnap-desktop-meta-xenial, the NAS drives are not mounted by default.

Man Thanks,
Regards
Felipe

orenr
New here
Posts: 2
Joined: Mon Aug 07, 2017 4:01 am

Re: Linux Station Installation failure

Post by orenr » Mon Aug 07, 2017 4:05 am

I have the same problem when trying to install Ubuntu in Linux station. the process fails every time at 62%
When looking at /var/log/container-station/ubuntu-hd.log I can see this entry-

"Failed to install built-in packages: qnap-desktop-meta-xenial"

ironfalcon
New here
Posts: 2
Joined: Tue Feb 21, 2017 1:43 am

Re: Linux Station Installation failure

Post by ironfalcon » Tue Aug 08, 2017 4:34 am

same issue here as well, not sure if it's related to most recent firmware upgrade

orenr
New here
Posts: 2
Joined: Mon Aug 07, 2017 4:01 am

Re: Linux Station Installation failure

Post by orenr » Mon Aug 14, 2017 1:01 pm

Solved. A new release for Linux station solved it - 1.3.1548 ( 2017/08/10 )

https://www.qnap.com/en/app_releasenote ... =ubuntu-hd

rflsouza
Starting out
Posts: 16
Joined: Fri Oct 07, 2011 9:47 am

Re: Linux Station Installation failure

Post by rflsouza » Sat Apr 10, 2021 6:30 am

orenr wrote:
Mon Aug 07, 2017 4:05 am
I have the same problem when trying to install Ubuntu in Linux station. the process fails every time at 62%
When looking at /var/log/container-station/ubuntu-hd.log I can see this entry-

"Failed to install built-in packages: qnap-desktop-meta-xenial"
The log helped me a lot! In the web interface it simply closed and showed no error.

For security I disable the admin user! and He was complaining about it, enabled the admin and managed to do the installation.

Error that was in the log:
{
"config": 4,
"errDetail": {
"code": 503,
"errorCode": 6,
"errorMsg": "admin is disabled!",
"progress": 0,
"result": "",
"state": "downloading",
"type": "UserError"
},
"lxcname": "ubuntu_2004",
"state": "error"
}
TS-253Be - 16GB memory - Crucial 16GB DDR3L-1600
2 - HD Seagate IronWolf NAS, 8TB, 3.5´, SATA - ST8000VN0022 (RAID 1)
2TB Seagate ST2000DL003-9VT166 (SATA) External backup (usb)
----------------------------------------------------
TS-251+ I used for 5 years (dead intel)
TS-219P+ Turbo NAS(old) working more than 10 yeas
3TB Seagate ST3000DM001-1ER166 (SATA) (dead)

User avatar
OneCD
Ask me anything
Posts: 8975
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: Linux Station Installation failure

Post by OneCD » Sat Apr 10, 2021 6:30 am

* topic locked to prevent further necroposting *

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

Locked

Return to “Official Apps”