Rsync to remote NAS via SSH failing (broken pipe error message)

Backup, Restore, Netbak Replicator, Cloud Storage Services
Post Reply
randalthevandal
New here
Posts: 4
Joined: Sat Aug 24, 2019 1:48 am

Rsync to remote NAS via SSH failing (broken pipe error message)

Post by randalthevandal » Wed Aug 28, 2019 4:54 am

Hello all!
I hope you all don't mind someone not super familiar with sysadmin posting here. I also saw some old posts that mentioned this issue, but they were all sealed & didn't offer me much resolve.

Anyhow, I've come across a peculiar issue when trying to do encrypted Rsync jobs via SSH / 22. Normal, unencrypted jobs over 873 work just fine to the remote NAS, but when trying via SSH, the job fails with the following message: "Hybrid Backup Sync] Failed to complete Sync job: One-way Sync 1". Encountered error "rsync: [sender] write error: Broken pipe (32)" Attempting to retry. Error code: 1."

In the Remote Rsync Server dialogue box QNAP states the following:
• you must enable a SSH connection on the remote host - I'm certain I've done this, but would appreciate someone confirming what this means.

• The port number must match the SSH port of the remote host - I've done this, confirmed both NAS units are on 22 with correct ports forwarded on both routers.

• The account must have permission to perform SSH encrypted backup jobs - no issue here, I've put in admin credentials with SSH permission.

With all of this said, I'm going to the location of the remote NAS to double check the router settings. One theory I had was that this could be stemming from UPNP options on either router. On my home end - I manually forwarded all necessary ports for QNAP services, whereas at the remote backup location I used an "auto-router configuration" dialogue box which handled all of the port forwards automatically, but only set them up for TDP, not "Both".

I've attached screenshots of the auto-router configs I mentioned, with each one clearly labeled. I'm now noticing that QNAP is showing errors for my home NAS unit, but everything is functioning correctly.

Any thoughts? Much appreciated if anyone helps!
You do not have the required permissions to view the files attached to this post.

kkirvesm
New here
Posts: 7
Joined: Fri Aug 22, 2008 4:35 am

Re: Rsync to remote NAS via SSH failing (broken pipe error message)

Post by kkirvesm » Sat Sep 07, 2019 3:22 pm

This error have been years. You have to FIX RsyncRR.sh. Search RsyncRR.sh-posts.

kkirvesm
New here
Posts: 7
Joined: Fri Aug 22, 2008 4:35 am

Re: Rsync to remote NAS via SSH failing (broken pipe error message)

Post by kkirvesm » Sat Sep 07, 2019 3:27 pm

I use changed rsyncRR.sh file. I found a new code from this forum.
Check this:
viewtopic.php?f=22&t=78623&p=460209&hil ... sh#p451907

it's working now. Put this file to /etc/init.d -folder. I use TS 453 pro.

Post Reply

Return to “Backup & Restore”