HBS3 fails with System Error when UPS is connected via USB

Backup, Restore, Netbak Replicator, Cloud Storage Services
Post Reply
sean.true
First post
Posts: 1
Joined: Sun Feb 03, 2019 10:57 pm

HBS3 fails with System Error when UPS is connected via USB

Post by sean.true » Wed Jul 22, 2020 9:28 am

Unplugging the UPS USB cable (used to signal shutdown on power fail) and rebooting fixes the problem.

Some digging suggests that the internal web service used for file system access can't handle USB devices which are not disks. It's also possible that QNAP is filtering out known USB devices that are not disks, but my UPS was recognized by QNAP as a UPS/external device.

Not in the mood to fix the bad module (.qpkg/output/shared/python/lib/python3.7/site-packages/qnap/hbs3/v1/controller/sysinfo/external.pyc), but if I don't hear back from QNAP I may do it out of aggravation.

P3R
Guru
Posts: 12293
Joined: Sat Dec 29, 2007 1:39 am
Location: Stockholm, Sweden (UTC+01:00)

Re: HBS3 fails with System Error when UPS is connected via USB

Post by P3R » Wed Jul 22, 2020 2:32 pm

I have never used HBS3 without a UPS.

What combination is causing the issue for you?
RAID have never ever been a replacement for backups. Without backups on a different system (preferably placed at another site), you will eventually lose data!

A non-RAID configuration (including RAID 0, which isn't really RAID) with a backup on a separate media protects your data far better than any RAID-volume without backup.

All data storage consists of both the primary storage and the backups. It's your money and your data, spend the storage budget wisely or pay with your data!

Post Reply

Return to “Backup & Restore”