Can't connect to Private Trackers.

Post your questions about BT download, FTP download, HTTP download, or QGet download software here.
Post Reply
Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Can't connect to Private Trackers.

Post by Wowbagger » Wed May 11, 2022 1:33 am

Hi,

I recently did a factory rest on my old QNAP TS-219P+, which runs QTS 4.33.

Since the reset, I have been unable to download any torrents from private (https) trackers, either with Download Station 5 or Transmission 2.94. I've read a lot of suggestions over the last few days but most (if not all) try to pinpoint and resolve potential issues with those applications. Nothing I've read has worked for me. Regular public (http) trackers work fine. I tried installing the desktop version of Transmission on my Windows laptop, which is on the same network, and that also works with all trackers.

Since neither client works, I feel like when I reset my NAS something else needs to be enabled or installed to allow applications to connect to https, but I can use curl to reach an https site, so that may not be the case. The specific error I get with Transmission is "Could not connect to tracker". I haven't found any log files for Download Station to check if it's the same error. I have also tried to install QBittorrent, but that one won't even start. I think it's because it has a dependency on QPython3, which I can't seem to get for an older NAS firmware.

Has anyone managed to get DS or Transmission working after resetting an older NAS? Can anyone think of something that I might have overlooked?

Thanks for any help!

User avatar
dolbyman
Guru
Posts: 26866
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Can't connect to Private Trackers.

Post by dolbyman » Wed May 11, 2022 2:11 am

did you read the topic right under the one you just created?

viewtopic.php?f=16&t=164073

Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Re: Can't connect to Private Trackers.

Post by Wowbagger » Wed May 11, 2022 2:56 am

The topic you linked to is describing an issue with Download Station's search function, and the suggested solution is to use Transmission.

Thanks for your help, but that is not related at all to the problem I am experiencing. And, as I mentioned, I have actually tried using Transmission as an alternative.

User avatar
dolbyman
Guru
Posts: 26866
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Can't connect to Private Trackers.

Post by dolbyman » Wed May 11, 2022 3:05 am

First post talks about finding no seeds or peers, less search results were also mentioned but seeds and peers were the main issue.

Download Station has been pretty much abandoned by QNAP, but only they could fix issues in QNAP own apps.

If transmission has also issues, the used client version might just be blacklisted for being outdated, might be time to retire that NAS as torrent downloader

dosborne
Easy as a breeze
Posts: 413
Joined: Tue May 29, 2018 3:02 am

Re: Can't connect to Private Trackers.

Post by dosborne » Wed May 11, 2022 11:20 am

I have no issues with qtransmission running on both my NAS boxes. V2.94.0 from qnapstore.eu
QNAP TS-563-16G 5x10TB Seagate Ironwolf HDD Raid-5 Triple NIC: 2x1GB 1x10GbE
QNAP TS-231P-US 2x18TB Seagate Exos HDD Raid-1 Dual 1GB NIC

Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Re: Can't connect to Private Trackers.

Post by Wowbagger » Wed May 11, 2022 8:40 pm

dolbyman wrote:
Wed May 11, 2022 3:05 am
Download Station has been pretty much abandoned by QNAP, but only they could fix issues in QNAP own apps.

If transmission has also issues, the used client version might just be blacklisted for being outdated, might be time to retire that NAS as torrent downloader
I don't believe either app has issues in themselves. Transmission has worked perfectly for at least 10 years, until I reset the NAS. Transmission also works perfectly from my Desktop, so it's definitely not a blacklisted client. Both apps on the NAS work with http trackers, just not with https. Its definitely a configuration issue, or a missing SSL certificate, or something along those lines. Something that was changed when I reset the NAS, and which somehow worked before. Maybe I had an older version of Transmission before the reset, which worked out of the box, but I did tend to keep everything updated.

I can't get any other torrent client to work on that box either, so I'd really rather figure out what changed. I've set up verbose logging but I'm getting nothing useful. I will replace the NAS one day, but I'm sure the old gal still has a bit more life in her. I recently upgraded the drives to 2x 4TB and it just quietly did its job - I don't need anything more.

Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Re: Can't connect to Private Trackers.

Post by Wowbagger » Wed May 11, 2022 8:46 pm

dosborne wrote:
Wed May 11, 2022 11:20 am
I have no issues with qtransmission running on both my NAS boxes. V2.94.0 from qnapstore.eu
After I reset the NAS, I might no longer have some service running that was installed/enabled before. Do you remember if you had to start any other services to get https trackers to work? Or do anything in particular with SSL certs? There are quite a few things you can enable in QTS and I may have missed something. I tend to turn off as much as possible as it is an older box with lower specs - I only use it for media and torrents.

User avatar
OneCD
Guru
Posts: 10087
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: Can't connect to Private Trackers.

Post by OneCD » Thu May 12, 2022 4:13 am

Wowbagger wrote:
Wed May 11, 2022 8:40 pm
I will replace the NAS one day, but I'm sure the old gal still has a bit more life in her. I recently upgraded the drives to 2x 4TB and it just quietly did its job - I don't need anything more.
Maybe consider the new TS-233? This would be a big jump in performance from your TS-219P+, it supports the current QTS versions and apps, and at US$199 is probably the cheapest QNAP NAS on the market. ;)

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Re: Can't connect to Private Trackers.

Post by Wowbagger » Thu May 12, 2022 5:23 pm

OneCD wrote:
Thu May 12, 2022 4:13 am
Maybe consider the new TS-233? This would be a big jump in performance from your TS-219P+, it supports the current QTS versions and apps, and at US$199 is probably the cheapest QNAP NAS on the market. ;)
Thanks. I will replace it one day but I'm currently working overseas and acquiring new hardware is not practical for me right now. I'd rather try to figure out what changed when I did the reset.

Wowbagger
New here
Posts: 7
Joined: Wed May 11, 2022 12:48 am

Re: Can't connect to Private Trackers.

Post by Wowbagger » Sat May 14, 2022 2:44 am

OK, I managed to find out that the version of Transmission I was using previously was 2.84. After quite a bit of hunting around, I finally managed to track down the correct QPKG installer for Transmission 2.84 (X19-ARM). I installed that and it works perfectly.

So it's not something I overlooked, but there seems to be a compatibility difference between 2.84 and 2.94 as far as firmware 4.3.3 is concerned.

Anyway, it's working now so that's good enough for me. Thanks for your suggestions. And thanks to user 'degsie' on this forum who posted the link to the file 5 years ago!

Post Reply

Return to “Download Station and QGet”