[TS-451] Streaming videos stutter, slow networkspeed (SOLVED)

DLNA, AirPlay, Chromecast, PS3, XBOX, iTunes, & other media players
raevenlock
New here
Posts: 2
Joined: Sun Nov 29, 2015 6:29 pm

[TS-451] Streaming videos stutter, slow networkspeed (SOLVED)

Postby raevenlock » Sat Jul 21, 2018 7:20 pm

Hello

My QNAP TS-451 has begun to stutter and buffer when I am streaming media to my external devices.

I have owned my QNAP for a couple of years now and I have not had this problem before. It all started after my NAS crashed and I had to restore it to default settings (Still have all my files on the NAS)

Using firmware 4.3.4.0644

How I am using my NAS?
My NAS is just for storing files and videos. I am NOT using the built in videoplayers from the NAS (Not connected with HDMI)
I am plying my files from an Nvidia Shield TV (with Kodi) and a Philips smarttv (with Kodi) (no major changes has been done to the external players)

How is everything connected? (This is how it always has been connected, even when it worked)
ASUS RT-N56U router -> Netgear switch -> Netgear switch -> NAS
ASUS RT-N56U router -> Netgear switch -> Netgear switch -> Nvidia Shield
ASUS RT-N56U router -> Netgear switch -> Philips SmartTV

What is the problem?
When I am streaming video-files to any of my Kodi players the video begins to buffer and stutter all the time, ALOT.
When I am trying to copy a video-file from the NAS to my Windows 10 computer I cannot get transfer-speed higher than 700kB/s (it goes up and down, up and down)

How is the NAS setup?
3 harddrives in RAID 5 (No storage pool)
Both NICs are connected with 1GB (No Port Trunking, No virtual switch, No DHCP server)
Videostation, Media-Streaming add-on, Codexpack are installed

I am hoping anyone can help me with this anoying problem :/
Will upload a video on the problem later today

Thank you!
Last edited by raevenlock on Sun Jul 22, 2018 3:06 am, edited 1 time in total.

dolbyman
Guru
Posts: 10161
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: [TS-451] Streaming videos stutter, slow networkspeed

Postby dolbyman » Sat Jul 21, 2018 10:29 pm

cpu load of the nas?

tried with only one lan connected?

raevenlock
New here
Posts: 2
Joined: Sun Nov 29, 2015 6:29 pm

Re: [TS-451] Streaming videos stutter, slow networkspeed

Postby raevenlock » Sun Jul 22, 2018 3:03 am

For some reason it worked slower then before when I tried it with just one LAN connected (strange).
But I actually think that I have solved the problem myself.
A rookie mistake perhaps, but I configured a virtual switch, gave that a static IP and connect both of the lan ports to it, that seemed to fix the problem!
We'll see..

But thank you for your time! :)

Ps. The filetransfer speed picked up aswell, from a couple of kB/s to 120Mb/s


Return to “Media Streaming”

Who is online

Users browsing this forum: No registered users and 1 guest