Two step verify- does not send to phone

iPhone, Windows Mobile, Symbian, Android
triples@aol.com
First post
Posts: 1
Joined: Mon May 15, 2017 7:25 am

Two step verify- does not send to phone

Postby triples@aol.com » Sun Jun 04, 2017 12:23 am

Set up two step verify on qnap. When logging in within home network from new device, a verify number is sent to my cell but does not go thru. To make it work, have to request an email, then it works.
Now trying access through qnapcloud from my phone and got to the step where code sent back to my phone but never arrived and cannot access drive as part of two step verify.
Anyone else experiencing this??
Ps- the correct phone number is in the drive.
Hmmm.... perplexed

User avatar
OneCD
Experience counts
Posts: 3276
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: Two step verify- does not send to phone

Postby OneCD » Sun Jun 04, 2017 2:08 am

Hi and welcome to the forum. :)

When asking a question, please remember to include your NAS firmware version and build number.

triples@aol.com wrote:When logging in within home network from new device, a verify number is sent to my cell but does not go thru.

Note: a phone number is not needed and a code is not 'sent' to your phone on each login attempt.

QNAP's 2-step verification process makes use of the Google 'Authenticator' app (on iOS and Android) that continuously generates new codes - each only valid for a few seconds - same idea as those portable security tokens:
Image
Time is a factor, so it's important your NAS and phone are automatically updating their system times.

Have you installed the Google 'Authenticator' app on your phone?

I've switched to pure Debian on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to follow, so I'll no longer be able to use or support QNAP's firmware. This means no more closed-source software, "Malware Removers", etc ... If you have the means, I highly recommend it. Powerup/poweroff times are < 1 minute. :D

one.cd.only@gmail.com

pablobasito
Starting out
Posts: 12
Joined: Thu Apr 11, 2013 7:33 pm

Re: Two step verify- does not send to phone

Postby pablobasito » Mon Nov 13, 2017 4:20 am

I have the same problem. I try to login with my Qfile, but when I connect, it asks me for a "2 step verification", and in the same screen, it shows me my cell number, and a "Send" button. When I hit it, a cowntdown number goes from 60 to 0. In that time, I receive no sms at all.
Of course, I have the Authenticator app in my phone, but if I try to put the 6 digit number I get from it, it says it's wrong. (yes, I put it very fast, I know I have limited time to do it).
I really need help about that. Thanks in advance.
EDIT: my NAS is a 453 Pro, with beta 4.3.4 firmware (if memory serves me well), however I think the problem could be in the android app (or in my settings??) not in the NAS.

User avatar
OneCD
Experience counts
Posts: 3276
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: Two step verify- does not send to phone

Postby OneCD » Mon Nov 13, 2017 4:41 am

pablobasito wrote:I have the same problem. I try to login with my Qfile, but when I connect, it asks me for a "2 step verification", and in the same screen, it shows me my cell number, and a "Send" button. When I hit it, a cowntdown number goes from 60 to 0. In that time, I receive no sms at all.

This doesn't sound like the 2-step verification process. SMS isn't used. Are you using the correct QNAP Qfile app? Or a 3rd-party app?

Here's how to set this up:
https://www.qnap.com/en/how-to/tutorial ... sing-qfile

The relevant section is titled "How to use 2-step verification to log in to a NAS using Qfile"

Suggest you contact QNAP for assistance.

I've switched to pure Debian on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to follow, so I'll no longer be able to use or support QNAP's firmware. This means no more closed-source software, "Malware Removers", etc ... If you have the means, I highly recommend it. Powerup/poweroff times are < 1 minute. :D

one.cd.only@gmail.com

pablobasito
Starting out
Posts: 12
Joined: Thu Apr 11, 2013 7:33 pm

Re: Two step verify- does not send to phone

Postby pablobasito » Mon Nov 13, 2017 4:59 am

I did it. I keep you informed, if I have news.
You do not have the required permissions to view the files attached to this post.

pablobasito
Starting out
Posts: 12
Joined: Thu Apr 11, 2013 7:33 pm

Re: Two step verify- does not send to phone

Postby pablobasito » Mon Nov 13, 2017 3:11 pm

I added the screenshots in the previous post. The order is reversed.

User avatar
OneCD
Experience counts
Posts: 3276
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: Two step verify- does not send to phone

Postby OneCD » Tue Nov 14, 2017 3:53 am

I've just finished confirming the required steps. I had to pull my old Android tablet out of storage and charge it up overnight. ;)

All worked OK.

What I did:

  1. Installed the Google Authenticator app in Android,

  2. Enabled 2-step verification on my older NAS (running QTS 4.2.6),

  3. Entered the code generated by QTS into the Authenticator App to "pair" the app with the NAS,

  4. Then logged in via Qfile. My Qfile Android app already has my preferred QTS account username and password entered, so I launched the Authenticator app again, viewed the current code, entered this into the required field on the Qfile login screen, clicked 'login', and done!

I've switched to pure Debian on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to follow, so I'll no longer be able to use or support QNAP's firmware. This means no more closed-source software, "Malware Removers", etc ... If you have the means, I highly recommend it. Powerup/poweroff times are < 1 minute. :D

one.cd.only@gmail.com

User avatar
schumaku
Guru
Posts: 42794
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Two step verify- does not send to phone

Postby schumaku » Tue Nov 14, 2017 6:45 am

About the expired QID, I'd suggest to login on https://myQNAPcloud.com/ from a Web browser. Not sure what can cause the expiration.

pablobasito
Starting out
Posts: 12
Joined: Thu Apr 11, 2013 7:33 pm

Re: Two step verify- does not send to phone

Postby pablobasito » Thu Nov 16, 2017 12:56 am

Even when I try from a PC (windows 10, tried on different browsers), I get the same kind of windows (see attachments), and of course the SMS thing isn't working.
The only difference is that from the PC browser I can select "choose another method etc. etc." (see one of the attachment), and there I find "Email". So, the website sends me an email with a 6digit code that works, so I can complete the 2step verification, and I can access to myqnapcloud.

EDITED NOTE: while I'm inside, I double checked my settings, and I tried to insert my cellphone number again. As you can see from the attachment, the system try to send me an sms for confirmation of my cell number, BUT I don't receive it.

EDIT: when I complete that phase, I'm inside the "standard" myqnapcloud window, where it asks me for my NAS username and password. And after I input them, it asks me for ANOTHER verification... this time with the Authenticator. That 2nd verification works.
You do not have the required permissions to view the files attached to this post.


Return to “Mobile Devices”

Who is online

Users browsing this forum: No registered users and 2 guests