ISCSI error after last update 5.0.0.1986

iSCSI related applications
Post Reply
fisch88
New here
Posts: 5
Joined: Sat Aug 01, 2009 9:10 pm

ISCSI error after last update 5.0.0.1986

Post by fisch88 » Tue Apr 05, 2022 9:35 pm

Hello, I have a problem after the last update. Every iSCSI LUN drive was showing "unknown error", so I tried to unmount the drives and it can't get them working, it has been constantly "Removing .. NaN%" for days
I cannot lose data..

Anyone know how I can fix this situation?
You do not have the required permissions to view the files attached to this post.

FSC830
Experience counts
Posts: 1057
Joined: Thu Mar 03, 2016 1:11 am

Re: ISCSI error after last update 5.0.0.1986

Post by FSC830 » Tue Apr 05, 2022 9:39 pm

A downgrade to previous used version (which one was it)?

Regards

BTW: If data is important, an external backup is mandatory! A raid is never ever a substitute for backup!

fisch88
New here
Posts: 5
Joined: Sat Aug 01, 2009 9:10 pm

Re: ISCSI error after last update 5.0.0.1986

Post by fisch88 » Tue Apr 05, 2022 10:15 pm

I wanted to downgrade but I stopped in front of this screen, I would not want to make it worse ...

I have not yet replicated the LUN volumes as they are compatible only with Hero it seems .. and it is the only NAS with this system
You do not have the required permissions to view the files attached to this post.

FSC830
Experience counts
Posts: 1057
Joined: Thu Mar 03, 2016 1:11 am

Re: ISCSI error after last update 5.0.0.1986

Post by FSC830 » Tue Apr 05, 2022 10:39 pm

That is, why no-one writes down his NAS or firmware version! Everyone cries for help without giving any idea what the current configuration it is/was!

This is an English forum, you should at least set the desktop language to English when posting such screenshots!
I know that there is a warning message every time when a downgrade was triggered.
What has your problem to do with QuTS hero? Do you run hero at your NAS?

Regards

fisch88
New here
Posts: 5
Joined: Sat Aug 01, 2009 9:10 pm

Re: ISCSI error after last update 5.0.0.1986

Post by fisch88 » Wed Apr 06, 2022 1:33 am

I use QTSHero, I did the downgrade (as recommended also by the support) and this is the situation, drastically worsened
2022-04-05 19_31_27-NAS1DATACENTER.jpg
You do not have the required permissions to view the files attached to this post.

FSC830
Experience counts
Posts: 1057
Joined: Thu Mar 03, 2016 1:11 am

Re: ISCSI error after last update 5.0.0.1986

Post by FSC830 » Wed Apr 06, 2022 2:21 am

As far as I can read in your screenshot hero do not support a downgrade.
If support advises you to do so, I am really surprised :geek: .

Anyhow, if support is already involved I hope it turns to a lucky end.

Regards

fisch88
New here
Posts: 5
Joined: Sat Aug 01, 2009 9:10 pm

Post by fisch88 » Wed Apr 06, 2022 5:30 pm

unfortunately, inexplicably, the support is not effective in solving problems, I have open cai for months without solving them.
Let's wait and see ..

trinityanderson
Starting out
Posts: 11
Joined: Sat Apr 02, 2022 12:54 am

Re: ISCSI error after last update 5.0.0.1986

Post by trinityanderson » Wed Apr 06, 2022 11:13 pm

I had the same "unknown error" message when mapping a LUN to a target. It's a generic error message presented in the GUI. You'll want to enable SSH on your NAS and SSH into the device. I have a post that provides some commands that you can issue that'll help you determine what the actual problem is. In my case, the device could not be found. This is a bit different as the LUN was there and appeared healthy however it turned out the linux system hadn't properly mapped it.

If you're comfortable with linux and linux commands check out this post: viewtopic.php?f=180&t=165908

QNAP support was extremely slow to respond but I found them very effective once they dug into the issue.

fisch88
New here
Posts: 5
Joined: Sat Aug 01, 2009 9:10 pm

Re: ISCSI error after last update 5.0.0.1986

Post by fisch88 » Wed Apr 13, 2022 6:50 pm

unfortunately the scsidevadm list_device command gives me these errors:

Code: Select all

open ctl_device fail error 13
open ctl_device fail error 13
List device fail, res = 0x3020115, IOCTL fail
If I found manuals with commands for managing iSCSI I would try to find a solution by myself ... i would try to reinstall the iscsi service first ..
2022-04-13 12_51_23-NAS1DATACENTER.jpg
You do not have the required permissions to view the files attached to this post.

trinityanderson
Starting out
Posts: 11
Joined: Sat Apr 02, 2022 12:54 am

Re: ISCSI error after last update 5.0.0.1986

Post by trinityanderson » Mon May 23, 2022 4:06 pm

Did you ever get a resolution to this issue? I know have the same

LuidgiRanitzki
New here
Posts: 7
Joined: Sun May 09, 2010 10:21 pm

Re: ISCSI error after last update 5.0.0.1986

Post by LuidgiRanitzki » Wed Aug 24, 2022 5:19 am

Hi,

I have the same error here.
Got the same output with the

scsidevadm list_device

command.
Difference: I have
- Model: TS-873AeU-RP
- OS: QTS hero
- Version: h5.0.0.2069

I contacted QNAP Support, hope they help soon. If they can resolve it, I will post the solution here. As the device is new, I was surprised and the problem occured out of a sudden after a reboot --> No backup currently, this was planned next week......

BR,
Georg

LuidgiRanitzki
New here
Posts: 7
Joined: Sun May 09, 2010 10:21 pm

Re: ISCSI error after last update 5.0.0.1986

Post by LuidgiRanitzki » Thu Aug 25, 2022 12:02 am

Updated to h5.0.0.2120 without success to fix the problem... anyone any ideas?

LuidgiRanitzki
New here
Posts: 7
Joined: Sun May 09, 2010 10:21 pm

Re: ISCSI error after last update 5.0.0.1986

Post by LuidgiRanitzki » Sun Sep 18, 2022 4:35 am

Support resolved the problem after a long while.
I am sorry that I cannot post the solution here as it was not described to me even that I asked for it. :(

Post Reply

Return to “iSCSI – Target & Virtual Disk”