Datastore appears empty (can see root folders) in vCenter browser

iSCSI related applications
Post Reply
AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Thu Mar 21, 2019 10:36 pm

Hi, everyone. Using a TVS-463 with vCenter 6.7.

I created an NFS datastore without issue, and initially was able to see all of the files on the datastore using the vCenter browser. I registered 2 VMs using existing files after successfully browsing to them. I come in today and now when I try to browse to the datastore in vCenter, with the exception of the top-level / root folders, it says there are no files/the list is empty when I click on any of the folders. I confirmed on the QNAP itself that everything is intact. All connections appear active and are without error/issue. The problem is that I now cannot power-on the VMs I created from this datastore since it says the VMX file cannot be located (since it cannot see anything). All the file permissions look good within the QNAP and nothing has changed since I initially created the datastore. Any suggestions?

Thank you in advance for your time and help.

EDIT: storageman if you see this I submitted a reply but it is waiting for mod approval. The TVS-463 is on the compatibility list as approved: http://tinyimg.io/i/RwCtUbK.PNG
Last edited by AA27CXP on Thu Mar 21, 2019 11:40 pm, edited 1 time in total.

User avatar
storageman
Experience counts
Posts: 4819
Joined: Thu Sep 22, 2011 10:57 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by storageman » Thu Mar 21, 2019 11:05 pm

I don't see the TVS-463 approved for VMware, do you?

AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Thu Mar 21, 2019 11:31 pm

storageman wrote:
Thu Mar 21, 2019 11:05 pm
I don't see the TVS-463 approved for VMware, do you?
Is this not it?

http://tinyimg.io/i/RwCtUbK.PNG

https://www.vmware.com/resources/compat ... tOrder=Asc

dolbyman
Guru
Posts: 14197
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by dolbyman » Thu Mar 21, 2019 11:40 pm

storageman wrote:
Thu Mar 21, 2019 11:05 pm
I don't see the TVS-463 approved for VMware, do you?
wouldn't that just mean that some hardware functions are unsupported ?

Granted, the only NAS I have so far connected to ESXI via NFS was a 951x (and that one IS VMware approved :oops: )

User avatar
storageman
Experience counts
Posts: 4819
Joined: Thu Sep 22, 2011 10:57 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by storageman » Thu Mar 21, 2019 11:43 pm

Take previous comments back
Approved as TVS-x63 Series but only for ISCSI

User avatar
storageman
Experience counts
Posts: 4819
Joined: Thu Sep 22, 2011 10:57 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by storageman » Fri Mar 22, 2019 12:32 am

What happens when you disabled and enabled the NFS service?

AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Fri Mar 22, 2019 2:36 am

storageman wrote:
Fri Mar 22, 2019 12:32 am
What happens when you disabled and enabled the NFS service?
It has now randomly started working again without issue. I did not change or update anything. However, I am now having an issue adding a new datastore to a different NAS (TS-869 Pro). I keep getting an error that, "The mount request was denied by the NFS server. Check that the export exists and that the client is permitted to mount it."

I can ping/vmkping without issue and Netcat has no errors. I have checked all the settings on this other NAS and they are fine. NFS is enabled and all the permissions are correct within the QNAP GUI for folder sharing. Everything has been static with this one.

dolbyman
Guru
Posts: 14197
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by dolbyman » Fri Mar 22, 2019 2:43 am

what NAS firmware are you running, there was a NFS bug a couple of weeks back

AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Fri Mar 22, 2019 2:51 am

dolbyman wrote:
Fri Mar 22, 2019 2:43 am
what NAS firmware are you running, there was a NFS bug a couple of weeks back
4.3.4.0820 on the TS-869 Pro


AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Fri Mar 22, 2019 3:23 am

Here's the vmkernel.log output when I try to add the datastore:

2019-03-21T19:19:50.102Z cpu3:2100161 opID=5cad05d5)StorageApdHandler: 977: APD Handle Created with lock[StorageApd-0x4312311dd9b0]
2019-03-21T19:19:50.104Z cpu16:2098645)NFS41: NFS41ProcessClusterProbeResult:3875: Reclaiming state, cluster 0x4312311de010 [10]
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)WARNING: NFS41: NFS41FSGetRootFH:4345: Lookup datastore failed for volume QNAP869 NFS (datastore): Not found
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)WARNING: NFS41: NFS41FSCompleteMount:3868: NFS41FSGetRootFH failed: Not found
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)WARNING: NFS41: NFS41FSDoMount:4510: First attempt to mount the filesystem failed: The NFS server denied the mount request
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)WARNING: NFS41: NFS41_FSMount:4807: NFS41FSDoMount failed: The NFS server denied the mount request
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)StorageApdHandler: 1063: Freeing APD handle 0x4312311dd9b0 []
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)StorageApdHandler: 1147: APD Handle freed!
2019-03-21T19:19:50.104Z cpu3:2100161 opID=5cad05d5)WARNING: NFS41: NFS41_VSIMountSet:431: NFS41_FSMount failed: The NFS server denied the mount request

AA27CXP
New here
Posts: 7
Joined: Thu Mar 21, 2019 10:30 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by AA27CXP » Fri Mar 22, 2019 3:37 am

Thanks for linking those. I ran cat /etc/exports and all of my IP address entries appear in there with the proper permissions so it doesn't seem to be the second one. I can try a firmware rollback but am somewhat hesitant to do so in case it causes other issues. Also (and I know they are from different products) the FW versions with the issues referenced in the first link are around 201903xx and mine is back at 201901xx so maybe it wasn't affected? I will consider the rollback though...

I appreciate your time.

User avatar
storageman
Experience counts
Posts: 4819
Joined: Thu Sep 22, 2011 10:57 pm

Re: Datastore appears empty (can see root folders) in vCenter browser

Post by storageman » Tue Mar 26, 2019 5:20 pm

Does it work with ISCSI?
Block will work faster than NFS.

Post Reply

Return to “iSCSI – Target & Virtual Disk”