Creation of file bsed LUNs never finishes ...

iSCSI related applications
aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 3:49 pm

Hi,

I use TS-EC880U with fw version 4.3.4.0675 Build 20180810.
After creation of iSCSI target, the process of adding a file-based LUN never finished (more than 24 hrs).
I miss the options to disable or unmap the LUN in the webGUI, and also miss the option to delete the target.
When I tried to connect from an esxi host, the initiator appeard in the webGUI as connected, but the LUN never showed as device in the vCeneter client.

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Thu Mar 28, 2019 5:12 pm

How big a LUN? In a thin or thick volume?
Block LUNs are best.

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 6:26 pm

I know, but I wanted to try just for test....
The LUN is 200GB, thick provisioned, in the log says that creation completed successfully almost immediately after creation

Information 2019/03/27 10:42:48 admin 192.168.xxx.xxx --- [iSCSI] Start to allocate LUN (LUN_0), capacity = 200 GB ...

Information 2019/03/27 10:42:50 admin 192.168.xxx.xxx --- [iSCSI] Complete the LUN (LUN_0) allocation, capacity = 200 GB.

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Thu Mar 28, 2019 7:17 pm

Hmm, thick is instance
So can you see it in the Qnap GUI?
Screenshot would help, is it just ESXi can't see it?

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 8:17 pm

In the Qnap GUI I see the ip address of the connected initiator and in the esxi I see the target iqn and ip adress, but not the LUN...
You do not have the required permissions to view the files attached to this post.

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Thu Mar 28, 2019 10:06 pm

Does it show same in another browser?
Assuming nothing connected try stop and start the ISCSI service.
Is anything else going on with the volume?

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 10:14 pm

Tried to start and stop ISCSI service several times from webGUI with no effect.
LUNs seem ok from webGUI.
You do not have the required permissions to view the files attached to this post.

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Thu Mar 28, 2019 10:19 pm

Does 10.10.1.99 ping, not using service binding?

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 10:29 pm

Yes!

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Thu Mar 28, 2019 11:06 pm

That's weird. Have you rebooted since?

File LUNs are stored in a directory named .@iscsi.img

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Thu Mar 28, 2019 11:35 pm

I already checked that directory and its empty.
I don't have an option for reboot now, may be tomorrow, but I prefer to do it without reboot, if it is possible

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Fri Mar 29, 2019 2:26 pm

This morning I rebooted the server, but this didn't help either!

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Fri Mar 29, 2019 4:24 pm

And if you delete the target?

aats0123
New here
Posts: 9
Joined: Thu Mar 28, 2019 3:35 pm

Re: Creation of file bsed LUNs never finishes ...

Post by aats0123 » Fri Mar 29, 2019 7:33 pm

I didn't have the option to delete the target - only Deactivate and Modify .
I checked /etc/config/iscsi_trgt.conf and it looked okay - luns were created correct there ...
Finally I used storage_util –-iscsi_restore_cfg and it deleted both luns and targets and cleared the config from iscsi_trgt.conf.

I'm not sure if try to create any targets and luns again how it will be?

User avatar
storageman
Ask me anything
Posts: 5096
Joined: Thu Sep 22, 2011 10:57 pm

Re: Creation of file bsed LUNs never finishes ...

Post by storageman » Fri Mar 29, 2019 7:57 pm

Good fix for others to see !
You can only delete if no LUNs attached and it seemed to think one was there, config got corrupted somehow.
It sounds to me that it created the config entry but failed to write the LUN file (maybe busy/volume issue /who knows)

Post Reply

Return to “iSCSI – Target & Virtual Disk”