QXG-10G1T direct connect tp PC and still very slow

Printers, HDDs, USB/eSATA drives, 3rd-party programs
Post Reply
tryn2lrn@yahoo.com
New here
Posts: 5
Joined: Thu Sep 17, 2020 6:05 am

QXG-10G1T direct connect tp PC and still very slow

Post by tryn2lrn@yahoo.com » Thu Sep 17, 2020 6:33 am

Hello, newbie here (I did a search for help on this and didn't really see any suggestions). I have a TS-453Be and installed the QXG-10G1T card. I have tried 2 different 10Gb cards in my PC direct connected through a CAT7 cable (also multiple cables tried). My large file transfer speed is 180MB/sec. The PC is using SSDs and the QNAP has 2-IRONWOLF drives in RAID 1. The 180MB/sec seems pretty slow to me. I was getting 110MB/sec using the 1Gb ports in the QNAP as was hoping spending the money to upgrade would at least double my throughput. I never expected the crazy numbers people are saying they can get. I tried the standard stuff on the internet, jumbo packets to 9k, disabling offloading on the nic etc. I also ordered another QXG-10G1T card to tryin the PC as well as the QNAP but can't seem to find the drivers for Win10 for the QXG-10G1T. Can anyone offer me some suggestions to try and increase the throughput on the 10Gb link? I tried the Asus 10Gb and the Trendnet 10Gb cards (to my dismay they are exactly the same thing, that was a waste of $$) Thoughts???
Thanks

dolbyman
Guru
Posts: 19727
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QXG-10G1T direct connect tp PC and still very slow

Post by dolbyman » Thu Sep 17, 2020 6:55 am

with just two drives in RAID1, you basically get the sequential speed of a single drive, nothing wrong there

tryn2lrn@yahoo.com
New here
Posts: 5
Joined: Thu Sep 17, 2020 6:05 am

Re: QXG-10G1T direct connect tp PC and still very slow

Post by tryn2lrn@yahoo.com » Thu Sep 17, 2020 7:40 am

So that is normal throughput for a single drive? I found the windows driver for the QXG-10G1T and installed that in the PC and got the same numbers. So it makes sense. I guess the real test would be, if I want to go through the effort, would be to put in an SSD or do the raid0 and see if the numbers go up? Thank you for the input.

dolbyman
Guru
Posts: 19727
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QXG-10G1T direct connect tp PC and still very slow

Post by dolbyman » Thu Sep 17, 2020 7:54 am

check the specs the manufacturer gives ..should be 180-200MB/s read

dont do raid0 .. one *blip* and all data is gone

get one or two more hdd and do a raid5

tryn2lrn@yahoo.com
New here
Posts: 5
Joined: Thu Sep 17, 2020 6:05 am

Re: QXG-10G1T direct connect tp PC and still very slow

Post by tryn2lrn@yahoo.com » Thu Sep 17, 2020 8:02 am

SO here is something I just noticed in the fine print of the TS-453BE specification:
"Slot 1: PCIe Gen 2 x2
PCIe bandwidth limitations will restrict the NAS 10GbE performance."
Does that mean that since, from I read, that 10Gb requires minimum PCIe 2.0 x4 slot that the TS-453Be is already down to 5Gb max due to the x2 slot?

tryn2lrn@yahoo.com
New here
Posts: 5
Joined: Thu Sep 17, 2020 6:05 am

Re: QXG-10G1T direct connect tp PC and still very slow

Post by tryn2lrn@yahoo.com » Thu Sep 17, 2020 8:13 am

Yes understood, I wouldn't keep raid0 just a test. Also, I didn't mention the 180MB/s is write speed to the NAS. I didn't test read speed as I really only care about the write speed. It is an odd setup I am doing. I have another TS-453Be with 4 drives in it as my network NAS. This new one is a seperate one to dump all my camera files to. I guess I should be happy that I got a 50% speed increase in moving the files. Will have to see how the system works for a while before I have to drop another $250 for more drives again. One last question you say to "check the specs the manufacturer gives ..should be 180-200MB/s read", do you mean the IRONWOLF drive read specs? Thank you

tryn2lrn@yahoo.com
New here
Posts: 5
Joined: Thu Sep 17, 2020 6:05 am

Re: QXG-10G1T direct connect tp PC and still very slow

Post by tryn2lrn@yahoo.com » Thu Sep 17, 2020 8:26 am

You are absolutely correct, I should have researched further. Just read a real world review and that drive showed 185MB/s windows copy and 189MB/s CrystalDiskMark. Sorry for wasting your time. I should know better.
Thanks again for you time.

Bob Zelin
Been there, done that
Posts: 885
Joined: Mon Nov 21, 2016 12:55 am
Location: Orlando, FL.
Contact:

Re: QXG-10G1T direct connect tp PC and still very slow

Post by Bob Zelin » Fri Sep 18, 2020 12:21 am

put in all 4 drives, create a single static RAID 5 volume, and guess what - your speeds will be dramatically increased.
Bob Zelin
Bob Zelin / Rescue 1, Inc.
http://www.bobzelin.com

Post Reply

Return to “Hardware & Software Compatibility”