All files tagged as "hidden system files"!!?

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
New here
Posts: 3
Joined: Fri Oct 05, 2007 3:22 pm

All files tagged as "hidden system files"!!?

Post by furwed » Thu Nov 01, 2007 11:39 pm

Dear Qnap,

I recently copied a large number of files from the external USB connector to a share on my TS-209 pro using local replication. All fine!

I then moved all the folders to a new location using Windows Explorer and after that all files was gone! Well, not quite but it had tagged all the files as hidden system files (the same as c:\windows files are as default)!!

Ok, if I toggled the "display hidden system files" option, I did see all files again but how did this happen? And most of all, how do I get it right again??

Please help me out here!

New here
Posts: 3
Joined: Fri Oct 05, 2007 3:22 pm

Post by furwed » Mon Nov 05, 2007 3:35 am

Hello again!

Ok, I can see all the files if I use the "display hidden system files" option, but when I copy a file to another location or disk the flag follows with it and it could not be reset!

Please, could you help reseting my files back to "normal"?


Know my way around
Posts: 131
Joined: Thu Oct 11, 2007 4:18 am
Location: Holstebro, Denmark

Similar problem

Post by L3kris » Tue Nov 06, 2007 4:43 am

Not trying to hijack the thread, but this may either be helping or not:

I'm having a similar problem: I copied a number of files onto the Public share and now they're all write protected. And not only the files but also the folders. Using Explorer I cannot create new files nor delete them. Using web file manager, I can delete them.
All this only became a problem a few days ago - I think after reinstalling Windows XP on one of my PCs - however my other PC with Vista on it has the same problem.

Getting the hang of things
Posts: 81
Joined: Sat Oct 27, 2007 10:23 pm

Post by APS » Wed Nov 07, 2007 1:47 am

hey furwed,

Sorry I see this so late, hope I am not too late and that you didn't get rid of your precious files....

Anyways,.. I'm not sure what happened but it seems that somehow the attributes for the files have changed into "system" files (hope I understood that right). I can't reproduce this right now with the Qnap,... but I have seen it happen before with a customer that used FTP to change rights for files/folders on a Linux server.

What you have to do is (and I hope this helps), remove all the attributes for the files. I have not been able to do that on Linux back then, but.... you can do it on Windows (XP, not sure about other versions). Read everything below first before you do it. Here's what I did :

1.- made sure that system files were shown (you know how to do this)

2. -I copied all the folders, using a windows explorer, to the XP machine. You may want to do this to a folder directly in C: (for example "c:\iamlost").

3.- open a cmd -->> (Start/run, and type "cmd", press enter)

4.- cd to the directory where you copied the files to (example : cd c:\iamlost

5.- next we have to get rid off all the attributes; type "attrib -R -A -S -H /S /D"

What you just did in step 5 is; you removed the file AND folder attributes -R (readonly), -A(archive), -S(system file,.. this is the one that's probably been bugging you), -H(hidden). The /S and /D are there to make sure you also process all sub-files and sub-folders. You should be able to make any changes to rights and visibilities again using the "normal" windows methodes now.

I hope this is helpful for you. I only had to use this twice so I'm hoping I didn't forget something,.. have to do this from memory,... and mine's affect by a few beers at the moment :? Good luck!

New here
Posts: 3
Joined: Fri Oct 05, 2007 3:22 pm

Post by furwed » Thu Nov 08, 2007 9:33 pm

Dear APS,
Thank you very much for your suggestion! It made the trick! :-)

I did try the good old fashion 'Attrib' command my self, but I did not use the /D option. That's the secret!

Thanks a lot!


User avatar
Know my way around
Posts: 166
Joined: Thu Nov 08, 2007 8:03 pm

Post by raffe » Thu Nov 08, 2007 10:00 pm


I have a similar problem. What I did:
1. Connected a external USB hard drive to the back of Qnap TS-209 Version 1.1.2 build 1012T
2. SSH with putty to Qnap as admin
3. I do a cp -r /share/USB Disk 1/* /share/Public/Filer
4. I wait for 200 GB to copy to Qnap
5. All files and directories in /share/Public/Filer are now read only, hidden and system files, if I connect to the shared folder with Windows XP.
6. I tried to do a chown guest.guest on all the files, but still same problem
7. I tried to do a chmod 777 on all the files, but still same problem

a) If I connect the USB to a Windows PC the files and directories are NOT read only, hidden and system files

b) If I now do a attrib från Win XP on the shared folder I get:

Code: Select all

A  SH      Z:\Filer\2006_0803_142828AA_web.jpg
A  SH      Z:\Filer\
A          Z:\Filer\attrib.txt
A  SH      Z:\Filer\Thumbs.db
A  SH      Z:\Filer\backup-xcopy.bat
A  SH      Z:\Filer\testping.bat

c) If I do a ls -la on the Qnap on the same folder I get:

Code: Select all

-rwxrwxrwx    1 guest    guest       84990 Nov  7 22:43 2006_0803_142828AA_web.jpg*
-rwxrwxrwx    1 guest    guest      305596 Nov  8 01:26*
-rwxrwxrwx    1 guest    guest        9216 Nov  8 01:27 Thumbs.db*
-rwxr--r--    1 admin    administ      217 Nov  8 07:49 attrib.txt*
-rwxrwxrwx    1 guest    guest         123 Nov  8 03:50 backup-xcopy.bat*
-rw-r--r--    1 admin    administ        0 Nov  8 07:51 ls.txt
-rwxrwxrwx    1 guest    guest          22 Nov  8 03:50 testping.bat*

d) The file ls.txt was done with ls -la > ls.txt as admin and attrib.txt was done from windows with attrib > attrib.txt. These two files are NOT problem files with read only, hidden and system files. These two are OK. Only the ones I copied has the problem.

e) If I remember right, the other files also had "-rwxr--r-- 1 admin administ" before my chown and chmod.

f) I have tried to do attrib -s, but Windows says it can't do that

g) I have tried to right click on files, but system files is greyed out (can not change it)

So, what can I try? On the External hard drive I have the right flags, so I could try the same copy againg, but logically I should get the same problem. Or? And I would like to be able to do a cp and not copy thrue Win XP (I have only wireless, so it will take loooong time). Any ideas :roll:

Getting the hang of things
Posts: 81
Joined: Sat Oct 27, 2007 10:23 pm

Post by APS » Thu Nov 08, 2007 11:34 pm

@ furwed

I'm glad it did the trick for you,.. I know how frustrating this can be :wink:

@ raffe

Windows will not be able to change the attribs of a file that it has no access to. You will have to try to use the "-s" in combination with the "-r" and "-h". I don't think the "-a" (archive) is important here. make sure you think logically about this;

- the file has to be write enabled first before you can change anything, so set the "-r" option first.
- I have found that without the "-h" Windows had issues in some cases with finding the files. That would have to be the second attrib to change (or third if you want to change the archive attrib)
- last should be the "-s" option

I have not tried to access a remote USB drive through the cmd before but you could set it up as a network drive in Windows, then open a cmd and try to access through it's drive letter. But it will have to e done through a cmd.

You can find the network drive share wizard in the Windows Explorer. It's under the top menu "tools". I haven't tried if this works but I think it is your best shot if you aren't looking forward to copying all your data across a wireless connection.

It seems these problems occur when file access/rights have been changed through FTP on the Qnaps' end. If the NAS is used in a Windows network,.. I think it would be better to only use the Qnap to set up toplevel shares, and all the underlaying folder structure in Windows. I hope someone can confirm this.[/quote]

User avatar
Know my way around
Posts: 166
Joined: Thu Nov 08, 2007 8:03 pm

Post by raffe » Fri Nov 09, 2007 3:40 am

I now think I know why I had the problem.

1. On Qnap thrue SSH I did a ln -s /share/USB\ Disk 1 /share/Public/USB1
2. On Win XP I connected as admin+password Z to \\\USB Disk 1
3. On Win XP I connected as admin+password Y to \\\Public

a) If I on the PC go to Z:\ the files are SR (read only and system files, but not hidden)
b) If I on the PC go to Y:\USB1\ the files are SHR (read only, hidden and system files).
c) If I on the Qnap do a ls -la /share/Public/USB1 the files are -r-xr-xr-x 2 admin administ.

So it seems like the mounting of the USB hard drive on the Qnap is making this problem (even if the files on the USB HD are normal read/write)

To be able to internally with SSH copy from USB hard disk to Qnap there should be a way to;
a) connect the USB hard drive as read/write
b) or set the permissions after the copy (in Qnap linux) so Windows see the files as normal read/write.

We need to figure out how to do the mounting and/or the permission setting after copying :?

User avatar
Know my way around
Posts: 166
Joined: Thu Nov 08, 2007 8:03 pm

Post by raffe » Fri Nov 09, 2007 6:53 am

OK, all this is so strange :shock:

1. I updated to Version 1.1.3 build 1101T and rebooted the Qnap
2. Then on Win XP I connected Y to \\\Public
3. On Win XP with cmd I did a

Code: Select all

cd filer
attrib /s /d -s -h -r *.*

4. And now it suddenly works (last time I got 'Not resetting hidden/system file') :?

But, never mind, now I'm happy :P
Thanks for all your help :!:

New here
Posts: 8
Joined: Tue Nov 13, 2007 9:04 pm
Location: The Netherlands

Post by Force » Sun Nov 18, 2007 11:39 pm

Ok let me explain some things:

Samba uses the execute bit of the file to flag it Archive, Hidden & System.
(Samba never has to execute files only read/write & delete)

So: 666 - Normal file
766 - Flagged in MSWindows as Archive
676 - Flagged in MSWindows as System
667 - Flagged in MSWindows as Hidden

The Samba default is 766 (if you copy a file from Windows to Linux through Samba).
But if you copy files in Linux or use the chmod to change rights you could end up in the situation that you see all the files as System and/or Hidden in Windows.
Note: If you use mldonkey then watch out not to change the file creation rights to 777 in the "downloads.ini" or all your downloaded files will show up as hidden & system in Windows.

To fix these problem: Log in with SSH, go to the directory which has the hidden and/or system files, and change the rights with "chmod -R 766 *".

Hope this helps,

New here
Posts: 7
Joined: Sun Dec 16, 2007 6:34 pm

Post by XIII2007 » Sun Dec 16, 2007 6:46 pm


I find solution for flag Hidden & System.
If you want chmod 777 in your files and no flag hidden & system in windows, you do modify smb.conf in Qnap :

- Activate telnet in administration interface
- Open a command and write telnet ip_qnap 13131 and loggin
- Write cd /mnt/HDA_ROOT/.config
- write vi smb.conf
- modify value map system = no and map hidden = no
- save
- On administration interface restart windows share.

Sorry for my english...


Starting out
Posts: 22
Joined: Fri Mar 21, 2008 7:01 am

Re: All files tagged as "hidden system files"!!?

Post by interested » Fri Apr 04, 2008 10:37 pm

I have the same problem.
I posted my issue in the Miscellaneous forum here:

From the date of the original post it would look like this problem has been around for quite some time.
Would be nice if Qnap would fix this issue so that i can use the one touch backup button feature with an external drive, without my files attributes getting changed to a hidden system state.

User avatar
Been there, done that
Posts: 516
Joined: Thu Dec 27, 2007 7:32 pm
Location: Sweden

Re: All files tagged as "hidden system files"!!?

Post by lentzit » Sat May 03, 2008 7:38 pm

Got the same problems here on my Ts209 with latest firmware. Dont know if you solved that problem so i write an answer for those who have the same problem.

To see all the files that are copied to an external drive you have to unhide all files via Tools and Folder Options.

To set new attributes, start the console with Start/Run and type cmd followed by clicking Enter
Go to the drive holding your data (ie. D:)
type attrib -s -h *.* /S /D ( think it was something like that)
Wait until ready Finished

I use robocopy for backup instead, it all can be run from a cmd file and started with windows scheduler tool. (
-TVS-663/16GB QTS 4.2 , RAID5
-QGenie QG-103N - Wireless Storage in Classroom Environment
-Services: WEB | Virtual Station | QSYNC | FTP | SSL | Private Cloud | Photo Station
-Using it for my blog (

Starting out
Posts: 17
Joined: Mon Dec 17, 2007 7:37 am

Re: All files tagged as "hidden system files"!!?

Post by nickcx » Tue May 06, 2008 9:15 pm


EXACTLY the same problems here, too! Previously, I used to 'CHOWN -R guest' a folder within QMultimedia to allow anyone access to it (I'm not bothered about security for this folder). However... after a copy from USB to the QUsb and subsequent move to the folder in question, ALL my files within subfolders are now hidden system files. The only way to get around it is to CHMOD 766 ./* each sub folder. -R doesn't work from further up, so as you can imagine this is a HUGE b*ll ache to rectify. No matter what permissions I assign to the root of the mail folder (recursively or no), I still have to go into each folder and CHMOD..

Oh, and Attrib-h won't work even if it's 777 all the way!

Any help gratefully received.


Getting the hang of things
Posts: 87
Joined: Mon Sep 24, 2007 10:08 am

Re: All files tagged as "hidden system files"!!?

Post by Subw00er » Wed May 07, 2008 9:51 pm

I have the same exact problem on my ts-209. I am not able to erase files or directories because they are permanently set as read only or archive.


We shouldn't have to go through this chmod **. It should just work. I bought the drive to store my terrabyte of data. I dont have a drive big enough to copy it to on my pc. I dont have the time to waste learning how to change permissions and user putty or whatever. This is Qnap's problem, not mine.

Qnap, please release a fix for this immediately. You go on creating new boxes like the 409 and your security boxes, but you have major problems with the ones you already have out there, like the 209. I'm telling you, this sort of thing will seriously hurt your reputation and I've already recommended to others to buy something else. I personally wont buy another qnap product until this is fixed - this coming from a guy who owns a 209, 209pro, 201, and a 409. I've stopped our order on the security box until you show you support your products like the 209.

Get on it! Its been months since this problem arose for me and I'm very annoyed by it. I mean, how hard is it? Copy the file over, and dont change its permissions. This is simple stuff.

I'm sorry about my aggressive post, but this problem has gone on too long, especially when qnap is so passive about the fix. Did they even reply to this thread?


Return to “File Sharing”