All files tagged as "hidden system files"!!?

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
User avatar
silas
Moderator
Posts: 1376
Joined: Sun Sep 09, 2007 6:59 am
Location: Poland
Contact:

Re: All files tagged as "hidden system files"!!?

Post by silas » Wed May 07, 2008 11:47 pm

I suppose You are using Windows XP...

I've just crated directory with all attributes +rahs and I copied it to Public folder. Now I've tried to delete it... and folder is deleted normally. I'm using Windows Vista x64.

I will ask You for something... Are You sure You are logged on NAS with "admin" user ? - just simple question because I cannot reproduce Your problem.

Subw00er
Getting the hang of things
Posts: 87
Joined: Mon Sep 24, 2007 10:08 am

Re: All files tagged as "hidden system files"!!?

Post by Subw00er » Thu May 08, 2008 1:29 am

Me? Yes, I am using admin. It seems like people either have this issue or dont.

Could this possibly be related to torrent downloads? Is it something to do with the way files are copied via a bittorrent transfer?

User avatar
silas
Moderator
Posts: 1376
Joined: Sun Sep 09, 2007 6:59 am
Location: Poland
Contact:

Re: All files tagged as "hidden system files"!!?

Post by silas » Thu May 08, 2008 6:50 am

no ... but i know about one issue with not possibility to delete files
users with rtorrent are unable sometimes to delete downloaded torrents
but this can be fixed by chmod command typed from shell

nickcx
Starting out
Posts: 17
Joined: Mon Dec 17, 2007 7:37 am

Re: All files tagged as "hidden system files"!!?

Post by nickcx » Thu May 15, 2008 4:52 pm

I have tried the following as suggested in this post as it has worked for me. However, I want to know what implications this has for my 209. Not being a linux man, I don't really undestand what I did... and a little bit of knowledge can be a danagerous thing:

Start Telnet and login as admin
At the prompt type: cd /mnt/HDA_ROOT/.config
The type: vi smb.conf
This will load the smb.conf file
Press i to allow editting
Locate the two variables map system = yes and map hidden = yes and change yes to no
Press Escape
Type :wq
You will then be returned to the /mnt/HDA_ROOT/.config prompt
Type reboot
Wait whilst your NAS reboots
Refresh you Windows Explorer and you should see the files.

Like I say, this worked for me and I hope it does for you. It seems a bit of a botch job, so I would really like to hear from QNAP why this has happened and what they can suggest to help their loyal customers.

Cheers,
Nickcx

happyguy
Getting the hang of things
Posts: 71
Joined: Wed Jan 16, 2008 12:18 am
Location: United States

Re: All files tagged as "hidden system files"!!?

Post by happyguy » Fri May 16, 2008 7:45 am

XIII2007 & nickcx are correct, you need to edit the smb.conf file to fix this so it doesn't keep re-occuring with every new file on the QNAP. I had to do this on my TS-209 Pro back in November/December, worked fine since then. (at the time I was trying to do something else with the conf file & found this issue while doing so)

I'm curious if that's how Linux sets up the smb.conf file by default, or if that's QNAP's default configuration.
--------------------
TS-209 Pro
FW 2.1.0 build 0904T
2x Seagate ST3750640AS 3.AA 750 GB (RAID 1)

nickcx
Starting out
Posts: 17
Joined: Mon Dec 17, 2007 7:37 am

Re: All files tagged as "hidden system files"!!?

Post by nickcx » Wed May 21, 2008 2:56 pm

Update: After 'fixing' the problem, I have found that I cannot view any images/thumbnails within Multimedia Station! Has anyone else seen this?

I'm going to log this with QNAP for help, so will keep you posted.

johannlo
Starting out
Posts: 30
Joined: Sat Jun 14, 2008 8:25 am

Re: All files tagged as "hidden system files"!!?

Post by johannlo » Sun Jun 15, 2008 10:43 pm

Thanks so much for these tips. Saved me from tearing my hair out.

And no, those options are not on in a default Red Hat install. Definitely one for the notebook

wherethebibawi
New here
Posts: 8
Joined: Tue Jun 24, 2008 6:07 pm

Re: All files tagged as "hidden system files"!!?

Post by wherethebibawi » Tue Jun 24, 2008 6:47 pm

Hi I have this problem, all I did was copy my files using the Qusb button and then moved the files using the web file manager. I read through your posts but I am not savvy enough with linux to putty in through the back door. When I attempt to do a -R-A-S-H /D/S in Command line of windows I recieve an access denied message. So I cannot change access permissions on my files either, in the Windows XP gui the hidden attribute is totally disabled, like it was an administrator restriction.

Please HELP!

happyguy
Getting the hang of things
Posts: 71
Joined: Wed Jan 16, 2008 12:18 am
Location: United States

Re: All files tagged as "hidden system files"!!?

Post by happyguy » Tue Jun 24, 2008 9:58 pm

wherethebibawi wrote:When I attempt to do a -R-A-S-H /D/S in Command line of windows I recieve an access denied message. So I cannot change access permissions on my files either, in the Windows XP gui the hidden attribute is totally disabled, like it was an administrator restriction.


For the record, you can't do this through Windows, needs to be done in the QNAP itself..which means SSHing into its Linux shell (via Putty or whatever). I don't think there's another way to do it, unless someone else knows.
--------------------
TS-209 Pro
FW 2.1.0 build 0904T
2x Seagate ST3750640AS 3.AA 750 GB (RAID 1)

gates668
New here
Posts: 5
Joined: Mon Sep 08, 2008 5:51 am

Re: All files tagged as "hidden system files"!!?

Post by gates668 » Sat Sep 13, 2008 8:32 am

I find the easiest way to fix this is to fire up WinSCP, browse to the main folder you just copied, right click and select properties. Then set the following:
Group: guest
Owner: guest
Permisions: 0666
Check: Add X to directories
Check: Set group, owner and permissions recursively
Click: Apply

This gives full access to everyone and I can see the files in both XP and WinSCP. My TS-409 is just a media share for my local network so full access works for me.

I hope this helps. I mucked with it at first and got confused on the group/owner stuff because copying stuff from the USB drive gives it a funky owner/group. WinSCP works great for that direct copying from USB as well to keep it from going through the network.

gates668

User avatar
stevebow
Been there, done that
Posts: 626
Joined: Mon Apr 07, 2008 11:46 am

Re: All files tagged as "hidden system files"!!?

Post by stevebow » Sun Sep 14, 2008 2:38 am

The file attributes as seen by Windows are equivalent to these chmod permissions:

Code: Select all

R – Read only    **-*******
A – Archive      ***x******
S – System       ******x***
H – Hidden       *********x

if that makes sense...
NAS: TS-509 Pro
Firmware: 4.1.1 Build1101
Drives: 5 x Western Digital WD20EFRX (Red) 2TB drives (RAID5)

NAS: TS-409 Pro
Firmware: 3.3.2 build 0918T
Drives: 4 x Western Digital WD20EFRX (Red) 2TB drives (RAID0)
Note: TS-409 Disk Management GUI mostly non-functional with WD Red HDDs

amarden
Starting out
Posts: 13
Joined: Tue Sep 16, 2008 10:04 pm

Re: All files tagged as "hidden system files"!!?

Post by amarden » Tue Sep 16, 2008 10:46 pm

This drove me nuts too. I set up my new NAS-409 pro and immediately copied my files over from a Vista PC. Everything seemed OK - but when another user (logging in to the NAS with a different username) tried to save/create/delete files, they couldn't - but only some files in some directories.

This is what I found:

1. When you copy over files from a PC, it copies across Windows permissions, or rather, it translates them into something that it thinks is a close match. Now, many of my files had got a mix of permissions over the years, and it ended up being a total mess on the NAS.

2. First attempt to fix, since I understood that all access on the NAS is controlled via the shares and not the file permissions was to run: chmod -R 777 * in the top of that share after logging in via telnet. What could be wrong with that? Give permissions on everything to everyone and then have it masked by the share permissions as appropriate. But then all of my files disappeared! Or so I thought - they've just diappeared from view on the PC. Playing with the permissions, I discovered what the previous poster says that wx being set makes the file hidden. So if I restrict the filesystem permissions on the file, I make the file more visible. Well that's obvious isn't it? Now the problem is to change only the files and not teh directories. The QNAP has a very slimmed down version of the find command installed which means you can't trawl through the directory structure, select only the files and run a chmod on these.

3. Luckily, I still had the original files on a local drive, so I took ownership of all files in the folder tree and changed the permissions to say only; Everyone: Full Access. Then I copied the whole lot over again. I guess uploading via FTP would also work OK.

Needless to say, I think there should be a big warning sign in red somewhere which says CHECK THE WINDOWS PERMISSIONS BEFORE YOU COPY STUFF OVER OR YOU'LL BE SCREWED somewhere prominently on the box / quick start guide. Or better still, since the file system permissions are irrelevant, make sure the NAS resets them on all file uploads, however done [QNAP person please take note]. There are so many threads on this forum where people seem to have hit the problem and there is no way in the world that they are going to be able to work all of this out if they are not Linux command-line savvy (let's face it, the idea of a NAS box is to make storing files a simple plug and play operation, not an exercise in advanced system administration).

As for the wx permissions thing, I assume that is not a QNAP thing but perhaps a Sambe 'feature' - for this to make any sense, it needs to totally unnecessray to go onto the box and mess with the files which, at the moment, it's not.

Hopefully, I'll be able to rely on the NAS now.

Cheers
Andy

manpete
New here
Posts: 8
Joined: Wed Dec 10, 2008 4:52 am

Re:

Post by manpete » Thu Dec 11, 2008 4:51 am

Force wrote:Ok let me explain some things:

[...]

Hope this helps


Yes, it did quite well. I converted the files on my former Syno DS207 to my new Qnap TS509 using the following method:

1) Install NFS on the Syno
2) Telnet to the Qnap
3) Mount the share
4) Copy the content to Qmultimedia/[categorydir]. I used -P to preserve the timestamp. (The Qnap changed all timestamps with one hour - not a big deal).
5) Umount the share
6) Switch of the Syno and sell it as used gear

All directories were there, but all the files seemed to have gone into oblivion. I already guessed I needed to chmod the stuff, but couldn't find the correct mode. Your explanation made me see the light. Now all my files are back, visible and usable.

Now I can safely take the two 1TB drives out of the Syno and tell the Qnap to migrate to Raid 5. Yeah!

Any poor fellow interested in a Syno 207 with 2x500Gb? :wink:

Eraser-EMC2-
Been there, done that
Posts: 711
Joined: Sat Oct 13, 2007 5:26 pm
Location: Germany

Re: All files tagged as "hidden system files"!!?

Post by Eraser-EMC2- » Fri Dec 12, 2008 3:55 am

you can do also a

Code: Select all

chmod -R -x+X *
on Linux

-x remove the Execute-Bits for Files and
+X set the Execute-Bits for Folders

The Execute-Bit for folders is for show (+X) or hide (-X) all files and subfolders.
_________________
Windows 7 32/64bit, German
TS-439 , 1x 512GB SSD/1x 512GB Samsung ; SAMBA as NT4 PDC, DHCP/DNS-Server
TS-431+, 1x 1TB WD green, 2x 3TB WD red , 1x 2TB Samsung
TS-220 , 2x 2TB Samsung, for Backup

Force
New here
Posts: 8
Joined: Tue Nov 13, 2007 9:04 pm
Location: The Netherlands

Re: All files tagged as "hidden system files"!!?

Post by Force » Mon Dec 15, 2008 7:19 am

I wrote a little script to set the rights:
Create a file e.g. setrights.sh and copy and paste the lines below.
then run the script from the (linux) command line with "setrights dirname"

Regards,
Force
------------------------------------------------------------------------------

#!/bin/sh
#
# script name : setrights
#
# purpose : Set rights of all files to 766 and all dirs to 777 (recursive)
# author : Force
# date : 2008/12/15
#
if [ $# -eq 1 ]
then
chmod -R a+rw $1
chmod -R a-x $1
chmod -R g+X,o+X,u+x $1
fi

Post Reply

Return to “File Sharing”