All files tagged as "hidden system files"!!?

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
Desmodromic
Starting out
Posts: 20
Joined: Sat Jan 10, 2009 6:28 am

Re: All files tagged as "hidden system files"!!?

Post by Desmodromic » Sun Feb 08, 2009 6:40 am

Hi Force,

I am a little bit noobish to Linux.

I created a file using notepad with the content you mentioned and gave it the right name.

Then I ftp'ed it to the NAS server, to the folder with the hidden content (and visible folders).

When I execute the file, nothing happens.

Could you tell me what I am doing wrong, or could you give a step-by-step description of the right procedure?

Many thanks in advance!

Desmodromic
Starting out
Posts: 20
Joined: Sat Jan 10, 2009 6:28 am

Re: All files tagged as "hidden system files"!!?

Post by Desmodromic » Sun Feb 08, 2009 9:07 pm

I think I found the reason your script did not execute well.

I noticed that I use spaces in the folder names. Linux doesn't seem to like that, so that could explain the problem.

I am renaming the folder names in order to remove the spaces in the titles.

Do you have a tool for that? ;)

Eraser-EMC2-
Been there, done that
Posts: 711
Joined: Sat Oct 13, 2007 5:26 pm
Location: Germany

Re: All files tagged as "hidden system files"!!?

Post by Eraser-EMC2- » Sun Feb 08, 2009 10:00 pm

For folders with spaces inside, it helps to put " outside of $1 like that :

Force wrote:------------------------------------------------------------------------------

#!/bin/sh
#
# script name : setrights
#
# purpose : Set rights of all files to 766 and all dirs to 777 (recursive)
# author : Force
# date : 2008/12/15
#
if [ $# -eq 1 ]
then
chmod -R a+rw "$1"
chmod -R a-x "$1"
chmod -R g+X,o+X,u+x "$1"
fi
_________________
Windows 7 32/64bit, German
TS-439 , 1x 512GB SSD/1x 512GB Samsung ; SAMBA as NT4 PDC, DHCP/DNS-Server
TS-431+, 1x 1TB WD green, 2x 3TB WD red , 1x 2TB Samsung
TS-220 , 2x 2TB Samsung, for Backup

jinaun
Starting out
Posts: 27
Joined: Sat Jun 13, 2009 12:13 pm

Re: All files tagged as "hidden system files"!!?

Post by jinaun » Thu Jun 18, 2009 12:11 am

i'm using FW 2.1.6 and this issue still happens.. on my brand new 239

the workaround that i found helpful in this forum is editing the samba config file..which so far seems to be working and chmod the files so the files will be visible

i'm i right to expect this issue be resolved in the next FW release? or it will not happen?

Desmodromic
Starting out
Posts: 20
Joined: Sat Jan 10, 2009 6:28 am

Re: All files tagged as "hidden system files"!!?

Post by Desmodromic » Sat Jul 18, 2009 9:28 pm

As a noobian I'd like to share a lesson learned with anyone who experiences the 'hidden XP files' problem and uses the setrights script.

I had some problems getting the script to run correctly, but I finally managed!

I solved my problem as follows:
1. Copy the setrights.sh script to the right folder (in my case it is /share/Qmultimedia/MyMusic).
2. Make sure you are in the right folder (execute for example: cd /share/Qmultimedia/MyMusic/ ).
3. Execute the following command from shell: /share/Qmultimedia/MyMusic/setrights.sh . (don't forget the '.' at the end! That is what solved my problem ;) ).
4. Wait until the scipt is finished.
5. Your files are now nicely visible for XP! Without having to use the (IMHO) quick and dirty solution to make protected files visible under XP.

I hope this helps!

Note: many thanks to Eraser-EMC2 for sharing the script he wrote!

User avatar
QNAPRobert
Starting out
Posts: 22
Joined: Wed Apr 08, 2009 1:12 pm
Location: TeletubbyLand!

Re: All files tagged as "hidden system files"!!?

Post by QNAPRobert » Sat Aug 01, 2009 8:53 am

Hi,all:
There's a system script that might come handy :

Code: Select all

/sbin/set_volume_mode <Share_Folder_name>


the share folder must be on root folder level,that is : on the share folder list in the Web administration GUI.

eg.
/sbin/set_volume_mode Public
would set all the folders mode and files mode back to QNAP default.

*Thanks Lee Buskey of U.S.A. informed me and all your efforts.

dreken
New here
Posts: 2
Joined: Fri Aug 15, 2008 5:09 pm

Re: All files tagged as "hidden system files"!!?

Post by dreken » Sun Dec 13, 2009 7:16 pm

WONDERFUL! This litte feature just made my day!

lifeisfun
Know my way around
Posts: 128
Joined: Sun Nov 30, 2008 5:09 am

Re: All files tagged as "hidden system files"!!?

Post by lifeisfun » Wed Jan 13, 2010 6:43 pm

I have similar problem with my 509
some avi files copied long time ago from external drive are set as hidden but there is no way
from windows to change it since that option is grayed out.
My folder structure is that each avi is in it's individual folder
(about 1000 of them and only about 100 having this problem )

Can you guys PLEASE help me with instructions what to do. I'm fine with windows
but never used Linux. :oops:

Thanks

lifeisfun
Know my way around
Posts: 128
Joined: Sun Nov 30, 2008 5:09 am

Re: All files tagged as "hidden system files"!!?

Post by lifeisfun » Thu Jan 14, 2010 6:35 am


Dropnuts
Getting the hang of things
Posts: 70
Joined: Sat Oct 31, 2009 2:09 pm
Location: Australia

Re: All files tagged as "hidden system files"!!?

Post by Dropnuts » Mon Jan 18, 2010 1:06 pm

QNAPRobert wrote:Hi,all:
There's a system script that might come handy :

Code: Select all

/sbin/set_volume_mode <Share_Folder_name>


the share folder must be on root folder level,that is : on the share folder list in the Web administration GUI.

eg.
/sbin/set_volume_mode Public
would set all the folders mode and files mode back to QNAP default.

*Thanks Lee Buskey of U.S.A. informed me and all your efforts.


I know this is an old thread, but this advice was working nicely for me.

But since a system reboot this script produces the output:
[~] # /sbin/set_volume_mode /share/Qmultimedia/
Volume: /share/Qmultimedia/
Path: Can't find it in /etc/smb.conf


Any idea why?
[TS-509] - E7600 C2D CPU, TS-809 firmware on 16GB SSD DOM

User avatar
schumaku
Guru
Posts: 43673
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: All files tagged as "hidden system files"!!?

Post by schumaku » Mon Jan 18, 2010 9:16 pm

Just use the share name, instead of tha share path:

Code: Select all

[~] # /sbin/set_volume_mode /share/Qmultimedia/
Volume: /share/Qmultimedia/
Path: Can't find it in /etc/smb.conf

[~] # /sbin/set_volume_mode Qmultimedia
Volume: Qmultimedia
Path: /share/HDA_DATA/Qmultimedia
Set directory mode to 777 and file mode to 666


-Kurt.

Dropnuts
Getting the hang of things
Posts: 70
Joined: Sat Oct 31, 2009 2:09 pm
Location: Australia

Re: All files tagged as "hidden system files"!!?

Post by Dropnuts » Tue Jan 19, 2010 8:56 am

Thanks for that. Worked a treat. I'm sure it used to work the other way before. Might be imagining things though.
[TS-509] - E7600 C2D CPU, TS-809 firmware on 16GB SSD DOM

Domini0n
Getting the hang of things
Posts: 93
Joined: Thu Nov 19, 2009 8:28 pm

Re: All files tagged as "hidden system files"!!?

Post by Domini0n » Sun May 23, 2010 1:03 am

NICE!

Had this problem for a while... Also posted on the subject, as at first glance this problem was different from mine, but it was not.
viewtopic.php?f=185&t=30203

I do have a few questions:
1) If i create a folder, then the folder is read_only, is this normal?
2) Files i create have owner admin:administrator where I would expect it to have admin:everyone. I expect this as "admin" is the user I'm logged in with and I expect "everyone" as files created on the NAS should be accessible by all users that log in with an account that has access rights to that share. Is this assumption correct or not? If not could someone try to explain this to me?
3) Some files are green when I look them up with putty, what does that mean? It also has an asterisk symbol at the end of the file name extension.

At least I'm able to access my files, safely again. NFS has been nothing but a nightmare for me as it crewed up all permission and no matter what I did, it kept having issues with programs like rTorrent++. Now testing to see what happens with smb, but it looks like those problems are gone as well.
Here is were I discussed by rTorrent++ problems: viewtopic.php?f=146&t=29219
Current NAS:
QNAP TS-469L (Huge performance increasement with everything compared to TS-419P)
Western Digital Red 3TB NAS HDD's x 4 (WD30EFRX) (Extremely quiet & fast | Runs in RAID5)
Kingston 2GB DDR3 SODIMM 1333MHz (PC3-10600) CL9 x 1 (KVR1333D3S8S9/2G) (Results in a total of 3GB DDR3 memory)

Old NAS:
QNAP TS-419P (To slow to handle multiple things at the same time)
Samsung EcoGreen F2 1.5TB x 4 (HD154UI) (Noisy compared to the WD Red 3TB | Ran in RAID5)

SamTHorn
New here
Posts: 5
Joined: Thu Apr 08, 2010 7:28 am

Re: All files tagged as "hidden system files"!!?

Post by SamTHorn » Tue Sep 14, 2010 1:06 am

I am not sure if you've resolved this yet but try right clicking the folder and in the properties un-select hidden. That should do the trick...

fulanke
Getting the hang of things
Posts: 50
Joined: Mon Jul 27, 2009 12:04 am

Re: All files tagged as "hidden system files"!!?

Post by fulanke » Sun Nov 21, 2010 9:50 pm

I am kicking into this thread as I haven't got any response to my own thread. I am facing exactly the same problem on my TS209PRO2 and after reading this thread, I do confirm that I have the same issue. Randomly files were being marked as hidden and system and I needed quite some time fixing this via SSH.

qnap support, please get alife and comment on this. File system permissions and file visibility are a critical thing for all qnap users, so I would like to see some priority on such issues. It can't be solution to force users doing SSH and chmod actions - especially given that QNAP claims to be a Plug&Play storage solution. Unexperienced users will freak out over this or return the box to the dealer as defective.

Post Reply

Return to “File Sharing”