Unable to access NAS as guest following firmware update to v4.3.6.0979

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by drivie » Sun Jun 23, 2019 6:41 am

Hello,

I have a TVS-871 and decided to update the firmware to version: 4.3.6.0979 today (previous firmware was from November 2018). Following the update, I'm no longer able to access the NAS from any of my Windows 10 machines without a prompt to enter network credentials. My Android phone also fails to access the NAS.

The NAS is setup as a stand-alone workgroup server (no domain) on my personal network. Previously, I was able to click the name of the NAS under the network heading in File Explorer and access the shares without issue (without the need to authenticate). I don't want to add users to the NAS as I frequently access it from devices (PCs, MACs, phones, tablets) on a temporary basis. I would just like it to work as it did before this update.

Here are some things I've tried:
- Confirmed that "Allow all connections" is enabled under Security
- Checked the share permissions and "Guest Access Right" is set to Full access.
- Tried giving RW access to the everyone group.
- Checked SMB level. Highest level is 3 and lowest level is 1 currently
- Pressed the reset button on the back of the NAS for 3 seconds (1 beep) and reconfigured as needed.
- Tried from another PC that was definitely working prior to the firmware update and the results are the same (request for network credentials).
- Confirmed "restrict anonymous users from accessing SMB shared folders" is set to "Disabled, anyone can view the shared folder list. Guest account can access folders with permission."
- Have unchecked/re-checked "Disable and hide multimedia functions"
- Confirmed that I don't have any stored usernames/passwords for the NAS in Windows credential manager.
- Confirmed that "Microsoft host network access" is not set for the shares
- Advanced Folder Permissions and Windows ACL Support are both disabled.
- Downgraded to firmware 4.3.6.0959

I'm at a loss as to what the newer firmware changed. Any assistance is greatly appreciated.

Thank you!
Last edited by drivie on Tue Jun 25, 2019 11:15 am, edited 3 times in total.

Sandom
New here
Posts: 6
Joined: Sat Nov 22, 2008 2:32 pm

Re: Unable to access NAS following firmware update

Post by Sandom » Mon Jun 24, 2019 10:23 pm

I have the identical issue, should I recall to the previous version?

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS following firmware update

Post by drivie » Mon Jun 24, 2019 11:46 pm

Sandom wrote:
Mon Jun 24, 2019 10:23 pm
I have the identical issue, should I recall to the previous version?
I considered that but my previous firmware was from November 2018 as I wasn't keeping it up-to-date as diligently as I probably should have.

If you upgraded from a slightly earlier version, it would seems like going back one or two versions might make sense. If that works, please let me know.

Thanks!

Sandom
New here
Posts: 6
Joined: Sat Nov 22, 2008 2:32 pm

Re: Unable to access NAS following firmware update

Post by Sandom » Tue Jun 25, 2019 4:16 am

Rolling back to 4.3.6.0959

Sandom
New here
Posts: 6
Joined: Sat Nov 22, 2008 2:32 pm

Re: Unable to access NAS following firmware update

Post by Sandom » Tue Jun 25, 2019 4:40 am

Guest login works again. QNAP software engineers seem to have been a very initiative to invent the wheel again ;-)

ButlerSAB49
New here
Posts: 7
Joined: Mon Jun 24, 2019 9:40 pm

Re: Unable to access NAS following firmware update

Post by ButlerSAB49 » Tue Jun 25, 2019 7:10 am

I have exactly the same issue but rolling back firmware hasn’t helped - still no Guest access! :(

I’ve rolled back to all available firmware downloads to no avail, now opened a support case with QNAP etc.

I have a TS-1263U and TS-1263U-RP both with the same issue at current!

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS following firmware update

Post by drivie » Tue Jun 25, 2019 10:34 am

Sandom wrote:
Tue Jun 25, 2019 4:40 am
Guest login works again. QNAP software engineers seem to have been a very initiative to invent the wheel again ;-)
Thanks for the follow-up. I appreciate you taking the time to give it a try and post back here again. I may do this as well to see if works for me.

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS following firmware update

Post by drivie » Tue Jun 25, 2019 10:35 am

ButlerSAB49 wrote:
Tue Jun 25, 2019 7:10 am
I have exactly the same issue but rolling back firmware hasn’t helped - still no Guest access! :(

I’ve rolled back to all available firmware downloads to no avail, now opened a support case with QNAP etc.

I have a TS-1263U and TS-1263U-RP both with the same issue at current!
Please let me know what you learn from QNAP support regarding this issue. I'm thinking about trying a roll back to older firmware but don't want to waste the time and potentially cause additional issues if it's not the answer.

Thank you!
Last edited by drivie on Thu Jul 04, 2019 11:39 pm, edited 2 times in total.

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by drivie » Tue Jun 25, 2019 10:40 am

I've updated the title of the thread to better reflect the issues we're experiencing under the latest firmware.

gregeeh
Getting the hang of things
Posts: 53
Joined: Thu Nov 23, 2017 10:27 am
Location: Sydney, Australia

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by gregeeh » Tue Jun 25, 2019 11:12 am

I too have the same problem after upgrading to 4.3.6.0979, however downgrading to 4.3.6.0959 has not fixed the issue. Darn.........

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by drivie » Tue Jun 25, 2019 11:15 am

gregeeh wrote:
Tue Jun 25, 2019 11:12 am
I too have the same problem after upgrading to 4.3.6.0979, however downgrading to 4.3.6.0959 has not fixed the issue. Darn.........
Thanks for providing input. I just downgraded to firmware 4.3.6.0959 as well and it failed to resolve the issue for me too.

gregeeh
Getting the hang of things
Posts: 53
Joined: Thu Nov 23, 2017 10:27 am
Location: Sydney, Australia

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by gregeeh » Tue Jun 25, 2019 11:25 am

The manual says:

The NAS has created the following users by default:
• admin: The administrator "admin" has full access to system administration and all shared folders. It cannot be deleted.
• guest: This is a built-in user and will not be displayed on the "User Management" page. A guest does not belong to any user group. The login password is "guest".
• anonymous: This is a built-in user and will not be shown on the "User Management" page. When you connect to the server by FTP, you can use this name to login.


However trying to access the NAS with the username and password of guest fails. Only the admin user seems to work.

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by drivie » Tue Jun 25, 2019 11:41 am

gregeeh wrote:
Tue Jun 25, 2019 11:25 am
The manual says:

The NAS has created the following users by default:
• admin: The administrator "admin" has full access to system administration and all shared folders. It cannot be deleted.
• guest: This is a built-in user and will not be displayed on the "User Management" page. A guest does not belong to any user group. The login password is "guest".
• anonymous: This is a built-in user and will not be shown on the "User Management" page. When you connect to the server by FTP, you can use this name to login.


However trying to access the NAS with the username and password of guest fails. Only the admin user seems to work.
Thanks for pointing that out. I suspect QNAP somehow either messed with or disabled this hidden guest account in one of the recent firmware updates. Hopefully it's an accident and they get it working again soon.

It certainly would be nice if there was an area in the GUI where you could enable/disable the hidden guest and anonymous accounts for those that either want additional security or don't need that level of security. This in lieu of having to enable or deny guest access for each folder.

ButlerSAB49
New here
Posts: 7
Joined: Mon Jun 24, 2019 9:40 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by ButlerSAB49 » Tue Jun 25, 2019 9:39 pm

QNAP Support responded to me today as per the attached... Unfortunately what they've advised does not seem to work either so I've responded again and awaiting another response!

Worth a try for you guys - let me know if it does happen to work for you... The setting they mentioned on my QNAPs was set to "Disabled" but the wording of the "Disabled" option sounds correct for what I want anyway... Will keep you posted!
You do not have the required permissions to view the files attached to this post.

megaabite
Starting out
Posts: 13
Joined: Wed Sep 26, 2018 11:22 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by megaabite » Tue Jun 25, 2019 11:05 pm

mine was always set to Disabled - checked it multiple times.

double/triple/quadruple checked guest settings on shared folders - full rights enabled.
plus all of it worked before upgrade. in my case it was very plain - worked immediately before upgrade, has not worked since.

downgrading to 4.3.6.0959 has not fixed the issue

must be a setting somewhere. have been through Network, Shared Folders, and Users multiple times. everything I can change seems to be correct.
Last edited by megaabite on Wed Jun 26, 2019 12:33 am, edited 1 time in total.

Locked

Return to “File Sharing”