Page 5 of 5

TVS-872XT: TB3 networking works for me on Windows 10 Pro 1903

Posted: Sat Jul 18, 2020 5:40 am
by buggz
OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363

Windows 10 Pro Build 18362.19h1_release.190318-1202

Processor Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. P3.30, 12/7/2018
SMBIOS Version 2.8
BaseBoard Manufacturer ASRock
BaseBoard Product Z370 Killer SLI/ac

System Drivers
nhi Thunderbolt(TM) Controller c:\windows\system32\drivers\tbt81x.sys Kernel Driver
tbtmpdrv Thunderbolt(TM) Networking c:\windows\system32\drivers\tp2p81x.sys Kernel Driver

Loaded Modules
Thunderbolt 16.3.61.14 439.23 KB (449,768 bytes) 3/16/2017 09:59 Not Available c:\program files (x86)\intel\thunderbolt software\thunderbolt.exe

Services
Thunderbolt(TM) Service ThunderboltService Running Manual Own Process "c:\program files (x86)\intel\thunderbolt software\tbtsvc.exe" Normal LocalSystem 0

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Sat Jul 18, 2020 8:27 pm
by gorkme
buggz thank you.
It's help me for 20 minutes.

I found this driver Thunderbolt 16.3.61.14
delete old versions. create thunderbolt connection. nothing change, but after I create Internet connection sharing. I recieve your speeds: ~2000\500 mb\sec (read\write)
But after that I want to try T2e connection via qfinder - and speed crashed back to 60\500 mb\sec

I'm trying to do everything back - but nothing. Happiness wasn't so long..

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Sat Jul 18, 2020 10:50 pm
by buggz
Hi gorkme,

I have never used the T2e protocol thingy.
That is totally a Qnap implementation.
It actually makes sense that speeds would decrease,
not only are you putting TB3 data stream on the connection,
now you are putting additional Ethernet stream data.

I will have to read more about this, but the use of this additional protocol would definately decrease the speed.

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Sun Jul 19, 2020 12:48 am
by gorkme
Try to reinstall to clean win 10 2004 workstation - the same situation. (try with 17 and 16 version of thunderbolt drivers)
60mb read\500 mb write

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Sun Jul 19, 2020 1:11 am
by buggz
I am no expert, nor pretend to be...
I don’t understand fully the Qnap T2E link.
I don’t understand why this would be used?
Only to provide Ethernet connectivity to the TB3 link?
It seems to me it just introduces too much traffic and causes the physical layer to be saturated?
Or, a very inefficient protocol?

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Sun Jul 19, 2020 7:24 pm
by gorkme
Minor update.

As I understand on gigabyte site there is latest driver wich supported Win10 ver.2004 v. 1‎.41.890.0 from 2‎020/06/09
I've install it.

speed come back to ~2000 read/500 write mb. after that i reboot the computer and speed is come back to ~ 60mb read\500 mb write
Interesting moment that then I change some parameters in thunderbolt adapter configuration like uncheck services like tcp ip v6 for a few seconds speed is come back.
IMG_2395.jpg
IMG_2403.jpg

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Thu Jul 23, 2020 10:08 pm
by gorkme
upd.

I have to install windows 10 1803 (with off updates). Qnap support and some people says here that it could help to fix thunderbolt problem.
So. I've install it. I use 17.4.77.400 driver.
What speed I have:
1. write 2000 mb\sec (on 2004 was 500 and I do not change adapter parameters to share the internet)
2. read as in win 10 2004 it starts from 2000 mb\sec but after 2-3 seconds it slows to 65 mb\sec

I have to buy anker thunderbolt cable to test different cable from apple - this is not help me too.


Anyone resolve this problem?

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Fri Aug 14, 2020 11:44 pm
by gorkme
upd.
Hi as I understand I have to fix read speed. It didn't slow after I reboot windows. Thunderbolt gives me stable 2 gb\sec on read.
What have I did: in the thunderbolt driver preferences I have to disable "receive side scaling"

system:
windows 10 2004
tested on driver ver 17.xxx and whql 1.41.xx

but here is another problem: to activate write speed 550 mb\sec you need to share internet true ethernet adapter, and after reboot writing speed is lost. you need to disable internet sharing and enable to activate it.

any ideas about it?

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Wed Sep 09, 2020 5:41 am
by kuau714
Glad I found this thread. I applied the @themannyram "fix" which did work for me. Though I am still getting not very good write speeds, yet at least for now its working.
I am running Windows 10 Pro Version 2004 build 19041.450 I have an Intel NUC NUC9VXQNB.
This is my current speed over Thunderbolt 3 and my TVS-672XT
Has anyone figured out how to increase the write speeds?

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Thu Sep 10, 2020 5:39 am
by kuau714
So here is the latest update.
I opened up a support ticket with QNAP, and there response was basically the fault lies with Microsoft and they do not have a fix,
even though I was getting very good read performance as shown above, I opened up one of my Davinci Resolve projects which all the video files reside on the NAS, i though for sure with the reported read speeds above I should be able to play back CInema DNG 24P 4K video though Resolve was dropping frames and would not play back smoothly. I was very disappointed to see this as my iMac loading the exact same project played back perfectly off the NAS via ThunderBolt 3

So I decided to purchase the QNAP QNA-T310G1T adaptor, received the unit today, plugged it in, installed the driver, followed the instructions and bang everything worked as advertised.
I am somewhat ** off at QNAP, there marketing material is very deceptive as the Windows support and Thunderboolt 3 clearly has issues and I wish QNAP would at least have some kind of message on there website discussing the issue.

As it stands right now for proper Windows support one needs to either have a 10Gb ethernet port or have to use a Thunderbolt 3 to 10Gb adaptor.

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Fri Sep 18, 2020 12:24 am
by Bob Zelin
kuau714 wrote:
Thu Sep 10, 2020 5:39 am
\

As it stands right now for proper Windows support one needs to either have a 10Gb ethernet port or have to use a Thunderbolt 3 to 10Gb adaptor.

I keep telling people this, but many don't listen. Use 10G and you never have any issues. Davinci Resolve, Adobe Premiere, FCP X and AVID Media Composer all work great -
just use 10G, not Thunderbolt.
Bob Zelin

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Posted: Fri Sep 18, 2020 12:34 am
by kuau714
Your right Bob, I am just kind of upset with QNAP how they can sell a product like this and not have it work as advertised and to boot the support staff says the issue is with Microsoft and not them. BTW I have my iMac Pro directly connected to the NAS via Thunderbolt 3 with zero issues...