Home Folder broken on upgrade to QTS 4.5.2

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
Post Reply
haoshan
First post
Posts: 1
Joined: Mon Jul 20, 2020 12:50 am

Home Folder broken on upgrade to QTS 4.5.2

Post by haoshan » Sat Feb 13, 2021 3:10 am

Just over a week ago I upgraded my TS-453D to QTS 4.5.2. After the upgrade, the virtual "home" samba share was no longer available. I managed to resolve the problem by disabling "Enable home folder for all users" (in Control Panel > Privilege > Users > Home Folder) and then re-enabling it and setting the correct Disk Volume. At the time, I assumed the problem was because I had not unlocked the volume on which the home folders reside between the upgrade and the recommended pre-upgrade reboot, and that an error in the upgrade script had resulted in new home folders being set up on the un-encrypted volume.

After another reboot today, however, the home share was again unavailable, and I had to repeat the procedure of disabling and re-enabling "Enable home folder for all users". Having to repeat the disable/enable procedure after every reboot is going to get annoying! Does anyone have any advice on how to resolve this permanently?

Geee
Starting out
Posts: 21
Joined: Fri May 18, 2012 9:06 pm

Re: Home Folder broken on upgrade to QTS 4.5.2

Post by Geee » Wed Apr 07, 2021 2:12 pm

I have the same issue on my TS-431P running QTS 4.5.2.1594.
This was after a power failure so I'm not 100% sure if the update to 4.5.2 caused the issue or the unexpected reboot.

When I try to re-enable the home folder for all users, i get the error that it failed and i should check the logs.
I'm not sure which log I'm supposed to check.
/var/log/storage_lib.log seems like a likely candidate however i didn't see any log entries that seem related to the "home" share.

Edit: I noticed that the home folder works again after doing the above procedure, despite the error message.
TS-431P, QTS 4.5.3, 3x Hitachi HDS5C3030ALA630 3TB, 1x Toshiba DT01ACA300 3TB

Geee
Starting out
Posts: 21
Joined: Fri May 18, 2012 9:06 pm

Re: Home Folder broken on upgrade to QTS 4.5.2

Post by Geee » Sun May 02, 2021 5:02 pm

I'm happy to see that this issue was fixed in the QTS 4.5.3.1652 release.
It is also mentioned in the release notes.

(yes, i have an encrypted volume)

For some reason the OT posted this under "File Sharing", I don't think it belongs here.
TS-431P, QTS 4.5.3, 3x Hitachi HDS5C3030ALA630 3TB, 1x Toshiba DT01ACA300 3TB

Post Reply

Return to “File Sharing”