Local User Account - inconsistent behaviour

Windows Access Rights Management
Post Reply
AndrewShaw
New here
Posts: 2
Joined: Fri Apr 03, 2020 8:24 am

Local User Account - inconsistent behaviour

Post by AndrewShaw » Wed Apr 07, 2021 8:31 am

Hi guys,

I have set up a local user account on my NAS for my day to day share connections.
I have 2 machines I use to connect from
1) a Windows 10 desktop that has been up and running for years
2) a MacBook Air that I have just completely reinstalled BigSur on and am setting up (I am new to the world of MacOS so am travelling slowly here!)

I am able to connect to my QNAP from my MacBook by changing the user it wants to connect as from Guest to the one I created.
From my Windows machine, however I cannot get the local user account to connect. It has been set up for the last few years just connecting as the default Admin account, but now when I disconnect one of the shares and try to remap it using the local account it fails and wants to default back to Admin.
It has just occurred to me as I write this - I have half a dozen different shares all mapped on this Windows machine, but I have left the others all mapped using admin and I have a vague recollection that Windows doesn't like it when you have a share mapped on one server under one account and then try to map a different share, but on the same server under a different userid. I may have just solved my own problem - will now try disconnecting all shares, reboot the W10 box and then try mapping using the local account.

I will report back.

Thanks for listening !!!
TS-851:
- 4 x 3TB @ RAID5, Backed up to 2nd on-site NAS. Additional backup to cloud "coming soon".
iSCSI
- 2 x SSD
- 1 x 500G
- 1 x 2TB IronWolf

AndrewShaw
New here
Posts: 2
Joined: Fri Apr 03, 2020 8:24 am

Re: Local User Account - inconsistent behaviour

Post by AndrewShaw » Wed Apr 07, 2021 9:18 am

That seems to have resolved my problem.
I disconnected all my NAS shares from the Windows machine, rebooted it to verify that they didn't come back and was then able to map them again using the new local userid.
TS-851:
- 4 x 3TB @ RAID5, Backed up to 2nd on-site NAS. Additional backup to cloud "coming soon".
iSCSI
- 2 x SSD
- 1 x 500G
- 1 x 2TB IronWolf

Post Reply

Return to “Windows”