Installing Elementary OS Qnap TS-251+

Post Reply
neurotico
New here
Posts: 3
Joined: Mon Aug 12, 2019 6:45 am

Installing Elementary OS Qnap TS-251+

Post by neurotico » Mon Aug 12, 2019 7:07 am

Hi!

I'm a beginner with Linux, I have a new Qnap, the TS-251+ w/ 16gb ram and LOVING it from my Freenas Mini. I'm trying now to get more familiar with Linux and wanted to setup a virtual machine that I can connect to via remote connection, or via web UI. I began researching and testing with Container Station and Virtualization Station. My goal is to install Elementary OS specifically. I'm not finding a way to. In Virtualization Station I get an error when creating a new VM and using the .ISO from Elementary's website:
"A data format error occurred due to an incompatible version of Virtualization Station (downgrading is not supported). You must upgrade to the latest version of Virtualization Sation. (17)"

But there are no updates for any app. This is irregardless of what I select for "OS Type" and "Version" the same error appears. I did once use the BETA version of the Qnap Firmware, then removed it as I was getting errors in the Multimedia Station. Could that be the error in reference?

In Container Station, I can't find a way to use an .ISO to deploy an OS. I then installed Ubuntu using the predefined options, but then found out that in Container Station there is no GUI...it's all console. I then installed Linux Station and that is working fine for me, but cannot install Elementary OS in there either.

I've read in this forum others asking for help with specific things in Elementary OS in Qnap, so it seems possible...but am unsuccessful when searching for help with what app to use and how to start the process. If anyone finds time to point me in the right direction, I'll greatly appreciate it!

Thank you!
John

neurotico
New here
Posts: 3
Joined: Mon Aug 12, 2019 6:45 am

Re: Installing Elementary OS Qnap TS-251+

Post by neurotico » Mon Aug 12, 2019 7:36 am

By the way, another issue (albeit minor, in my case) with Linux Station is the inability to control resources it uses. Mine is sooo slow, even though I got 14gb free RAM, not sure what it is capable of seeing.

neurotico
New here
Posts: 3
Joined: Mon Aug 12, 2019 6:45 am

Re: Installing Elementary OS Qnap TS-251+

Post by neurotico » Tue Aug 13, 2019 11:04 pm

I resolved this issue myself. Multimedia Station does not seem to exist in current stable version, but in the current beta it does. Virtualization Station is also newer in the Beta and reverting back to a stable version does not downgrade all the apps. Removing the apps does not correct it, because upon reinstalling the apps, it will get the updated version available only in the beta OS. So getting everything back to the valid version of the apps, for the stable version of the OS, was the needed trick. Now my Virtualization Station works properly with the .ISO from Elementary OS.

Post Reply

Return to “Virtualization Station”