Internet access to Virtual Machine doesn't work

QNAP NAS solution for server virtualization and clustering/HA/FT
Post Reply
rgatchalian
Starting out
Posts: 17
Joined: Sun Dec 06, 2015 7:21 am

Internet access to Virtual Machine doesn't work

Post by rgatchalian » Sun Jun 25, 2017 10:10 pm

Hi,

I'm new to Qnap Virtualization. I'm trying to use a windows virtual machine as Web Server (I use .NET MVC hence I need the windows server). My Qnap NAS address is 192.168.0.20 and my virtual machine has a static IP 192.168.0.30. I can access the IIS webserver using the Virtual Machine IP Address. To access the Virtual Machine externally (from the internet), I made a port forwarding rule on my router. External Port 80 to local 192.168.0.30:80. Please note that there's no other Port Forwarding rule to my Qnap Nas.

The issue is that when I am on the same network the web application is accessible but when I try accessing it from my domain name example http://MyDomainName.com:8877 on a different network (i.e. mobile network) it just direct me to my Qnap NAS login page. I even tried changing the default NAS port from 8080 to 8088, thinking that it might be conflicting but it still didn't work.

Then, I changed the port forwarding rule to a specific port i.e. 8877 to local 192.168.0.30:80. This then work even on an external network. I'm not sure if there is a setting in Qnap or if this is a router issue.

So my current workaround is to enable the NAS web server then modify the index.php to redirect to http://MyDomainName.com:8877. This works but I not ideal to show the port number.

Many thanks in advance.

Post Reply

Return to “Server Virtualization & Clustering”