ADDC Backup error

Questions about using Windows AD service.
Post Reply
gordon8452
New here
Posts: 9
Joined: Fri Mar 11, 2011 12:37 am

ADDC Backup error

Post by gordon8452 » Tue May 05, 2015 12:07 am

I am getting consistent warnings every few days from the Domain Services log for the following:

[Domain Services] Log of ADDC database backup to /share/CACHEDEV1_DATA/homes/xxxxx/dc_backup.exp: /usr/local/samba/bin/tar: /share/CACHEDEV1_DATA/.samba_target/private: file changed as we read it

Any thoughts? Is there a way to set "--ignore-failed-read"? Should the backup not go to a users home directory? I have it set to overwrite the old backup and I wouldn't be opposed to using the other option of appending date so it makes new files if there were some options to purge old backup after so many days instead of manually.

Karlh
Starting out
Posts: 14
Joined: Sun Feb 08, 2015 7:06 am

Re: ADDC Backup error

Post by Karlh » Sat May 09, 2015 2:50 am

Same failure here

itguylv
First post
Posts: 1
Joined: Tue Jan 12, 2016 8:32 am

Re: ADDC Backup error

Post by itguylv » Sat Jan 30, 2016 2:12 am

Same here

deejinoz
Starting out
Posts: 12
Joined: Tue Nov 10, 2015 12:00 pm

Re: ADDC Backup error

Post by deejinoz » Mon Oct 17, 2016 9:04 am

Hi guys,

I am getting the same error. Did any of you get any kind of resolution to this problem, please?

Attackwave
First post
Posts: 1
Joined: Fri Oct 13, 2017 10:53 pm

Re: ADDC Backup error

Post by Attackwave » Fri Oct 13, 2017 11:06 pm

Hi,

getting same error.

The backup script backups directory "/share/CACHEDEV1_DATA/.samba_target/private".

During the backup process, data can be written to the msg.sock directory. Then the backup process
ends with this warning.

Workarounds:

Edit file /etc/init.d/smb.sh and change NEW_TAR Variable:

Solution 1: Suppress Warning (I like)
NEW_TAR="/usr/local/samba/bin/tar --warning=no-file-changed"

Solution 2: Exclude Directory (Maybe another data can be written to the directory)
NEW_TAR="/usr/local/samba/bin/tar --exclude=/share/CACHEDEV1_DATA/.samba_target/private/msg.sock"

Check if it works...

Post Reply

Return to “Windows Domain & Active Directory”