Intermittent list of AD Trusted Domains when setting share permissions

Questions about using Windows AD service.
Post Reply
giox969
Starting out
Posts: 12
Joined: Fri Sep 11, 2015 9:35 pm

Intermittent list of AD Trusted Domains when setting share permissions

Post by giox969 » Fri May 26, 2017 8:15 pm

We have 8 trusted AD domains in our production WAN. QNAP with firmware 4.3.3 is joined to our "master" domain, which has trusts with all the remiaining 7 domains.
The option "Enable trusted domains" in SMB Advanced Options is enabled.

When settings permission on a SMB share, we can only see an empty/incomplete/partial list of domains from which we can choose users from. Sometimes the list is empty, sometimes it only contains some domains.

domlist_empty.png
domlist_partial.png

I tested in a shell with wbinfo, but all seems to be ok

Code: Select all

wbinfo -m
correctly reports our 8 domains + BUILTIN and our QNAP hostname.

Code: Select all

wbinfo -u
correctly lists all user on our master domain

Code: Select all

wbinfo --domain TRUSTEDDOMAIN -u
correctly lists all user on all 7 domains (it's a bit slow, sometimes)

Code: Select all

wbinfo -i 'trusteddomain\user' 
correctly retrieve info for a user on a trusted domain

The problem seems to be related to the web UI only.

How can I add users of trusted domains to my share permissions if they are not listed in that dropdown list?

Thank you
You do not have the required permissions to view the files attached to this post.

cryogenx
First post
Posts: 1
Joined: Tue Mar 24, 2015 3:19 am

Re: Intermittent list of AD Trusted Domains when setting share permissions

Post by cryogenx » Wed Sep 20, 2017 10:46 pm

Im having the exact same issue and along with it terribly slow permissions apply speed, some of my folders have taken in upwards of 8 hours to apply permissions, seriously considering replacing these devices with something else

Post Reply

Return to “Windows Domain & Active Directory”