AD re-registration required periodically.

Questions about using Windows AD service.
Post Reply
Net Admin
New here
Posts: 4
Joined: Fri Jun 29, 2018 8:52 am

AD re-registration required periodically.

Post by Net Admin » Fri Jun 29, 2018 9:19 am

Good morning,

I have a ts-251+ running fw: 4.3.4.0597 build 20180528

A few times I've gone to add a permission for a new share, only to find that there are no domain groups in the list when selected. Normally there are domain users in the that list, but not in the domain groups - though at least twice neither selection results in a list of users.

To fix the above issue I go into control panel, security and refresh the ad partnership. All the previous information (re the ad wizard) is still there, and once refreshed with admin name and password (for ad) the permissions lists are fully propagated once more.

The AD machine in this case is a 2008r2 box.

Is there a known cause for this behavior, or a fix?

On the subject of the QNAP nas using AD from the server, what happens if the server is down? Will the QNAP still use the permissions it has to provide access to user shares, or will it stop providing access because it can't contact the AD?

Many thanks.

rick6612
New here
Posts: 2
Joined: Wed Mar 20, 2019 12:52 am

Re: AD re-registration required periodically.

Post by rick6612 » Wed Mar 20, 2019 2:06 am

Hello,

Wondering if anyone else has had similar problems? We are running a QNAP TS-859U+ with firmware 4.2.6. It is connected to AD on our Windows SBS 2011 server. For the most part, it has been fine. However, we did have a problem one day where users were suddenly being prompted for credentials when trying to access shares on the QNAP. Re-entering the AD credentials wouldn't do any good. Eventually, we ended up re-running the AD Authentication wizard, which restored normal functionality to the NAS.

Now we're trying to figure out what went wrong, and wondering if this is likely to happen again.

Thanks,

Rick

HerrDoktor
First post
Posts: 1
Joined: Sat Jun 04, 2011 10:03 pm
Location: Southern Germany

Re: AD re-registration required periodically.

Post by HerrDoktor » Sat Jul 20, 2019 1:01 am

Cheers Guys, wanted to chime into the discussion. I have a customer with 11 QNAPs (all kinds of 6 Bay) and we are facing this issue on 2 of the 11 Boxes. Those boxes are usually set up the same way, patch-level is usually the same.

So if there is a permanent solution, it would be great to know it.

I only want to work with AD-Groups, it is too much hassle to give permissions individually.

rick6612
New here
Posts: 2
Joined: Wed Mar 20, 2019 12:52 am

Re: AD re-registration required periodically.

Post by rick6612 » Sat Jul 20, 2019 4:53 am

Hi HerrDoktor,

I have not had this problem again since the one time it happened. All I ever did to fix it was to re-run the AD Authentication wizard. Are you having a recurring problem?

Rick

Post Reply

Return to “Windows Domain & Active Directory”