TS-569 cannot join Domain

Questions about using Windows AD service.
Post Reply
acatic
First post
Posts: 1
Joined: Thu Oct 18, 2018 4:16 am

TS-569 cannot join Domain

Post by acatic » Thu Oct 18, 2018 4:31 am

I have three QNAPs, which I'd like to join to the domain. The two TS-1269U-RP's join fine. One (a TS-569) cannot join the domain. It can ping/get pinged. Browsing its files is fine from a domain-joined computer. I've tested it with the last three firmware versions. It's now on the latest, 4.3.4.0734 (2018/10/08)

Our domain controllers are all 2012 R2.

Many thanks for all guidance.

Debug log reproduced below.


Microsoft network settings failed. Please check the DNS server, domain name, and user name and password for logging in the domain.

======== DEBUG START =======

/usr/local/samba/bin/net time set -S DC1.domain.local

[command] echo ******** | /usr/bin/kinit "svc_acct@DOMAIN.LOCAL"

Password for svc_acct@DOMAIN.LOCAL:

Specify WORKGROUP = MY_DOMAIN

[command] /usr/local/samba/bin/net ads join -S DC1 -U "svc_acct%********" -s /etc/config/smb.conf

Failed to join domain: failed to lookup DC info for domain 'DOMAIN.LOCAL' over rpc: Undetermined error

[command] /usr/local/samba/bin/net ads join -S DC1.domain.local -U "svc_adfs%********" -s /etc/config/smb.conf

Failed to join domain: failed to set machine kerberos encryption types: Out of memory

[command] /usr/local/samba/bin/net rpc join -S DC1 -U "svc_acct%********" -s /etc/config/smb.conf

Failed to join domain: failed to lookup DC info for domain 'MY_DOMAIN' over rpc: Undetermined error

[command] /usr/local/samba/bin/net rpc join -S DC1.niagaraparks.nf -U "svc_acct%********" -s /etc/config/smb.conf

Failed to join domain: failed to set machine kerberos encryption types: Out of memory

Post Reply

Return to “Windows Domain & Active Directory”