Trying to Join TS-873 to Domain Fails

Questions about using Windows AD service.
Post Reply
BDMcGrew
First post
Posts: 1
Joined: Tue Dec 18, 2018 2:26 am

Trying to Join TS-873 to Domain Fails

Post by BDMcGrew » Tue Dec 18, 2018 2:32 am

Good morning,

I'm new to the whole QNAP environment. I'm trying to join a TS-873 to a Windows domain and it's failing with the below message. I've searched around and can't seem to find an answer so any assistance is greatly appreciated. I've tried with multiple domain admin accounts including my account wish is the renamed domain admin account.

Server: 2008R2 Standard
Domain Function Level: 2003 - No, I can't upgrade it right now, sorry!

Error is below. Domain account is being created and DNS entries are present and correct.

Thanks,

-brian

Microsoft network settings failed. Please check the DNS server, domain name, and user name and password for logging in the domain.

======== DEBUG START =======

/usr/local/samba/bin/net time set -S MVPNS112.machinevisionproducts.com

[command] echo ******** | /usr/bin/kinit "brian@MACHINEVISIONPRODUCTS.COM"

Password for brian@MACHINEVISIONPRODUCTS.COM:

Specify WORKGROUP = MVP

[command] /usr/local/samba/bin/net ads join -S MVPNS112 -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

[command] /usr/local/samba/bin/net ads join -S MVPNS112.machinevisionproducts.com -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

[command] /usr/local/samba/bin/net ads join -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

[command] /usr/local/samba/bin/net rpc join -S MVPNS112 -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

[command] /usr/local/samba/bin/net rpc join -S MVPNS112.machinevisionproducts.com -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

[command] /usr/local/samba/bin/net rpc join -U "brian%********" -s /etc/config/smb.conf

Failed to join domain: Failed to set machine spn: Operations error

Do you have sufficient permissions to create machine accounts?

User avatar
storageman
Experience counts
Posts: 4207
Joined: Thu Sep 22, 2011 10:57 pm

Re: Trying to Join TS-873 to Domain Fails

Post by storageman » Tue Dec 18, 2018 5:53 pm

1.As you probably know entries are case-sensitive - assume you checked?
2.Date/time must be in agreement with domain controller.
3.Check SMB level on NAS and server.

Post Reply

Return to “Windows Domain & Active Directory”