QNAP Firmware Update - Active Directories / Domain Connection Lost

Questions about using Windows AD service.
Post Reply
SKahle83
New here
Posts: 5
Joined: Sat Mar 16, 2019 4:52 pm

QNAP Firmware Update - Active Directories / Domain Connection Lost

Post by SKahle83 » Sat Jun 22, 2019 9:42 am

Good evening,

I spent the whole day setting up a Windows Server 2019 virtual machine in my QNAP TS-451+ using Virtualization Station. Everything was going fine; I set up the VM as domain controller, set up active directories, created users / groups, added a bunch of physical client machines to the domain, and then joined my QNAP to the domain and used the Domain Users/Groups to apply permissions to my QNAP shared folders. Everything was working great. Then I decided to to do the firmware update that the QNAP web interface is always bothering me about...

Previous Firmware: 4.3.6.0895 (2019-03-28) ? Maybe? The QNAP was installed in March, and I haven't done a firmware update since the initial setup.
Current Firmware: 4.3.6.0959 (2019-05-31) Installed this today.

The first symptom I noticed was that my shared folders that had been mapped via a GPO were inaccessible. They were mapped by NetBIOs name, so I figured if something is going on with the DNS, then maybe I could map them by IP address directly on the client. No luck. I can only access my NAS shared folders by logging into the QNAP web interface and using the File Station app, or by mapping them on a computer that on the network but NOT part of the domain. This led me to looking at the shared folder permissions; I could see all of my AD users /groups applied to the folders, but when I tried to "Add" and then choose a domain user/group, it would just hang.

Next I looked at the "Domain Security" in Control Panel, which still showed AD authentication. I figured I would try to re-enter the credentials and rejoin; it failed to join, set Domain Security back to "No domain security," and stripped all of my AD user/group permissions off of my shared folders. Now I am unable to re-join the domain. It just hangs for a while "Applying, please wait" and then notifies me: "Microsoft network settings failed. Please check the DNS server, domain name, and user name, and password for logging in the domain" <-- All of this is correct.

I went into the Windows 2019 server and deleted the A (Host) records for the QNAP/NAS, but that didn't help anything.

Other Information:
The DNS and AD services on the Win 2019 Server seem to be working still; I am able to login from different client machines to the domain, roaming profiles are working, and my other GPOs (with the exception of my mapped NAS drives) are workign.

Based on other threads I've read in the forum, this disconnection form AD / Domain seems to be a pervasive problem with firmware upgrades. I couldn't find any tricks that worked for me; I am super frustrated at this point.

-SKahle83

Post Reply

Return to “Windows Domain & Active Directory”