Authentication problems

Questions about using Windows AD service.
EllenorLions
New here
Posts: 2
Joined: Thu Dec 06, 2012 12:22 am

Re: BackupExec Authentication problems

Post by EllenorLions » Thu Dec 06, 2012 12:28 am

Regarding backing up QNAP with BackUpExec - we found that you need to install the Ralus agent on the QNAP a QPKG package and have an account on the QNAP and the backup server that match. This also saves on having to have a licence to backup your QNAP with Backup Exec. If you are using version 2012 then you tend to get a message when the backup has completed saying the agent needs to be updated, this is because the agent has not been updated to match this newer version.

sarangtc@gmail.com
Starting out
Posts: 29
Joined: Fri Apr 18, 2014 1:56 am

Re: Authentication problems

Post by sarangtc@gmail.com » Wed Sep 09, 2015 11:01 am

I am getting the same problem on my TS-1679U-RP which had firmware 4.1.3, so I updated to 4.1.4 but problem still continues. I have not been able to completely isolate the problem but have noticed the following:
1) as described above I can always access the NAS from my windows domain PCs via \\IP\Share but only sometimes via \\Nasname\share\ (domain server Windows Server 2012)
2) nslookup in windows machines for Nasname and IP (i.e. forward and reverse) show correct results
3) once \\Nasname connection is successfully initiated it will continue to work until that PC does not use the connection for a long time, e.g. when you come back to your PC first thing in the morning, it doesn't connect
3a) Last night a left a small video running in loop, when I came back in the morning, that PC could still connect through Nasname, all other PCs were prompting for username and password when connecting to Nasname (username and password are not accepted though). connecting via IP always works as stated before, but all projects are linked via Nasname so this is frustrating
4) Have to restart NAS at least once sometimes more to get the windows PCs to be able to connect via Nasname, restarting the windows PCs does not help.

Thanks, please help me solve this problem

sarangtc@gmail.com
Starting out
Posts: 29
Joined: Fri Apr 18, 2014 1:56 am

Re: Authentication problems

Post by sarangtc@gmail.com » Thu Sep 10, 2015 9:16 am

I have tried:
/etc/rc.d/init.d/smb stop
/etc/rc.d/init.d/smb start

and
/etc/init.d/winbind restart

iGeorge
First post
Posts: 1
Joined: Mon Mar 13, 2017 10:56 pm

Re: Authentication problems

Post by iGeorge » Tue Mar 14, 2017 3:10 am

Hi,

Today I have the authentication issue on QNAP TS-1263U (4.2.2). I have problems with authentication domain users on NAS share. Domain server is Microsoft Standard Server 2012.
Users can read root folders names on NAS throw [ip_address]/[share_name], not entering inside.
But when they trying to get access to [SERVER_NAME]/[ShareName], login windows appears for domain access and any attempts to login was failed (before all was OK) - NAS didn't recognized user domain login and password from local network.
And from the MS Server 2012 user with admin rights can access to NAS shared folders, using his domain login and password.

Any ideas?
Thank's.

NiQ1234
New here
Posts: 5
Joined: Sun Nov 06, 2016 7:27 am

Re: Authentication problems

Post by NiQ1234 » Sat May 06, 2017 12:05 pm

Same issue here after changing domain controller. Can login with IP address and FQDN but not host name.

If I setcfg loglevel to 3 the following interesting error is logged:

Code: Select all

[2017/05/06 05:00:46.080793,  1] ../source3/librpc/crypto/gse.c:465(gse_get_serv
er_auth_token)
  gss_accept_sec_context failed with [ Miscellaneous failure (see text): Failed
to find cifs/{NAS_HOSTNAME}@{DOMAIN.DNS.NAME}(kvno 31) in keytab MEMORY:cifs_srv_keytab (arc
four-hmac-md5)]
[2017/05/06 05:00:46.080944,  1] ../auth/gensec/spnego.c:574(gensec_spnego_parse
_negTokenInit)
  SPNEGO(gse_krb5) NEG_TOKEN_INIT failed: NT_STATUS_LOGON_FAILURE
[2017/05/06 05:00:46.081035,  2] ../auth/gensec/spnego.c:745(gensec_spnego_serve
r_negTokenTarg)
  SPNEGO login failed: NT_STATUS_LOGON_FAILURE
[2017/05/06 05:00:46.081818,  3] ../source3/smbd/server_exit.c:218(exit_server_c
ommon)


Searching for this error shows nothing with regard to QNAP. A general Samba forum suggested setting "kerberos method" to "secrets and keytab" but that completely breaks SMB.

EDIT: Solved by itself. If you experience this problem leave the ** thing alone, go home / go to sleep, it may work when you come back.

thearcherx
First post
Posts: 1
Joined: Thu Aug 29, 2019 1:30 am

Re: Authentication problems

Post by thearcherx » Thu Aug 29, 2019 1:35 am

This might be a old post but I think I found what is the cause for \\hostname gets invalid credential but \\ipaddress works. The time on the QNAP was off by 30 minutes which was way off sync with domain controller. After correcting the time access by \\hostname is restored. :ashamed:

Post Reply

Return to “Windows Domain & Active Directory”