Music Station not playing FLAC following update

Please post your questions about using the web-based Photo, Music, Video Stations here.
robanstey
First post
Posts: 1
Joined: Fri May 19, 2017 10:05 pm
Model: TS-253A/453A/653A/853A

Music Station not playing FLAC following update

Postby robanstey » Fri May 19, 2017 10:31 pm

Hi Everyone,

All my music is in FLAC format and until recently played happily through Music Station accessed through the web interface via my PC. Following recent updates this no longer works and instead I get a pop-up message (see attachment) stating (incorrectly) that my browser only supports MP3 and that to play the files I must enable Flash. If I do enable Flash it then works but it is then downsampling to MP3 and sounds horrible. This fault is across both Chrome and Firefox and on multiple machines. Music played through the QMusic app is unaffected.

I raised a support ticket for this but the 'help' was terrible - the person I was talking to couldn't understand the problem despite reproducing it and I left the conversation at the point where he was talking about a new feature request.

I would like to try rolling back to a previous version but can't find any to install. Has anyone else encountered this issue and if so how did you resolve it? My guess is that the update broke proper browser recognition which is a common enough fault, especially if someone hard-coded browser versions, but I can't even get the help desk to see it as a fault so there's no likelihood of a fix.

My logs show version 5.0.4 installed 27/04/2017 and 5.0.5 installed 12/05/2017. My memory is a bit hazy on this but I thought there were more updates than this. In any case the fault seems to have come in when the major revamp happened and the Spotlight/Manage switch was introduced.

Any light you can shed on this would be a great help. If I can get an earlier version to try out I may be able to open a new ticket and get some proper help to resolve this.

Thanks in advance.

My QNAP system is:
TS-435A
Firmware: 4.3.3.0188
Music Station v5.0.5

Accessed via:
Windows 10 PC & laptop
Chrome version 58.0.3029.110 64-bit
Firefox 53.0.2 32-bit
You do not have the required permissions to view the files attached to this post.

nickc
Starting out
Posts: 38
Joined: Sun Feb 08, 2009 5:25 pm
Model: TS-101/TS-201

Re: Music Station not playing FLAC following update

Postby nickc » Mon May 29, 2017 2:35 pm

Hi, I'm not sure if this will be helpful or not, but at least it's a response! I can't comment on the specific questions you raise as I don't use Music Station and don't intend to. And I don't access or play my musicI via a web browser either. Instead I use MinimServer (running on the QNAP), BubbleUpnp as controller (in my case running on an Android tablet, but it runs on other platforms), and Volumio as renderer/player (in my case running on a Raspberry Pi connected to my hi-fi, but Volumio also runs on several platforms.) Apart from providing performance second to none (MinimServer is a masterpiece of software) this setup certainly plays FLAC (and other lossless formats) and all three software components have active, intelligent and highly supportive developers. It might be worth your while checking out: http://minimserver.com/index.html & https://volumio.org/discover/ (if you play your music on/through a pc, you might not need Bubbleupnp - see the advice on MinimServer site re running on pc or NAS)
HS-251+ with 2 x 4gb WD "red" drives; TS-109 with Seagate 750Gb SATA, Seagate FreeAgent Pro 750Gb eSATA (Q-RAID 1), Seagate 750Gb USB disk 1.
SFR neufbox adsl modem/router; 3com Gigabit switch 5; PS 3; PCs & laptop all running Linux Ubuntu & windows XP; various Android devices; 2 x Raspberry Pi B+ running Volumio & Max2Play respectively.


Return to “Photo Station, Music Station, Video Station”

Who is online

Users browsing this forum: No registered users and 2 guests