QuMagie release

Please post your questions about using the web-based Photo, Music, Video Stations here.
User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7545
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie release

Post by Moogle Stiltzkin » Fri Jun 07, 2019 2:53 am

i notice mine got stuck. same even when trying to redo it.

funny cauz initially it was 100% early on. only recently did i see this change.

Image


so yeah it feels a bit wonky and incomplete. needs a bit more to do to get it into stable working condition. a few things


1. improve the recognition tagging. seems it doesn't pick up on a lot of things (in my example it was people category for animated characters that in previous facial tagging were recognized but in qumagie FAR FAR fewer were detected. but i do note that a lot of these pics were listed under objects as cartoons instead. maybe that is intended? but if that is the case, why then were the people still showing animated characters still? need further clarification by qnap their stance on tagging for artwork characters as in not real people pictures. if they are meant to be under cartoons then fine, put them all in cartoons but make it consistent)
2. i'm hating the cartoon tag. can you plz correctly detect as anime... or at least allow the user to reassign from cartoon to anime. then for anything truly a cartoon, the user can then flag that and move it into a separate group called "cartoon". there is not much flexibility here.
3. ai engine got stuck, feels like it's buggy.
4. need to improve the image viewing in qumagie for single picture view mode. lack of full size original quality image button. yes you have downloading button in the checklist main gallery, but in single view, there is no download button for the original pic.

anything else i missed?
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

iam@nas
Easy as a breeze
Posts: 267
Joined: Wed Jun 15, 2016 2:49 am

Re: QuMagie release

Post by iam@nas » Fri Jun 07, 2019 3:33 am

It's crazy. Even though I have only 600 photos in QuMagie after a re-installation and folder adjustment the Multimedia Console / AI wants to scan 20k images. It's really strange and I wonder whether some jobs fail with out-of-memory errors similar to Elasticsearch/QSirch.
Nevertheless QuMagie detects now faces on the images it failed last time. But there may be a magic barrier in QuMagie at about 1100-1600 images.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7545
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie release

Post by Moogle Stiltzkin » Fri Jun 07, 2019 3:56 am

iam@nas wrote:
Fri Jun 07, 2019 3:33 am
...
interesting point.

i'm upgrading ram sometime soon, so i'll run a test again when i do.

16gb is enuff? :'
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

iam@nas
Easy as a breeze
Posts: 267
Joined: Wed Jun 15, 2016 2:49 am

Re: QuMagie release

Post by iam@nas » Sat Jun 08, 2019 10:39 pm

16 GB should be more than enough, currently 9 GB (+ 7 GB buffers/caching) are used on my nas. AI needs CPU/GPU resources and not RAM.

So I added a path with 623 photos to QuMagie/Settings/Content Management/Content Sources/Edit and in Multimedia Console/AI Engines/Facial Recognition the progress reached 2% (623/21255). Object Recognition reached 100% ( 21255 / 21255 ). As https://nas/apps/qumagie/album/things is empty no-thing was detected.
Anyhow 30 faces were detected while similar faces were detected as the same person. I wonder how a person can be on one photo multiple times (unless mirrors are used or there's a portrait in the background).

After adding some more photos to QuMagie also the % progress in Multimedia Console has been increasing. And the CPU usage is again between 90 and 100 %.

tngtng
First post
Posts: 1
Joined: Sun Jun 09, 2019 2:21 pm

Re: QuMagie release

Post by tngtng » Sun Jun 09, 2019 2:24 pm

Does QuMagic support TS-228A ? it is arm based 64 bit cpu. Thanks !

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7545
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie release

Post by Moogle Stiltzkin » Sun Jun 09, 2019 2:29 pm

tngtng wrote:
Sun Jun 09, 2019 2:24 pm
Does QuMagic support TS-228A ? it is arm based 64 bit cpu. Thanks !
if i recall correctly, they remove some app features from the arm models becauz it barely had enuff compute to adequately use some of the features. maybe it was vm?

i'm doubtful qumagie can work well on this kind of arm model :S you should probably upgrade to a celeron x86 cpu or better.

NAS Drive CPUs Explained - What Difference Does it Make?
https://www.youtube.com/watch?v=HXYCGtVjLgk

ARM Vs X86 CPUs – How Important Is CPU Power And Efficiency When Buying Your First NAS
x86 CPU such as Intel and AMD on NAS Servers

x86 Processors on the other hand can massively out perform ARM both on single tasks and multiple tasks. They are also more suitable for rendering, transcoding, graphic creation in VMs and more. Alongside this it is also worth highlighting that an x86 CPU can do anything an ARM can do.

It is just a fact that an x86 will perform all tasks quicker. This of course comes at a price, both financially and consumption. The average x86 Intel i7 CPU in a 4-Bay NAS produces around 35-45W whilst in operation, whereas an average ARM has a maximum use of around 20-25W.

Likewise in hibernation or standby, x86 use 10-15W, where as an ARM will use as little as 4-6W. Likewise a NAS with an x86 CPU will be between 15 and 30% more expensive in terms of cost (like for like), but this is largely due to the device being able to do more and the cost of the hardware itself.
https://nascompares.com/2018/06/24/arm- ... first-nas/



also qumagie would benefit from a graphics card i believe. i got a 1050gtx installed on my ts-877 :mrgreen:


Just an update, this is the pre-requisite for Qumagie
NAS system requirements: x86-based NAS with QTS 4.4.1 (or later); 64-bit ARM-based NAS with QTS 4.4.1 (or later).
https://www.qnap.com/solution/qumagie/en-au/
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

zebulon2
Getting the hang of things
Posts: 55
Joined: Mon Jan 01, 2018 5:20 pm

Re: QuMagie release

Post by zebulon2 » Fri Jun 14, 2019 4:44 pm

On my TS-453A with 4.4.1, I notice that QuMagie looks at the thumbnail files for recognition. Why would it want to do that? Why not restricting itself to full-size pictures? That is double (maybe triple, with the 4K thumbnails) the work!

mercer2
New here
Posts: 4
Joined: Fri Jun 19, 2009 11:31 am

Re: QuMagie release

Post by mercer2 » Sun Jun 16, 2019 11:23 am

I have a TS-EC2480U with 32GB of ram, firmware 4.4.1.0949. I get the following message; failed to launch qumagie core reinstall in app center.

I did reinstall and reboot many times, same message always. Any ideas on how to solve it?

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7545
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie release

Post by Moogle Stiltzkin » Sun Jun 16, 2019 11:40 am

mercer2 wrote:
Sun Jun 16, 2019 11:23 am
I have a TS-EC2480U with 32GB of ram, firmware 4.4.1.0949. I get the following message; failed to launch qumagie core reinstall in app center.

I did reinstall and reboot many times, same message always. Any ideas on how to solve it?
uninstall qumagie and wait for the next update. thats what i did :(
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

mercer2
New here
Posts: 4
Joined: Fri Jun 19, 2009 11:31 am

Re: QuMagie release

Post by mercer2 » Sun Jun 16, 2019 2:54 pm

Moogle Stiltzkin wrote:
Sun Jun 16, 2019 11:40 am
mercer2 wrote:
Sun Jun 16, 2019 11:23 am
I have a TS-EC2480U with 32GB of ram, firmware 4.4.1.0949. I get the following message; failed to launch qumagie core reinstall in app center.

I did reinstall and reboot many times, same message always. Any ideas on how to solve it?
uninstall qumagie and wait for the next update. thats what i did :(
I was afraid that, that was the answer........

zebulon2
Getting the hang of things
Posts: 55
Joined: Mon Jan 01, 2018 5:20 pm

Re: QuMagie release

Post by zebulon2 » Fri Jun 21, 2019 10:19 pm

I have the error message since a few days. Are you sure you reinstalled QuMagie Core? QuMagie and QuMagie Core are separate packages. Core does not appear in my case in the NAS App Center, but the pkg can be downloaded from the App Center web page: https://www.qnap.com/en/app_center/?qts ... kw=qumagie
I am pretty sure that uninstalling QuMagie does not uninstall QuMagie Core. I will try to reinstall later too and report back.

zebulon2
Getting the hang of things
Posts: 55
Joined: Mon Jan 01, 2018 5:20 pm

Re: QuMagie release

Post by zebulon2 » Tue Jun 25, 2019 4:53 pm

So I have reinstalled QuMagie Core using the pkg file and still get the error message indeed. That said it does not seem to prevent it to work (apart from a few bugs).

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7545
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie release

Post by Moogle Stiltzkin » Tue Jun 25, 2019 5:25 pm

did u try the new beta 2 ? they did some fixes. mostly to do with multimedia console.
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

zebulon2
Getting the hang of things
Posts: 55
Joined: Mon Jan 01, 2018 5:20 pm

Re: QuMagie release

Post by zebulon2 » Wed Jun 26, 2019 9:56 pm

I will wait for the new beta.

zebulon2
Getting the hang of things
Posts: 55
Joined: Mon Jan 01, 2018 5:20 pm

Re: QuMagie release

Post by zebulon2 » Fri Jun 28, 2019 3:27 pm

Just tried the public beta 2 (the "good" one, 0978) and it seems that they have corrected this service start error issue. Still have a problem in QuMagie, but this will probably require a QuMagie (Core) update.

Post Reply

Return to “Photo Station, Music Station, Video Station”