QuMagie Bugs

Please post your questions about using the web-based Photo, Music, Video Stations here.
mwwsh
New here
Posts: 6
Joined: Thu May 23, 2019 11:13 pm

QuMagie Bugs

Post by mwwsh » Mon Dec 16, 2019 5:25 pm

Just tried QuMagie
Great software in principle but its not really a version 1 release - too many issues.

Here's a list of my issues :-
1) No thumbnails in "Things". I have categories "Animal" etc which says 64 Photos, but clicking on the cateogry show 0 Photos.

2a) Facial Recognition doesn't get all the faces. I guess this will improve with time. I have a photo will 4 people in it but only 1 face is recognised. All faces are clear. Oddly Qumagie can recognise things which aren't faces as a face so this is odd.

2b) But trying to correct a recognition is poor.
eg I have 4 photos "recognised" for a person but 3 are wrong. I select a photo and remove the person from the tag but it then removes all 4 photos - even the one correctly matched.

3) Smart Albums - I've created a Smart Album for people tagged with 4 names - the album is empty and yet all the people have photos against them.

4) When re-creating "Things" - QNAP Multimedia console shows 21% complete but QuMagie shows 60.7% complete. One is wrong.

5) When "Review"ing a set of matches - I press "Different" and it gets stuck in a loop. I've left it 5 mins and nothing happens. Its fairly consistent which photos fails. If I refresh and go back in it will fail of the same file again. Sounds like the file is locked (and a reboot might fix it)

mwwsh
New here
Posts: 6
Joined: Thu May 23, 2019 11:13 pm

Re: QuMagie Bugs

Post by mwwsh » Tue Dec 17, 2019 1:00 am

I've tried a full "Object Recognition" re-run - took a few hours but no success.
Still suggests there are photos but when clicking on a category it says 0 Photos;

User avatar
dolbyman
Guru
Posts: 22816
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: QuMagie Bugs

Post by dolbyman » Tue Dec 17, 2019 1:22 am

best to report all those issues to qnap via ticket, nothing we can do about it here

mcgrete
Starting out
Posts: 17
Joined: Sat Dec 19, 2015 7:03 am

Re: QuMagie Bugs

Post by mcgrete » Tue Dec 17, 2019 2:46 pm

Hi,

I am trying QuMagie for 1st time. Regarding your experience, here is my limited experience from several hours; all of this took place while the system was indexing, generating thumbnails, facial recognition, etc; I am using a TS-453A (8GB RAM), recently reinitialized the entire NAS, updated firmware too; just finished restoring content (~4TB). Wish I would have only restored a limited content to test out QuMagie and others, to avoid extensive indexing, etc that could adversely affect my experience (speed wise), but surprisingly the speed was not too bad, but is more sluggish as QuMagie is attempting to display hundreds of photos in a category. For reference, Multimedia has found ~140k photos and ~5k videos and still going... QuMagie has only processed ~5k photos and ~3k videos at this point, still processing. I started about 4-5 hours back, roughly.

I have generally been sour on QNAPs apps. As a result, I have merely used the NAS as a consolidated backup system - way underutilized, but the software has been a bear to support my needs. It seems most software released today is relying upon users to be their testing grounds, and then work out bugs after it is released. Trying to capitalize on my investment in this NAS.

1) I don't have a problem with 'Things'; I get categories of things and thumbnails and photos.
* However, to use the 'Thing' for a search, you must create a Tag, e.g. goto 'Sea' thing, and select all pictures (which there is no select all!), and then tag as 'Sea'. Developers should at least enable 'select all' method inside a Thing to create a Tag. Ideally, someone should be able to use 'Sea' or some other things category directly without having to create a Tag from such a category that exists already.

2a) I have a range of photos from old and poor quality (early 1900's and a few in the 1800s) to new and great quality; at the moment, I would say that QuMagie is 'fair'; it appears to get better at recognition as you add more photos for a person. I don't expect it to recognize me at 1 yr, 5 yrs, 10 yrs, 20 yrs, etc. It was less accurate with 1960's/1970's photos, but the quality and changes for a person from 1 yr to 20 yrs required multiple identifications of the same person over the time periods. It may be most helpful perhaps if you/I let it work, and when it finds groups of pictures associated with a given timeframe (e.g. from my 2018 folder only) it may be better at grouping those that a person is in photos for the year than across multiple decades such as 1988 through 2018. I am not blown away, but I am not severely disappointed at this point.

2b) I have not had this issue that I am aware of.

3) I just tested this, for two people; worked for me. Did you verify that you wanted all four people in each picture (search using all criteria)? You may have selected that instead of 'search using any criteria'. The former will only give you photos when all 4 people are in each photo; the latter gives you any photo where at least 1 of the people are in the photo.

4) I have a discrepancy between % as well; I opened a ticket on this. Likely a lag with some thread to have them update; also, I don't think Multimedia gives update on 'Things' specifically, but only on Photos and Videos. So, it could be that Multimedia found X photos during indexing, but that QuMagie has yet completed its facial recognition thumbnails etc; so they may never agree until all services are completed. IMO...

5) Regarding 'different', I find QuMagie to be slower here for sure; but I have not had it crash. It doesn't take 5 minutes, it is less than 1 minute, maybe 10-30 seconds (I did not time it...)

Other issues:
A) QuMagie will not play MTS video formatted files. I have submitted a ticket to QNAP. I can find no documentation of what QuMagie will support and not support. Before my reinitialization, I used to play MTS files. I tried adding Codexpack, and VideoStation5; still no luck. I did find that PhotoStation2 (now it is v5) supported MTS files. Even if PhotoStation supports MTS files, I do not want to have to use 2-3 apps for photos & video. A total solution is desired, not multiple apps.

B) I can not find any documentation on anything regarding what will happen with the indexing or similar in QNAP or in QuMagie if I modify the creation date or filenames of files that QNAP or QuMagie have already indexed / tagged, etc. I have some cleaning up to do regarding GPS locations, date creations (wrong date in camera or scanned images from old photographs); I plan to use some other application, as QuMagie does not support any modification of such information (that would be a very nice add-on; having to use another package and then add more tags in QuMagie - lots of work. Anyone have experience here? Will / can QuMagie also recognize existing tags / metadata in the file and override or eliminate need for QuMagie to process the 'Thing' or 'Place' info? I have submitted a ticket on this too.

C) I can find no information on what one can / cannot accomplish with an Album. I only find the ability to share and to export; export creates a zip file and downloads to my computer. I did not try to share yet.

Thanks

hansdp
First post
Posts: 1
Joined: Sun Dec 22, 2019 4:24 am

Re: QuMagie Bugs

Post by hansdp » Wed Dec 25, 2019 6:22 pm

I experience similar issues.

Did you find a solution for the "No thumbnails in Things" problem?
I would like to get that one resolved on my system

foo_001
New here
Posts: 7
Joined: Wed Jan 11, 2017 2:57 pm

Re: QuMagie Bugs

Post by foo_001 » Sat Jan 04, 2020 6:18 am

I have similar issue with what you described under 5

5) When "Review"ing a set of matches - I press "Different"

It’s a very annoying bug, it always get stuck on the same photo. The only way to pass it is to find that individual picture and name it. But that’s not an easy task since I have 200k+ pics and it found a lot of faces. I have to go through all the faces and find that particular picture.

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 9957
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: QuMagie Bugs

Post by Moogle Stiltzkin » Sat Jan 04, 2020 12:22 pm

thx for sharing, but don't forget to ALSO report to here
https://service.qnap.com/


i reported somethings about qumagie also. requires more polish. but it's a good app concept once it's ready.
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 +16gb ddr4 Crucial+ QWA-AC2600 wireless+QXP PCIE
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TL-D400S 2x 4TB WD Red Nas (WD40EFRX) 2x 4TB Seagate Ironwolf, Raid5
[^] QNAP TS-659 Pro II
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-253D
[^] QNAP TS-228
[Mobile NAS] TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Qotom Pfsense|100dl/50ul MBPS FTTH Internet | Win10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
https://www.patreon.com/mooglestiltzkin

valiant
New here
Posts: 5
Joined: Sat Jan 18, 2020 6:52 pm

Re: QuMagie Bugs

Post by valiant » Sat Jan 18, 2020 7:19 pm

This is nothing, people!

QuMagie doesn't support any backup feature, which means that inevitably some day there will be an update (either to QuMagie/Core or Multimedia Console), which will wipe all of your endless hours of sorting, tagging and creating albums.

This has happened to me and many others (viewtopic.php?f=177&t=152566&p=740612), so think twice before spending too much time working in QuMagie, because you'll 100% lose your work -unless they decide to fix this nonsense...

User avatar
graemev
Getting the hang of things
Posts: 97
Joined: Sun Feb 12, 2012 10:17 pm

Re: QuMagie Bugs

Post by graemev » Sat May 16, 2020 3:37 am

Are folks seeing this behaviour:

QuMagie Core provides facial recognition and object recognition engines. Note: These processes run in the background and may affect system performance.
Facial Recognition
Working...
99% ( 30760 / 30771 )
Object Recognition
Working...
99% ( 30764 / 30771 )
CPU

Both have been sitting at 99% for several months ...

My guess is there are some photos in which it breaks , e.g. big photos, so it just constantly restarting

hectoroki
New here
Posts: 2
Joined: Tue Apr 14, 2020 6:02 am

Re: QuMagie Bugs

Post by hectoroki » Mon Jun 15, 2020 12:35 am

valiant wrote:
Sat Jan 18, 2020 7:19 pm
This is nothing, people!

QuMagie doesn't support any backup feature, which means that inevitably some day there will be an update (either to QuMagie/Core or Multimedia Console), which will wipe all of your endless hours of sorting, tagging and creating albums.

This has happened to me and many others (viewtopic.php?f=177&t=152566&p=740612), so think twice before spending too much time working in QuMagie, because you'll 100% lose your work -unless they decide to fix this nonsense...
I totally agree with you, this should have a backup function and not waste so many time on this.

Also, they need to correct the way the wrong tagged pictures are.. I am testing with only 1000 pics, and it's a big mess already, and i have around 300K .. Can't imagine what will happen when i fully blow up the analyze.

Hope they fix this, as this is my first Nas and i was really excited but starting to get dissapointed.

stonehz
New here
Posts: 5
Joined: Fri Sep 18, 2015 7:03 am

Re: QuMagie Bugs

Post by stonehz » Thu Jul 09, 2020 7:29 pm

Can we please add to the list that it QuMagie also scans .@__thumb folders which makes the recognition 100% slower (cause photos are scanned twice)
Raised here: https://www.reddit.com/r/qnap/comments/ ... ultimedia/ (by myself)
and another person here: viewtopic.php?t=154552

hectoroki
New here
Posts: 2
Joined: Tue Apr 14, 2020 6:02 am

Re: QuMagie Bugs

Post by hectoroki » Thu Jul 09, 2020 10:00 pm

Just updated the QuMagie, Photostation and Multimedia, and this made the thumbnail and face recognition start all over again

Mikelt
New here
Posts: 3
Joined: Mon Jul 27, 2020 7:10 pm

Re: QuMagie Bugs

Post by Mikelt » Tue Jul 28, 2020 6:51 pm

Hi, I am having a problem where facial recognition is not always happening on all photographs.

I have just moved about 50 photos over to a QNAP NAS directory and only a few have come up with with tagged or appear in the suggested set. I dont want to restart facial recognition as that seems to wipe out all matches which have to date bee successfully tagged. Is there a way to manually restart facial recognition for one directory only perhaps? .... or failing that to manually tag a person in a photo where the facial recognition hasn't done its job?
Many thanks to anyone who can help.

Mikelt
New here
Posts: 3
Joined: Mon Jul 27, 2020 7:10 pm

Re: QuMagie Bugs

Post by Mikelt » Thu Jul 30, 2020 1:44 am

I have found the function to manually tag faces in photos in the PhotoStation application. I am though amazed that the automatic recognition cannot see a face in what to me is the clearest of photos of a person and yet will conversely select a blurred unidentifiable face and request entry of the name. :?

mustard
Starting out
Posts: 20
Joined: Sat Jun 15, 2013 7:24 pm

Re: QuMagie Bugs

Post by mustard » Mon Dec 21, 2020 1:45 am

Mikelt wrote:
Thu Jul 30, 2020 1:44 am
I have found the function to manually tag faces in photos in the PhotoStation application. I am though amazed that the automatic recognition cannot see a face in what to me is the clearest of photos of a person and yet will conversely select a blurred unidentifiable face and request entry of the name. :?
Rather defeats the point of QuMagie is meant to replace Photostation though.

Post Reply

Return to “Photo Station, Music Station, Video Station”