How to disable FFMPEG process

Please post your questions about using the web-based Photo, Music, Video Stations here.
BunnyBomb
Starting out
Posts: 11
Joined: Thu Apr 17, 2014 10:43 pm

Re: How to disable FFMPEG process

Post by BunnyBomb » Tue Apr 29, 2014 2:02 am

Thanks for the reply.

I suppose I thought if this was happening to me, it simply must be happening to others who would better articulate the issue than I.

For my own NAS, I'm finding it struggling to load any other App I use. It's like using dial-up internet to access photos, use FTP, everything. I've manually ended the process via shell today and everything is back to normal. I can continue doing this, but I suppose my question was more - is there a better fix coming, or will we continue to have to deal with ffmpeg this way forever?

StardustOne
Know my way around
Posts: 117
Joined: Sat Sep 15, 2007 5:18 am

Re: How to disable FFMPEG process

Post by StardustOne » Sun Jul 20, 2014 10:02 pm

I am having the same issues, although I do have the Multimedia, Photostation, Filestation enabled. But hey, I have it enabled because of the wonderful promises by Qnap that everything on these NAS is so easy and quick.

I do not mind of having background tasks running, yet isn't there a way to make these software updates a bit less CPU hungry? Why can't this silly ffmepg program run with less CPU power? It only creates a few thumbnails and it does a bit of trans coding, right? Who writes such bad software in the first place? Okay, it is open source, yes and sometimes, what does not cost much is not worth much. Or is the people who integrate the software into a NAS software build to blame?

Why can't we get more control over such things? e.g. setting the tasks to run with less priority or restrict their CPU usage? It is about time that Qnap implements features that allows us non-experienced users to control what is going on without having to use putty and to write scripts. I bought Qnap because it is so easy to work with them, seems to be not so easy after all.

Running the 4.1 software on the 2 GHz TS-419P II does run that ffmpeg at 85 to 95% all the time while it is creating thumbnails. Hey, it is a thumbnail, not a 50 GB blu-ray file, can't this be done faster, at least a little bit? It is a turbo NAS after all :).

thunder.02dragon
New here
Posts: 5
Joined: Mon Aug 18, 2014 5:57 am

Re: How to disable FFMPEG process

Post by thunder.02dragon » Fri Aug 22, 2014 3:54 pm

I am too facing the same issue..I use to stream the video files to my PS3 and others but today its extreme as of this ffmpeg process..why its so buggy..darn all the videos that I am running are stopping due to 100%CPU my a**.

No official solution?

robertsst
New here
Posts: 5
Joined: Mon May 03, 2010 8:33 pm

Re: How to disable FFMPEG process

Post by robertsst » Tue Aug 26, 2014 2:28 am

Have you tried to transcode anything?

I had this issue and it was because someone had used the iPhone app and started to transcode a video.

User avatar
pwilson
Guru
Posts: 22568
Joined: Fri Mar 06, 2009 11:20 am
Location: Victoria, BC, Canada (UTC-08:00)

Re: How to disable FFMPEG process

Post by pwilson » Tue Aug 26, 2014 2:42 am

thunder.02dragon wrote:I am too facing the same issue..I use to stream the video files to my PS3 and others but today its extreme as of this ffmpeg process..why its so buggy..darn all the videos that I am running are stopping due to 100%CPU my a**.

No official solution?


Performance will return to normal, when your "Not Selected" NAS Model has finished scanning your Multimedia content. If you disable the Multimedia Management feature on your NAS, this will resolve it everywhere except File Station. If you don't want to use Photo Station, Music Station, File Station, Video Station, File Station etc going forward, this may be a solution for you.

It took 300 hours to scan my Multimedia on my old TS-419P+, but I have a lot of Multimedia files. When I migrated to a TS-470Pro, it took less than 24 hours to scan this same Multimedia.

Patrick M. Wilson
Victoria, BC Canada
QNAP TS-470 Pro w/ 4 * Western Digital WD30EFRX WD Reds (RAID5) - - Single 8.1TB Storage Pool FW: QTS 4.2.0 Build 20151023 - Kali Linux v1.06 (64bit)
Forums: View My Profile - Search My Posts - View My Photo - View My Location - Top Community Posters
QNAP: Turbo NAS User Manual - QNAP Wiki - QNAP Tutorials - QNAP FAQs

Please review: When you're asking a question, please include the following.

User avatar
pwilson
Guru
Posts: 22568
Joined: Fri Mar 06, 2009 11:20 am
Location: Victoria, BC, Canada (UTC-08:00)

Re: How to disable FFMPEG process

Post by pwilson » Tue Aug 26, 2014 2:44 am

robertsst wrote:Have you tried to transcode anything?

I had this issue and it was because someone had used the iPhone app and started to transcode a video.


Your TS-109/209 Pro device does not support Transcoding.

Patrick M. Wilson
Victoria, BC Canada
QNAP TS-470 Pro w/ 4 * Western Digital WD30EFRX WD Reds (RAID5) - - Single 8.1TB Storage Pool FW: QTS 4.2.0 Build 20151023 - Kali Linux v1.06 (64bit)
Forums: View My Profile - Search My Posts - View My Photo - View My Location - Top Community Posters
QNAP: Turbo NAS User Manual - QNAP Wiki - QNAP Tutorials - QNAP FAQs

Please review: When you're asking a question, please include the following.

User avatar
pwilson
Guru
Posts: 22568
Joined: Fri Mar 06, 2009 11:20 am
Location: Victoria, BC, Canada (UTC-08:00)

Re: How to disable FFMPEG process

Post by pwilson » Tue Aug 26, 2014 2:47 am

BunnyBomb wrote:Thanks for the reply.

I suppose I thought if this was happening to me, it simply must be happening to others who would better articulate the issue than I.

For my own NAS, I'm finding it struggling to load any other App I use. It's like using dial-up internet to access photos, use FTP, everything. I've manually ended the process via shell today and everything is back to normal. I can continue doing this, but I suppose my question was more - is there a better fix coming, or will we continue to have to deal with ffmpeg this way forever?


Hard to help with your "Not Selected" NAS model. :shock:

Patrick M. Wilson
Victoria, BC Canada
QNAP TS-470 Pro w/ 4 * Western Digital WD30EFRX WD Reds (RAID5) - - Single 8.1TB Storage Pool FW: QTS 4.2.0 Build 20151023 - Kali Linux v1.06 (64bit)
Forums: View My Profile - Search My Posts - View My Photo - View My Location - Top Community Posters
QNAP: Turbo NAS User Manual - QNAP Wiki - QNAP Tutorials - QNAP FAQs

Please review: When you're asking a question, please include the following.

jkelso
New here
Posts: 5
Joined: Fri Sep 17, 2010 8:46 am

Re: How to disable FFMPEG process

Post by jkelso » Tue Oct 28, 2014 8:39 am

="pwilson
Hard to help with your "Not Selected" NAS model. :shock:


You kill me Patrick :lol: You are of course absolutely right.

I do appreciate all the help I have found reading your replies.

Thanks.

PS. I also tried going to Control Panel, Multimedia Management, Media Library set a schedule and unchecked "set media scanning priority to high" Once it starts the scheduled scan tonight I suppose my old TS410 might choke again but I can't afford an upgrade so I will have to live with it.

silvain24
New here
Posts: 7
Joined: Wed Jun 25, 2014 12:10 am

Re: How to disable FFMPEG process

Post by silvain24 » Thu Nov 13, 2014 10:36 pm

Hi,

I have a HS-210 with last november's firmware release, i still have the same problem.

Each time i launch the File Station, and go in my private Video folder (witch is not in multimedia folder), i have 30 or 40 ffmped who starts just to create thumbnail. I let you imagine the memory consuption for a 50 movies folder (mkv between 4 and 20GB per video). The NAS don't responding for 30 or 40 minutes. Worse, if two users go in the same directory at the same time, ffmeg processes are twice for each video!!
All my transcoding options and multimedia options are disabled. I'm using only filestation and AFP protocol. All others are disabled.

I'm very disappointed with this NAS, i've chose it because fanless, but the global performances are so poor, even for private use.

joergzwingli
New here
Posts: 4
Joined: Sat Mar 06, 2010 2:05 am
Location: Switzerland
Contact:

Re: How to disable FFMPEG process

Post by joergzwingli » Wed Dec 31, 2014 7:21 am

Hi to everybody,

I had been facing this problem with FFMPEG process causing a high CPU usage in several occasions on a TS219P with different firmware versions. What surprised me most that I had my NAS running for several month at low CPU usage with around 300GB of multimedia files all kind. I am streaming and I use Photo, Music and Video station so obviously my Media Library Station is running!
Then all of a sudden I noticed the increase of the CPU usage caused by the FFMPEG process. First I had no idea why and when it became like this. As I said I had not changed my data significantly so why should it keep running for a long time. I checked the forums here and tried all the advices but without success.
Switching off all services and restarting the NAS didn't help. Then one time I reloaded the same firmware version and for some reason it was gone. But because I didn't put much of attention to what was the specific step that helped to get rid of the problem I forgot about it as it was again running perfectly as before. After several months of normal operation I faced it again three days ago. The only thing I remembered that I had a regular restart with all the services running. Likely this caused the problem.
Now what I did:
1.) I deactivated the Media Library completely and turned off Twonky and the DNLA Station too.
2.) Stopped all backup and real time synchronization tasks and ejected the external HD's
3.) Reloaded the latest firmware 4.1.2 again and waited for the restart after the firmware reload.
4.) I waited for about 15min to see of the FFMPEG process would come up again as it used to do before. All good.
5.) Enabling one task after another did not cause this process to pop up again. So my system is running smoothly as before.

Out of this cognition I believe there must be an issue with the software. I feel that a restart or an upgrade of the firmware while all the tasks are running is critical. It looks as if not all the processes start up correctly and FFMPEG process falls into a never ending loop no matter if Media Library is enabled or disabled.

Hope this observation will help other users to get rid off their problems and I feel that the engineers of QNAP should check if there might be a hidden firmware bug.

Good success
Joerg

User avatar
Toxic17
Ask me anything
Posts: 5694
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: How to disable FFMPEG process

Post by Toxic17 » Wed Dec 31, 2014 8:18 am

Jerg, just out of curiosity have you submitted a ticket to qnap, your post here does not mention if you had contacted them, posting the issue and findings here is good for users to see, but will go unnoticed by QNAP, unless you contact them directly.
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.5.3.1652 • TVS-463-16GB 4.5.3.1652 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1624 • APC Back-UPS ES 700G
Network: VM Hub3 • UniFi UDM Pro 1.10-0.9 • Controller: 6.2.23 • UniFi US-16-150W/US-8-60W 5.60.3 • USW Mini Flex 1.8.4 • UniFi G3-Flex • AP: AC Pro 5.60.3 • U6-LR 5.60.3

joergzwingli
New here
Posts: 4
Joined: Sat Mar 06, 2010 2:05 am
Location: Switzerland
Contact:

Re: How to disable FFMPEG process

Post by joergzwingli » Thu Jan 01, 2015 6:21 am

Dear Simon
I haven't opened a ticket with QNAP yet but I'm going to do it. Thanks for your input.

Best regards
Joerg

iunlock
Getting the hang of things
Posts: 68
Joined: Sat Aug 01, 2015 1:04 pm

Re: How to disable FFMPEG process

Post by iunlock » Fri Aug 21, 2015 6:00 pm

Thanks Joerg. Great info.....

RadimCZ
First post
Posts: 1
Joined: Thu Feb 25, 2016 4:32 pm

Re: How to disable FFMPEG process

Post by RadimCZ » Thu Feb 25, 2016 4:47 pm

I had the same trouble with 100% CPU usage. It was caused by "VIDEO STATION LITE" application. So I sent this application to ** - and now it is OK :)
// Anyway, "Video station" application does not cause any similar troubles...

ja666
Know my way around
Posts: 182
Joined: Sat Nov 29, 2014 5:21 pm

Re: How to disable FFMPEG process

Post by ja666 » Thu Jul 28, 2016 7:59 pm

StardustOne wrote:Running the 4.1 software on the 2 GHz TS-419P II does run that ffmpeg at 85 to 95% all the time while it is creating thumbnails.
What I learned if you move (with File Station 'copy/move to' command) photo-video files / directories within your share / folder, the indexing / thumbnail creation starts from scratch. Why? That's ridiculous the thumbnails are not moved together with their corresponding files :evil:

Post Reply

Return to “Photo Station, Music Station, Video Station”