Constant email alerts since update

Discussion on remote replication.
jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Constant email alerts since update

Postby jccpaul » Fri Mar 10, 2017 2:46 am

Hi all, I need a little help with this since I haven't been able to figure it out. Last month we had a drive fail so we replaced it. We had some issues after swapping the drive which resolved by working with support. We had to upgrade the firmware and software and such. So everything is up to date. But we're having issues with constant email alerts now I need some help figuring out.

QNAP details:
TS-869U-RP
Firmware 8.2.3 build 20170213

Here are the latest emails I got from the QNAP:
Server Name: dataServer8bay
IP Address: 192.168.2.13
Date/Time: 2017/03/09 08:00:03
Level: Warning
[Remote Replication] (Sync) Logs Backup failed: rsync: getaddrinfo: ts1 873: Name or service not known Begin 1st retry.

Server Name: dataServer8bay
IP Address: 192.168.2.13
Date/Time: 2017/03/09 08:00:04

Server Name: dataServer8bay
IP Address: 192.168.2.13
Date/Time: 2017/03/09 08:01:07
Level: Warning
[Remote Replication] (Sync) Logs Backup failed: rsync: getaddrinfo: ts1 873: Name or service not known Begin 2nd retry.

Server Name: dataServer8bay
IP Address: 192.168.2.13
Date/Time: 2017/03/09 08:01:07
Level: Warning
[Remote Replication] (Sync) Logs Backup failed: rsync: getaddrinfo: ts1 873: Name or service not known Begin 2nd retry.

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Wed Mar 15, 2017 7:45 am

Anyone??

dolbyman
Experience counts
Posts: 4518
Joined: Sat Feb 12, 2011 2:11 am
Model: TS-419P+
Location: Vancouver BC , Canada

Re: Constant email alerts since update

Postby dolbyman » Wed Mar 15, 2017 7:52 am

there is no firmware 8.x.x (yet) ...so I guess that is supposed to say 4.x.x

regarding the problem...

there is obviously a second nas (ts 873?) that cannot be reached for remote backups .. hence the error message ...so more info about the whole setup please

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Wed Mar 15, 2017 7:59 am

More details, we have 8 different jobs scheduled with different sync frequencies. They all say "Finished" yet I continue to get these error alert emails.

dolbyman
Experience counts
Posts: 4518
Joined: Sat Feb 12, 2011 2:11 am
Model: TS-419P+
Location: Vancouver BC , Canada

Re: Constant email alerts since update

Postby dolbyman » Wed Mar 15, 2017 10:55 am

are those jobs going to different nas units ?

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Wed Mar 15, 2017 8:15 pm

They all go to the same NAS named "ts1", and as I mentioned they all say finished when I look at the job schedule. Yet it still sends me emails that they fail. I get the failure of logs the most since that happens daily. I do also see the others from time to time.

P3R
Ask me anything
Posts: 8193
Joined: Sat Dec 29, 2007 1:39 am
Model: TS-459 Pro II
Location: Stockholm, Sweden (UTC+01:00)

Re: Constant email alerts since update

Postby P3R » Wed Mar 15, 2017 9:05 pm

jccpaul wrote:They all go to the same NAS named "ts1", and as I mentioned they all say finished when I look at the job schedule.
A job will have a status of "Finished" when it isn't running any more. "Finished" isn't the same as "Successful" and you won't see "Unsuccessful" there either.

Check the job log if you want more details on what happened. My guess is the log will indicate a bad connection between the two systems.

What more specifically than a "NAS" is the remote system? Is it located on the same ip network?

What Remote Replication mode found in which application (Backup Station or Hybrid Backup Sync) are you running?
RAID have never ever been a replacement for backups. Without backups on a different system (preferably placed at another site), you will eventually lose data!

A non-RAID configuration (including RAID 0, which isn't really RAID) with a backup on a separate media protects your data far better than any RAID-volume without backup.

All data storage consists of both the primary storage and the backups. It's your money and your data, spend the storage budget wisely or pay with your data!

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Thu Mar 16, 2017 11:27 pm

oh, well thats good to know. So these jobs might not actually be completing. Ive been somewhat ignoring the messages since I thought they were still finishing. Thats a little misleading.....Yes the are on the same IP 192.168.2.x and we're using Backup Station, the other system is a Buffalo Terastation NAS.

I have gone into the replication job and from the settings there and theres a TEST, the test is successful. I guess that tells me that it sees the network name/port and the credentials work.

The most I get from the logs is "name or service not known". From my PC I can ping the name fine. I logged into the terastation and 95.71% full, not sure if that has anything to do with it. So theres about 450gb free.

P3R
Ask me anything
Posts: 8193
Joined: Sat Dec 29, 2007 1:39 am
Model: TS-459 Pro II
Location: Stockholm, Sweden (UTC+01:00)

Re: Constant email alerts since update

Postby P3R » Fri Mar 17, 2017 3:29 pm

jccpaul wrote:Yes the are on the same IP 192.168.2.x and we're using Backup Station...
And in Backup Station you use Rsync?
The most I get from the logs is "name or service not known".
Which log? The System Log or the job log within Backup Station?
RAID have never ever been a replacement for backups. Without backups on a different system (preferably placed at another site), you will eventually lose data!

A non-RAID configuration (including RAID 0, which isn't really RAID) with a backup on a separate media protects your data far better than any RAID-volume without backup.

All data storage consists of both the primary storage and the backups. It's your money and your data, spend the storage budget wisely or pay with your data!

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Sun Mar 19, 2017 8:57 am

The jobs are under Remote Replication > NAS to NAS

And the log I looked at was just under System logs > system event logs

P3R
Ask me anything
Posts: 8193
Joined: Sat Dec 29, 2007 1:39 am
Model: TS-459 Pro II
Location: Stockholm, Sweden (UTC+01:00)

Re: Constant email alerts since update

Postby P3R » Sun Mar 19, 2017 9:30 am

jccpaul wrote:The jobs are under Remote Replication > NAS to NAS
It isn't documented well but the NAS to NAS option is intended only for when both source and destinations are Qnaps. Since your remote system is non-Qnap, you should use the option Rsync.
And the log I looked at was just under System logs > system event logs
To hopefully get to know slightly more you could also look at the log within Backup station, when you've highlighted the specific backup task. But first you'd better try using Rsync instead of NAS to NAS.
RAID have never ever been a replacement for backups. Without backups on a different system (preferably placed at another site), you will eventually lose data!

A non-RAID configuration (including RAID 0, which isn't really RAID) with a backup on a separate media protects your data far better than any RAID-volume without backup.

All data storage consists of both the primary storage and the backups. It's your money and your data, spend the storage budget wisely or pay with your data!

jccpaul
New here
Posts: 7
Joined: Fri Mar 10, 2017 2:32 am
Model: TS-859U

Re: Constant email alerts since update

Postby jccpaul » Sun Mar 19, 2017 9:36 am

Thanks for the help


Return to “Remote Replication/ Disaster Recovery”

Who is online

Users browsing this forum: No registered users and 1 guest