Page 1 of 1

CANT CONNECT TO DESTINATION NAS USING RTRR

Posted: Sun Feb 02, 2020 6:05 pm
by hollowman
Hello, I am new to RTRR. I am trying to setup RTRR or Rsync. The setup is easy and I am confident I am doing it correctly. Everything appears good until I try to connect to the remote NAS. The remote NAS is at a different location (my brothers house). I have followed many online tutorials as well, and it is fairly easy to use and setup.

My problem is not the setup, but connecting to the remote NAS. I tried connecting to the remote NAS via RTRR with the WAN IP address, but I just get error "failure" when I press test button. There is something blocking me on the destination NAS (TS-431), like a port / firewall or something. I've port forwarded 873 and 8899 on the router in the remote/destination and it still will not work. I don't think port forward is necessary but I did it anyway, I don't know what else to do. I went to port checker website and most or all common ports are closed.

I have read that using qnapcloud is best for this, so I created a qnapcloud account on both NAS devices (host and destination nas). After inputting the qnapcloud details in in the host NAS, it sill will not allow me to connect.
On the remote NAS, I get errors on all ports on the remote NAS in the web connectivity (see attached pictures of remote nas).

Just a side note: there is a google mesh attached to the modem at the destination NAS, but I doubt this will effect anything as it only provides extended wifi to the house.

Can anyone please help

Thank you.

Re: CANT CONNECT TO DESTINATION NAS USING RTRR

Posted: Sun Feb 02, 2020 7:28 pm
by P3R
  1. You expose a public IP in the second of your attachments. I strongly recommend that you quickly edit your post and remove it!
  2. Qnap have historically promoted exposing the NAS to everyone on the internet but in light of the many hacker attacks and malware infections, the latest being called QSnatch, that have plagued Qnap users for years they have finally turned around and are now starting to recommend a much more restrictive approach to NAS internet exposure.
  3. Most if not all experienced administrators would agree on that the only reasonably secure and recommended way to connect remotely over the internet is with a VPN-solution in place. In this case a site-to-site VPN would be required and that is best implemented at the internet-facing firewalls/routers at the respective site. With that in place you no longer have to worry about opening specific ports for different services that many users find complicated.
  4. You seem to use the router UPnP-feature that have a bad track record for security and you expose a lot of services not needed for objective in the topic of this thread. Security-wise that's a nightmare and an open invitation to all the bad guys out there!

Re: CANT CONNECT TO DESTINATION NAS USING RTRR

Posted: Sun Feb 02, 2020 8:39 pm
by hollowman
P3R, I don't know how I missed that, I have removed the IP address from my attachment.

Thanks for the security tip

Re: CANT CONNECT TO DESTINATION NAS USING RTRR

Posted: Tue Feb 04, 2020 3:37 pm
by hollowman
Never mind everyone. thank you everyone for helping.

Iv taken the destination NAS to another location and it worked straight away.

There appears to be something blocking the destination NAS at the location, possibly ISP related issues. It could also be modem/firewall or google wifi that is connected to the modem blocking everything. I have not figured it out.

All I know that something is blocking incoming connections at the location. I have moved my NAS to another location with good internet and it working good.