No access to subfolders of RSYNC backup folder

Discussion on remote replication.
Post Reply
andrehj
Getting the hang of things
Posts: 58
Joined: Sat Oct 10, 2009 8:59 pm

No access to subfolders of RSYNC backup folder

Post by andrehj » Sun Oct 11, 2009 5:52 am

I am using Deltacopy to backup my Windows (Vista x64 ultimate SP2) machine to a QNAP TS-119 NAS using the rsync protocol. For this purpose I made a backup folder with administrator group access on the QNAP. This works well, because I can read and write in this folder. However, I CANNOT read or write in the subfolders (which were created by the rsync backup process) of this backup folder.
I cannot access these subfolders through FTP, Network (in Windows Explorer) or the Web File Manager.

What am I doing wrong here, because one the most important things with a backup is that it you should have ACCESS to it when something goes wrong with the original file... :?

Any help is appreciated,

Andrehj

GeoffC
Starting out
Posts: 16
Joined: Wed Aug 26, 2009 7:51 pm

Re: No access to subfolders of RSYNC backup folder

Post by GeoffC » Mon Oct 12, 2009 5:25 am

I have tried DeltaCopy and I could certainly read files in the backup (I didn't want / need write access to the backups).

Are you using DeltaCopy client to push the backups to the NAS or are you using server to allow the NAS to pull the backups?

What happens if you allow 'everyone' access to the backup folder?

andrehj
Getting the hang of things
Posts: 58
Joined: Sat Oct 10, 2009 8:59 pm

Re: No access to subfolders of RSYNC backup folder

Post by andrehj » Tue Oct 13, 2009 2:18 am

Dear GeoffC,

GeoffC wrote:I have tried DeltaCopy and I could certainly read files in the backup (I didn't want / need write access to the backups).
Are you using DeltaCopy client to push the backups to the NAS or are you using server to allow the NAS to pull the backups?
What happens if you allow 'everyone' access to the backup folder?


Thanks for your reply,
I use Deltacopy to push the backups to the NAS. I even modified access to the backup folder to everyone (gave everyone group and guests read only rights). This makes no difference, I can still browse the backup folder and create files there, but somehow these rights do not get copied to the subfolders (created by the backup routine). So I still cannot access my own backups. Not with FTP, not as network share, not at all! :evil:
The only (small) exception is the Web File Manager: in the Web File Manager I can browse my folders (view directory listings) but I still cannot view or download my files.

Today I did some more tests:
- Restore (with Deltacopy) works, but there is no way I can restore only one file...
- Upgraded rsync to cwrsync's version 3.0.6 (including their cygwin1.dll and cyggcc_s-1.dll) . This solved my problem of rsync hanging after several folders, but no changes in access...
- Added -p parameter, does not help.
- Removed compression during transfer, does not help.

Can anybody (QNAP experts?) give me a clue?

andrehj
Getting the hang of things
Posts: 58
Joined: Sat Oct 10, 2009 8:59 pm

Only admin account can access subfolders of RSYNC backup fol

Post by andrehj » Wed Oct 14, 2009 5:06 am

Today I did some more tests:

I wanted to see if I could get to my files with telnet. So I installed Putty and logged in with admin (I normally use a different account from the administrators group). And I had access to my files!
So I changed my network share username and FTP login to admin, and I had access! :D

Now I have a new problem: In Deltacopy I use a different account name from the administrators group to connect to my Qnap. But why can this user not access these files? Why is the admin user the only one who has access? :evil:
Below is the output from ls -alt:

[/share/Backup/testdir] # ls -alt
drwxr-xr-x 2 admin administ 4096 Oct 13 21:44 ./
-rwx------ 1 admin administ 134551 Oct 13 21:44 picture.jpg*
drwx------ 4 admin administ 12288 Oct 13 21:42 ../
[/share/Backup/testdir] #

Who can give me a clue in the right direction?

andrehj

SamuelTee
New here
Posts: 4
Joined: Wed Oct 14, 2009 4:21 pm

Re: No access to subfolders of RSYNC backup folder

Post by SamuelTee » Wed Oct 14, 2009 4:36 pm

Hy all,

Since DeltaCopy uses rsync via cygwin the following might help:
Create a (global) environment variable CYGWIN and set its value to "nontsec" (without the quotes).

cygwin activates the acl (user privileges a.s.o.) per default but messes alot with that on NTFS filesystems. The above environment variable disables that.

If your cygwins version is 1.7 the above trick doesn't work because the new cygwin works different. In that case a little more work is to be done:

    - create a subfolder "etc" in your DeltaCopy main dir
    - create a file "fstab" in that folder with the following content

    Code: Select all

    none /cygdrive cygdrive binary,posix=0,user,noacl 0 0

Now it should work.

If not you might want to try another GUI tool based on rsync. Try this.

andrehj
Getting the hang of things
Posts: 58
Joined: Sat Oct 10, 2009 8:59 pm

Re: No access to subfolders of RSYNC backup folder

Post by andrehj » Wed Oct 14, 2009 11:20 pm

Hi SamuelTee,

Thanks for your elaborate reply, I will try your suggestions tonight.
SamuelTee wrote:If your cygwins version is 1.7 the above trick doesn't work because the new cygwin works different. In that case a little more work is to be done:

I have two versions of cygwin1.dll: 1005.0.0.0 and 1007.0.0.0 I'm using the last one, since that is the one that's required for cwRsync's sync.exe version 3.0.6
Is version 1007.0.0.0 the same as version 1.7?
SamuelTee wrote:If not you might want to try another GUI tool based on rsync. Try this.

This program doesn't seem to be able to email a backup report. I really need this feature, because otherwise I will never be notified of backup problems.

Regards, Andrehj

SamuelTee
New here
Posts: 4
Joined: Wed Oct 14, 2009 4:21 pm

Re: No access to subfolders of RSYNC backup folder

Post by SamuelTee » Mon Oct 19, 2009 2:31 am

Hy andrehj,

so it seems your cygwin is version 1.7.

So try this /etc/fstab suff. It should work. At least it worked for me 'cause I had the exact same problem ;-)

As for the mail-support in QtdSync ... you're right. That might be a feature I should suggest to the author ;-)

andrehj
Getting the hang of things
Posts: 58
Joined: Sat Oct 10, 2009 8:59 pm

Re: No access to subfolders of RSYNC backup folder

Post by andrehj » Mon Oct 19, 2009 7:59 pm

SamuelTee wrote:Hy all,

Since DeltaCopy uses rsync via cygwin the following might help:
Create a (global) environment variable CYGWIN and set its value to "nontsec" (without the quotes).
cygwin activates the acl (user privileges a.s.o.) per default but messes alot with that on NTFS filesystems. The above environment variable disables that.
If your cygwins version is 1.7 the above trick doesn't work because the new cygwin works different. In that case a little more work is to be done:
    - create a subfolder "etc" in your DeltaCopy main dir
    - create a file "fstab" in that folder with the following content

    Code: Select all

    none /cygdrive cygdrive binary,posix=0,user,noacl 0 0
Now it should work.

Hi SamuelTee,

Today I finally found some time to try your suggestions. However, they do not seem to work. Also, from this post on the Deltacopy Forum I conclude that your suggestions are for Deltacopy Server (am I correct?) and not for Deltacopy Client (which I use).

I also found that Deltacopy uses the -rlt parameter, which seems to do something with rights, but I cannot find out exactly what it does. Could this be the problem?

SamuelTee
New here
Posts: 4
Joined: Wed Oct 14, 2009 4:21 pm

Re: No access to subfolders of RSYNC backup folder

Post by SamuelTee » Tue Oct 20, 2009 5:38 pm

Hy Andrehj,

sorry. The trick i posted has one bug (and it is supposed to work for the DeltaCopyClient too): To use that /etc/fstab-stuff it is necessary to locate the etc folder one level higher in the tree hierarchy. So try the following.

1. In you DeltaCopy main dir create a folder called "bin"
2. Copy all the stuff from the DeltaCopy maindir into the created dir.
3. Now do the /etc/fstab stuff I described (Note: the etc folder must be located in the main dir, too)
4. Now run DeltaCopy from the bin folder (You might want to adjust references, links etc).

Greets,
SamuelTee

Post Reply

Return to “Remote Replication/ Disaster Recovery”