REXP drive no longer visible

Questions about SNMP, Power, System, Logs, disk, & RAID.
waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Thu Feb 13, 2020 6:09 am

no such command

Code: Select all

[~] # lspci
-sh: lspci: command not found
[~] #
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

User avatar
OneCD
Ask me anything
Posts: 6964
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: REXP drive no longer visible

Post by OneCD » Thu Feb 13, 2020 4:18 pm

waninae39 wrote:
Wed Feb 12, 2020 9:59 pm
i use the text based command line to access any commands

is there a command to check the SAS card on the NAS?
waninae39 wrote:
Thu Feb 13, 2020 6:09 am

Code: Select all

[~] # lspci
-sh: lspci: command not found
[~] #
If you don't mind using the CLI, then suggest installing the Entware QPKG via the Qnapclub Store repo. You'll then be able to add additional utilities like 'lspci':

Code: Select all

opkg install pciutils

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
storageman
Ask me anything
Posts: 5488
Joined: Thu Sep 22, 2011 10:57 pm

Re: REXP drive no longer visible

Post by storageman » Thu Feb 13, 2020 5:16 pm

waninae39 wrote:
Thu Feb 13, 2020 6:09 am
no such command

Code: Select all

[~] # lspci
-sh: lspci: command not found
[~] #
Works on mine

waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Thu Feb 13, 2020 8:23 pm

another unknown command

Code: Select all

[~] # opkg install pciutils
-sh: opkg: command not found
[~] #
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

User avatar
OneCD
Ask me anything
Posts: 6964
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: REXP drive no longer visible

Post by OneCD » Fri Feb 14, 2020 4:01 am

waninae39 wrote:
Thu Feb 13, 2020 8:23 pm
another unknown command

Code: Select all

[~] # opkg install pciutils
-sh: opkg: command not found
[~] #
Did you install Entware first?

You also need to logout your current SSH session then login again (so your $PATH is updated) before you can use ‘opkg’.

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Fri Feb 14, 2020 6:34 am

this is what lspci shows

Code: Select all

[~] # lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 05)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Desktop SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
02:00.0 USB controller: Etron Technology, Inc. EJ188/EJ198 USB 3.0 Host Controller
03:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9235 PCIe 2.0 x2 4-port SATA 6 Gb/s Controller (rev 10)
04:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9235 PCIe 2.0 x2 4-port SATA 6 Gb/s Controller (rev 10)
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Fri Feb 14, 2020 6:51 am

plugging the sata cable in and running the command again shows the same results

no lights appear on the NAS or the REXP
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Wed Feb 19, 2020 6:02 am

i get a new sata cable to the REXP.

it did NOT fix it.
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

waninae39
Know my way around
Posts: 179
Joined: Mon Jun 09, 2008 11:32 am

Re: REXP drive no longer visible

Post by waninae39 » Fri Feb 28, 2020 10:58 am

a new i/f board in the main QNAp and a new cable to the REXP

its back up again
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

Post Reply

Return to “System & Disk Volume Management”