updated firmware, can't see shared drives or data

Questions about SNMP, Power, System, Logs, disk, & RAID.
Post Reply
benh2o
New here
Posts: 4
Joined: Sun Sep 08, 2019 11:01 pm

updated firmware, can't see shared drives or data

Post by benh2o » Sun Sep 08, 2019 11:12 pm

i have a TS-431P. we recently did a firmware update on friday and now I can't see any of the shared drives, either through the Qnap Cloud (which worked the day before), or internally on our LAN. I was never asked to reformat or initialize any drives, so I data should all be there, but it seems path to it is broken. Now, I did notice when it was updated we were prompted to enter device name and for some reason we used a different name then what we had before. So, perhaps the device name change is causing this issue? I'm a noob at this stuff, so excuse my ignorance. these are our companies man working files, so REALLY need some help here. I've opened a support ticket with Qnap but so far nothing has been done :( . help.

benh2o
New here
Posts: 4
Joined: Sun Sep 08, 2019 11:01 pm

Re: updated firmware, can't see shared drives or data

Post by benh2o » Sun Sep 08, 2019 11:22 pm

let me be clearer... i can see the drives through the online control panel. three of the four drives are in use on our device. but, it's not showing any volumes. could it be as simple as changing the name of the device back to what it used to be called? I'm scared to try anything that would potentially jeopardize the data on these drives...

User avatar
Toxic17
Ask me anything
Posts: 5241
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: updated firmware, can't see shared drives or data

Post by Toxic17 » Sun Sep 08, 2019 11:50 pm

A firmware upgrade should not ask/prompt for a device name. it just updates the Operating system. So this prompt sounds like there has more gone on than just a Firmware Update.

firstly lets see some information

NAS Model.
Firmware Version including build Number.
What exact hard drives are fitted including type of raid configuration.

Also what if any Backup plan do you have in place for the data held on the NAS?
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.1.1146 • TVS-463-16GB 4.4.1.1146 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1098 • APC Back-UPS ES 700G •
QPKG's: TwonkyServer 8.51 • Apache73 v2441.7310 • QSonarr 3.0.3.645 • QNBZGet 21.0 • phpMyAdmin 4.9.0.1 • Qmono 5.20.1.19 • McAfee 3.0.1 • Lychee 3.2.16 • HBS 3.0.191016 • LEgo v3.1.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+• UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

benh2o
New here
Posts: 4
Joined: Sun Sep 08, 2019 11:01 pm

Re: updated firmware, can't see shared drives or data

Post by benh2o » Mon Sep 09, 2019 12:00 am

Toxic17 wrote:
Sun Sep 08, 2019 11:50 pm
A firmware upgrade should not ask/prompt for a device name. it just updates the Operating system. So this prompt sounds like there has more gone on than just a Firmware Update.

firstly lets see some information

NAS Model.
Firmware Version including build Number.
What exact hard drives are fitted including type of raid configuration.

Also what if any Backup plan do you have in place for the data held on the NAS?
Thank you for responding. nas model is TS-431P, current firmware version is 4.3.6.1050. 3 WD 4tb drives installed (WD40EZRZ-00GXCB0) and i believe it's raid 5. i don't think there's any backup plan. we did have all the drives out of the NAS while we were performing the update, if that helps with anything else.

User avatar
Toxic17
Ask me anything
Posts: 5241
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: updated firmware, can't see shared drives or data

Post by Toxic17 » Mon Sep 09, 2019 12:20 am

sorry, what? you took to drive out whilst doing the firmware update? where have you read this procedure?

Firmware updates 99% of the time are done with the drives plugged in, and the update is run from the Firmware Update screen in the admin control panel of the NAS. see link below:

https://www.qnap.com/en/how-to/tutorial ... -firmware/

I am purely speculating but you have somehow upgraded the NAS via QFinder perhaps?

I am not sure what state your NAS will be in, the drives and data should be ok, as long as you plugged them back into the same slots they came out of and did not format or reinitialise the NAS and drives.

So we really need to know what exactly happened, and how. please explain what and how you managed a firmware update in detail, do not leave any info out.

also what firmware version were you on before this upgrade?
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.1.1146 • TVS-463-16GB 4.4.1.1146 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1098 • APC Back-UPS ES 700G •
QPKG's: TwonkyServer 8.51 • Apache73 v2441.7310 • QSonarr 3.0.3.645 • QNBZGet 21.0 • phpMyAdmin 4.9.0.1 • Qmono 5.20.1.19 • McAfee 3.0.1 • Lychee 3.2.16 • HBS 3.0.191016 • LEgo v3.1.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+• UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

benh2o
New here
Posts: 4
Joined: Sun Sep 08, 2019 11:01 pm

Re: updated firmware, can't see shared drives or data

Post by benh2o » Mon Sep 09, 2019 12:48 am

Ok, sorry, here’s more info. We had to evacuate because of Hurricane Dorian, we unplugged QNap and brought it safety and replugged in and everything was fine. When we returned, we did the same and that’s when we started having problems. 1) QNAP was not fully starting up. Constant Green blinking light. Not able to get to login screen
2) Removed all three drives and restarted
3) Was able to login but immediately got install latest firmware message. Updated firmware without drives installed
4) was able to login after firmware install
5) inserted drives and can see them but no data/volumes. Not sure if they were inserted in correct slots as previously inserted
6) Qnap cloud backup should have been running. Not sure how to access these files. Could be under my username?

User avatar
Toxic17
Ask me anything
Posts: 5241
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: updated firmware, can't see shared drives or data

Post by Toxic17 » Mon Sep 09, 2019 1:24 am

I would suggest you contact QNAP to see if they can recover the volumes for you. since its the weekend you wont get anything until tomorrow morning.

can you log into the NAS via SSH?
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.1.1146 • TVS-463-16GB 4.4.1.1146 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1098 • APC Back-UPS ES 700G •
QPKG's: TwonkyServer 8.51 • Apache73 v2441.7310 • QSonarr 3.0.3.645 • QNBZGet 21.0 • phpMyAdmin 4.9.0.1 • Qmono 5.20.1.19 • McAfee 3.0.1 • Lychee 3.2.16 • HBS 3.0.191016 • LEgo v3.1.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+• UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

ganekogorta
Starting out
Posts: 34
Joined: Sat Nov 21, 2009 7:31 am
Location: Bizkaia

updated firmware, can't see shared drives or data

Post by ganekogorta » Mon Sep 09, 2019 1:52 am

Hi
I'm in the same situation.
I've updated my TS-453Be from 20190704-4.3.6.0993 to 20190820-4.3.6.1040 and the shares are inaccesible from Windows :(
If I do a QTS downgrade to 4.3.6.0993, the shares are online again Image

In both cases I have no problem with QTS-web

User avatar
Toxic17
Ask me anything
Posts: 5241
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: updated firmware, can't see shared drives or data

Post by Toxic17 » Mon Sep 09, 2019 2:19 am

ganekogorta wrote:
Mon Sep 09, 2019 1:52 am
Hi
I'm in the same situation.
I've updated my TS-453Be from 20190704-4.3.6.0993 to 20190820-4.3.6.1040 and the shares are inaccesible from Windows :(
If I do a QTS downgrade to 4.3.6.0993, the shares are online again Image

In both cases I have no problem with QTS-web
this is not the same situation. Please start your own thread. if you read the topic, the user states he has no volumes as the NAS was upgraded with the hard disks removed.

You are also using 4.3.6.1040 which was removed by QNAP because of an SMB bug. QTS 4.3.6.1050 which has now been released is suppose to fix this issue.

if you upgrade to 4.3.6.1050 and you still experience SMB issues, then submit a ticket with QNAP.
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.1.1146 • TVS-463-16GB 4.4.1.1146 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1098 • APC Back-UPS ES 700G •
QPKG's: TwonkyServer 8.51 • Apache73 v2441.7310 • QSonarr 3.0.3.645 • QNBZGet 21.0 • phpMyAdmin 4.9.0.1 • Qmono 5.20.1.19 • McAfee 3.0.1 • Lychee 3.2.16 • HBS 3.0.191016 • LEgo v3.1.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+• UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

ganekogorta
Starting out
Posts: 34
Joined: Sat Nov 21, 2009 7:31 am
Location: Bizkaia

updated firmware, can't see shared drives or data

Post by ganekogorta » Mon Sep 09, 2019 3:09 am

Sorry, it’s true, not same case, you are right. I’ve read only the title.
Sorry again and thanks for your answer.

Post Reply

Return to “System & Disk Volume Management”