Disk's failure - Raid Error status (TS-451)

Questions about SNMP, Power, System, Logs, disk, & RAID.
Post Reply
alekons
Starting out
Posts: 21
Joined: Wed Jan 28, 2015 11:44 pm

Disk's failure - Raid Error status (TS-451)

Post by alekons » Tue Sep 17, 2019 2:12 am

Hi Experts,

Recently 2 out of 4 disks on my TS-451 had problems (Raid 10). One disk dissapear and the other one gives SMART warning and Disk access history (i/O) Error.
I replaced the faulty one on bay 1 (hotswap) but still the LUN status is error and cannot access any files.

Any idea? Where can i start troubleshooting.
For convinicence attached some screenshots from the Storage & Snapshots section

TS-451 - QTS 4.3.6 Build 1050

Thanks in advance
Alexis
QNAP TS-451 - 4 * Seagate NAS 4TB (RAID10) - FW: QTS 4.3.6 Build 1050

alekons
Starting out
Posts: 21
Joined: Wed Jan 28, 2015 11:44 pm

Re: Disk's failure - Raid Error status (TS-451)

Post by alekons » Tue Sep 17, 2019 2:34 am

Additional info :

Code: Select all

[admin@QNAPNAS ~]# cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath]
md322 : active raid1 sdd5[3](S) sdc5[2](S) sdb5[1] sda5[0]
      7235136 blocks super 1.0 [2/2] [UU]
      bitmap: 0/1 pages [0KB], 65536KB chunk

md256 : active raid1 sdd2[3](S) sdc2[2](S) sdb2[1] sda2[0]
      530112 blocks super 1.0 [2/2] [UU]
      bitmap: 0/1 pages [0KB], 65536KB chunk

md13 : active raid1 sdb4[1] sdd4[3] sdc4[2] sda4[24]
      458880 blocks super 1.0 [24/4] [UUUU____________________]
      bitmap: 1/1 pages [4KB], 65536KB chunk

md9 : active raid1 sdb1[1] sdd1[3] sdc1[2] sda1[24]
      530048 blocks super 1.0 [24/4] [UUUU____________________]
      bitmap: 1/1 pages [4KB], 65536KB chunk
QNAP TS-451 - 4 * Seagate NAS 4TB (RAID10) - FW: QTS 4.3.6 Build 1050

dolbyman
Guru
Posts: 15267
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Disk's failure - Raid Error status (TS-451)

Post by dolbyman » Tue Sep 17, 2019 2:49 am

run

Code: Select all

md_checker
if the wrong two drives failed then your RAID is toast.. that's why you should run RAID6 for guaranteed two drive failure tolerance

the firmware you are running was recalled by qnap, so a downgrade might also be advised
Last edited by dolbyman on Tue Sep 17, 2019 4:17 am, edited 1 time in total.

alekons
Starting out
Posts: 21
Joined: Wed Jan 28, 2015 11:44 pm

Re: Disk's failure - Raid Error status (TS-451)

Post by alekons » Tue Sep 17, 2019 3:01 am

Thanks for the advice. Output of the command below:

Code: Select all

[admin@QNAPNAS share]# md_checker

Welcome to MD superblock checker (v1.4) - have a nice day~

Scanning system...

HAL firmware detected!
Scanning Enclosure 0...

RAID metadata found!
UUID:           136b3e4a:e0f44a4b:cc1bba75:9bcd0f3d
Level:          raid10
Devices:        4
Name:           md1
Chunk Size:     64K
md Version:     1.0
Creation Time:  Feb 7 18:59:49 2015
Status:         OFFLINE
===============================================================================
 Disk | Device | # | Status |   Last Update Time   | Events | Array State
===============================================================================
 --------------  0  Missing   -------------------------------------------
 --------------  1  Missing   -------------------------------------------
   3  /dev/sdc3  2   Active   Jul 23 15:43:57 2019  2686358   A.AA
   4  /dev/sdd3  3   Active   Jul 23 15:43:57 2019  2686358   A.AA
===============================================================================

Strange as the drives are present:

Code: Select all

[admin@QNAPNAS ~]# qcli_storage -d
Enclosure  Port  Sys_Name     Type      Size      Alias          Signature   Partitions  Model
NAS_HOST   1     /dev/sda     HDD:free  3.64 TB   --             QNAP FLEX   5           WDC WD40PURX-64GVNY0
NAS_HOST   2     /dev/sdb     HDD:free  3.64 TB   --             QNAP FLEX   5           Seagate ST4000VN000-1H4168
NAS_HOST   3     /dev/sdc     HDD:data  3.64 TB   --             QNAP FLEX   5           Seagate ST4000VN000-1H4168
NAS_HOST   4     /dev/sdd     HDD:data  3.64 TB   --             QNAP FLEX   5           Seagate ST4000VN000-1H4168
QNAP TS-451 - 4 * Seagate NAS 4TB (RAID10) - FW: QTS 4.3.6 Build 1050

dolbyman
Guru
Posts: 15267
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Disk's failure - Raid Error status (TS-451)

Post by dolbyman » Tue Sep 17, 2019 5:24 am

looks like the raid is busted

you could try a force assemble (if you have working backups)

Code: Select all

mdadm --assemble --force --verbose /dev/md1 /dev/sda /dev/sdb /dev/sdc /dev/sdd
or even better yet, try to open a ticket with qnap

alekons
Starting out
Posts: 21
Joined: Wed Jan 28, 2015 11:44 pm

Re: Disk's failure - Raid Error status (TS-451)

Post by alekons » Tue Sep 17, 2019 5:46 am

thank you for the help. The command didnt work:

Code: Select all

[admin@QNAPNAS ~]# mdadm --assemble --force --verbose /dev/md1 /dev/sda /dev/sdb /dev/sdc /dev/sdd
mdadm: looking for devices for /dev/md1
mdadm: Cannot assemble mbr metadata on /dev/sda
mdadm: /dev/sda has no superblock - assembly aborted
So i opened a ticket to support.
QNAP TS-451 - 4 * Seagate NAS 4TB (RAID10) - FW: QTS 4.3.6 Build 1050

Post Reply

Return to “System & Disk Volume Management”