Help ! All Files lost after Raid5 rebuild

Questions about SNMP, Power, System, Logs, disk, & RAID.
Post Reply
D3xmeister
New here
Posts: 4
Joined: Fri Sep 20, 2019 12:37 am

Help ! All Files lost after Raid5 rebuild

Post by D3xmeister » Fri Sep 20, 2019 12:54 am

Hello, I have a TS420 with a Raid5 4x2TB disks. One of the disk failed (showed as a bad 3GB disk) and RAID5 was running in degraded mode.

2 days ago I Swapped the bad HDD with a new 2TB one and the RAID5 rebuild has started automatically in Storage manager, so I let it be.

Today, I connected to the NAS, and there was a firmware update prompt that was taking the whole screen. I clicked on Start Firmware update, it did it, it restarted and it then showed the first set-up wizzard, like when it was new.

I found below the wizard the restart button so I restarted it, and now it boots up fine, the Raid 5 is reconstructed and healthy, all the user accounts have their home folders present in the file system, but these users are missing now from users, all I have is the admin, and all the folders created by the users and admin anywhere in the file systems are gone, basically all the data. Disk management shows I have all free space basically.

I looked at the logs and all it showed is Raid configuration is reconstructed but it is in orange, and firmware update completed and nothing else except normal start-up logs. All form today, there are no old logs.

How can I recover my data ? How it got lost without a warning or me doing anything to it ? Any ideas ?

Thanks

dolbyman
Guru
Posts: 15201
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Help ! All Files lost after Raid5 rebuild

Post by dolbyman » Fri Sep 20, 2019 1:04 am

no backups ?

was the RAID rebuild finished before you did the firmware upgrade ?

see if you can find your data if you recreate the shares via share management (although if the disk managment shows up as free space, I fear that won't work)

D3xmeister
New here
Posts: 4
Joined: Fri Sep 20, 2019 12:37 am

Re: Help ! All Files lost after Raid5 rebuild

Post by D3xmeister » Fri Sep 20, 2019 1:40 am

There are backups but in many different places, it will take a lot of time to gather all the data again in one place.

I don't know if the rebuild finished, when I accessed it today it was at the firmware update screen that was taking over the whole interface, and I just clicked to update the firmware.

All I have in the share management is the default shares and an option to restore default shared folders which I assume is not what I want.

dolbyman
Guru
Posts: 15201
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Help ! All Files lost after Raid5 rebuild

Post by dolbyman » Fri Sep 20, 2019 1:51 am

QNAP does not force you to update, you should have ignored the update until you made sure all is rebuild , I have never seen a full screen info about updates.. but then I work with relatively high res screens

did you have custom shares ? .. if so recreate them and see if there is counterparts on the volume when you point it towards the storage

D3xmeister
New here
Posts: 4
Joined: Fri Sep 20, 2019 12:37 am

Re: Help ! All Files lost after Raid5 rebuild

Post by D3xmeister » Fri Sep 20, 2019 2:28 am

Tried, but it doesn't work. :(( It could be that the rebuild wasn't finished, I had the option to cancel but I assumed it finished and restarted and that's why there was the fw update notification, which unlike those that appear in a box, this one was taking the whole interface, but yes there was the option to cancel or update and I clicked update.

User avatar
MrVideo
Experience counts
Posts: 4661
Joined: Fri May 03, 2013 2:26 pm

Re: Help ! All Files lost after Raid5 rebuild

Post by MrVideo » Fri Sep 20, 2019 11:34 am

Now it looks like you have to start over.

Log in as admin vis ssh and run the following command:

Code: Select all

du -sk /share/*
and report back the results.
QTS 4.1.n/4.2.n/4.3.n MANUAL
Submit QNAP Support Ticket - QNAP Tutorials, FAQs, Downloads, Wiki - Product Support Status - Moogle's QNAP FAQ help V2
When you ask a question, please include the following
(Thanks to Toxic17 for the links)
QNAP md_checker nasreport (release 20180525)
===============================
Model: TS-869L -- RAM: 3G -- FW: QTS 4.1.4 Build 20150522 (used for data storage)
WD60EFRX-68L0BN1(x1)/68MYMN1(x7) Red HDDs -- RAID6: 8x6TB -- Cold spare: 1x6TB
Entware
===============================
Model: TS-451A -- RAM: 2G -- FW: QTS 4.2.3 Build 20170213 (used as a video server)
WL3000GSA6472(x3) White label NAS HDDs -- RAID5: 3x3TB
Entware -- MyKodi 17.3 (default is Kodi 16)
===============================
My 2017 Total Solar Eclipse Photos

D3xmeister
New here
Posts: 4
Joined: Fri Sep 20, 2019 12:37 am

Re: Help ! All Files lost after Raid5 rebuild

Post by D3xmeister » Fri Sep 20, 2019 3:52 pm

Last night I already created new shares and started copying the data back, have to have all there by monday so I could not wait.

Still seems weird to me this happened, even with that firmware update and reboot I think the rebuilt should have continued not giving me a ready built raid 5 that’s empty. Also, having all the user accounts folder in ,,Homes,, but no actual accounts in ,,Users,, is another weird thing I don’t get.

Thank you for the help.

Post Reply

Return to “System & Disk Volume Management”