Shares access denied + [smdb] process relaunch problem

Questions about SNMP, Power, System, Logs, disk, & RAID.
Post Reply
arnaud
New here
Posts: 5
Joined: Fri May 30, 2008 11:08 pm

Shares access denied + [smdb] process relaunch problem

Post by arnaud » Sat Nov 15, 2008 5:06 pm

Hello,

After a power disruption and 1 year of perfect functioning, I am experiencing an "access denied" on all my QNAP T209 II (2x1TB RAID1) shares, either accessed from windows or web file manager. I've also detected some mash up in the directory tree.

My log also mentions hard disk journal inconsistence and a re-launch of [evtlogd] and [smbd] every minute or so. I've found those events described in the forum, without solution.

I tried a fdisk -l via telnet, returning the following and does not sound too good:

Code: Select all

[code]Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          66      530113+  83  Linux
/dev/sda2              67         132      530145   82  Linux swap / Solaris
/dev/sda3             133      121590   975611385   83  Linux
/dev/sda4          121591      121600       80325   83  Linux

Disk /dev/sda4: 73 MB, 73531392 bytes
2 heads, 4 sectors/track, 17952 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/sda4 doesn't contain a valid partition table

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          66      530113+  83  Linux
/dev/sdb2              67         132      530145   82  Linux swap / Solaris
/dev/sdb3             133      121590   975611385   83  Linux
/dev/sdb4          121591      121600       80325   83  Linux

Disk /dev/md0: 999.0 GB, 999025934336 bytes
2 heads, 4 sectors/track, 243902816 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md0 doesn't contain a valid partition table

Disk /dev/md9: 542 MB, 542769152 bytes
2 heads, 4 sectors/track, 132512 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md9 doesn't contain a valid partition table

Disk /dev/md5: 542 MB, 542769152 bytes
2 heads, 4 sectors/track, 132512 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md5 doesn't contain a valid partition table
[/code]


What I've tried until now is the following:
- test HD as recommended in log. Not working (unable to unmount, as stated in log)
- remove 1 hard disk and rebuild the RAID. File access with 1 disk was OK as well as rebuild but no change to access denied status nor re-launches after the mirroring completion.

I am not a linux/RAID expert but can manage through some tech procedure. Any clue about what I could do?


As B-plan: I fear that I may have to format the logical drive but have no spare disk big enough to contain the data. Is there a way for me to format only 1 disk and use the second mirror on stand-alone basis (by ex mounted on a PC or as external drive) to put back the data on the QNAP afterwards. What would I need to achieve that, focusing especially on the RAID1 structure?

Thank you so much for your help!

Arnaud
arnaud.x.lefevre @ gmail.com
Brussels, Belgium

User avatar
QNAPJames
QNAP Staff
Posts: 1492
Joined: Fri Jun 13, 2008 3:12 pm
Location: Irvine, California

Re: Shares access denied + [smdb] process relaunch problem

Post by QNAPJames » Sun Nov 16, 2008 4:31 am

hi there,

please contact our tech. support and let them check it for you. it can also help us to find out if there is a problem. thanks!

arnaud
New here
Posts: 5
Joined: Fri May 30, 2008 11:08 pm

Re: Shares access denied + [smdb] process relaunch problem

Post by arnaud » Sun Nov 16, 2008 6:59 pm

Dear James,

I sent support a kind request this Friday evening. Still plenty of patience in store, don't worry: it gave me time to back up that 1TB mass of data, too, which is not that bad after all.

I'll come back here if no answer is received mid-week.

Thanks for coming back to me!

Arnaud
arnaud.x.lefevre @ gmail.com
Brussels, Belgium

jwscholl2561
First post
Posts: 1
Joined: Mon Dec 22, 2008 10:11 pm

Re: Shares access denied + [smdb] process relaunch problem

Post by jwscholl2561 » Sun Sep 27, 2009 11:03 pm

after a year of flawless service using Seagate 1.5TB drives, my ts409 is giving this same error.....was there resolution to this issue? what was it?

Post Reply

Return to “System & Disk Volume Management”