Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Questions about using NAS on Mac OS.
Post Reply
Stefano1975
New here
Posts: 9
Joined: Tue Mar 23, 2021 12:28 am

Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by Stefano1975 » Tue Mar 23, 2021 7:20 pm

Hi everyone.
I am quite satisfied with my TS-230. However, I noticed that my (wired) connection between my NAS and my iMac is often lost, both with AFP and SMB protocols.
Most of the times, it requires minutes to get my NAS shared folders appear in my network resources on iMac, some other times, it only takes few seconds, however too often I get a connection lost.
This happens only with my iMac. In fact, qFile on my Android and iPad works like a charm. It's worth mentioning that my iMac does not lose connection with the NAS when I connect to it via 192.162.1.XXX (Chrome). The connection failure is seemingly linked to the smb and afp protocols.
Does anyone know how to fix this, please?
Thanks in advance.
Stefano

torch1
Know my way around
Posts: 112
Joined: Thu Jul 04, 2019 4:53 am

Re: Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by torch1 » Sat Mar 27, 2021 12:53 am

Big Sur does not "officially" support AFP https://support.apple.com/guide/mac-hel ... lp3015/mac
Suggest you disable AFP on the QNAP and see if that resolves your issue.

Stefano1975
New here
Posts: 9
Joined: Tue Mar 23, 2021 12:28 am

Re: Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by Stefano1975 » Sat Mar 27, 2021 3:22 am

Thanks for your reply.
My iMac has High Sierra, not Big Sur.
Moreover, when I tried to deactivate AFP support, my NAS advised me I would have to disable Time Machine backup (and I don't want to do that).
Do you know how to keep TM backup job with AFP disabled?
Thanks a lot in advance

torch1
Know my way around
Posts: 112
Joined: Thu Jul 04, 2019 4:53 am

Re: Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by torch1 » Sat Mar 27, 2021 4:02 am

Sorry - just assume you were on BS. High Sierra supports TM over SMB as well: https://support.apple.com/guide/mac-hel ... /mac/10.13
Follow the QNAP tutorial on using TM with SMB: https://www.qnap.com/en-us/how-to/tutor ... -via-smb-3

Stefano1975
New here
Posts: 9
Joined: Tue Mar 23, 2021 12:28 am

Re: Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by Stefano1975 » Sat Mar 27, 2021 2:15 pm

Thanks so much. I'll try and let you know.
Have a nice day.
Best,

Stefano1975
New here
Posts: 9
Joined: Tue Mar 23, 2021 12:28 am

Re: Lost connection (SMB and AFP) between iMac and NAS (wired configuration)

Post by Stefano1975 » Sat Mar 27, 2021 10:44 pm

I tried to enable the TM backup with SMB support only, but every time I try to switch off the AFP in my NAS I get a message the says I have to disable TM backup.
Are you sure that this is not linked to my TS-230? Couldn't it be that this is possible with other NAS, but not mine?
P.S.
I am a newbie with NAS, so please be patience :)
Thanks again

EDIT
Maybe I found the reason why I cannot swith off the AFP support without deactivating the TM backup. I am using the HBS 3 app within the NAS, and this creates a virtual user and a shared folder without asking which network sharing protocol would be used.
I will try the alternative way that is explained here: https://www.qnap.com/en-us/how-to/tutor ... -via-smb-3
I hope I solve my problem.
Thanks a lot

Stefano

Post Reply

Return to “Mac OS”