Disabling UPNP in myQNAPcloud link does nothing

Post your questions about myQNAPcloud service here.
Post Reply
bigjimmy
New here
Posts: 3
Joined: Tue Sep 14, 2021 12:34 am

Disabling UPNP in myQNAPcloud link does nothing

Post by bigjimmy » Tue Sep 14, 2021 12:55 am

I have unchecked the upnp setting in myQNAPcloud (under "Auto Router Configuration") as I do not need to access my NAS outside of my network.

However, after looking through the UPNP rules in my router and looking at the logs, I can see that the qnap NAS is still opening ports on my router, seemingly ignoring the above setting.

Is there a way to get the NAS to stop opening ports on my router? I don't want to disable UPNP for my entire network as it will cause problems for one of my other devices.

I want to do this as looking through my router logs I can see lots of probing requests where my network is being probed for open ports, and I can see that they have discovered that there is an open port on the NAS as they keep hitting it with requests, probably looking for a vulnerability.

User avatar
dolbyman
Guru
Posts: 24009
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Disabling UPNP in myQNAPcloud link does nothing

Post by dolbyman » Tue Sep 14, 2021 12:57 am

Don't know what other devices you have .. but a manual portforward for [that other device] should be better than this gaping security hole named upnp.

Cloudlink (tunnel via QNAP servers) does not use upnp / autorouter config. Directly exposing services does.

Maybe you already have a malware infection on the NAS that is controlling upnp itself

bigjimmy
New here
Posts: 3
Joined: Tue Sep 14, 2021 12:34 am

Re: Disabling UPNP in myQNAPcloud link does nothing

Post by bigjimmy » Tue Sep 14, 2021 3:04 am

That manual port forward for the other device sounds like a good idea. I'll look into this.

It still seems daft that the setting in myQNAPcloud link does nothing. I might open up a support ticket.

Looking at the UPNP table on my router, it shows that the NAS has opened up the following ports. I've ssh'd into the NAS and have inspected the processes running on the open ports:

8080 - The web portal
80 - apache - no idea why this is running as there is nothing served
443 - apache_pr - again, no idea why this is running as nothing is served
52935 - No process running on this port, but the NAS has opened it

52935 is the one that is concerning me and is getting probed in the logs a lot. I've disabled UPNP at the router for now.

User avatar
spile
Easy as a breeze
Posts: 433
Joined: Tue May 24, 2016 12:13 am

Re: Disabling UPNP in myQNAPcloud link does nothing

Post by spile » Tue Sep 14, 2021 2:58 pm

bigjimmy wrote:
Tue Sep 14, 2021 3:04 am
I've disabled UPNP at the router for now.
That is the key requirement to secure your NAS.

bigjimmy
New here
Posts: 3
Joined: Tue Sep 14, 2021 12:34 am

Re: Disabling UPNP in myQNAPcloud link does nothing

Post by bigjimmy » Tue Sep 14, 2021 4:59 pm

Thanks. I've done this. The NAS could also be secured if this checkbox in the admin tools worked.

Post Reply

Return to “myQNAPcloud service”