Unable to reach NAS Web from home network using My DDNS

Post your questions about myQNAPcloud service here.
Post Reply
yeemp
New here
Posts: 4
Joined: Sun Oct 18, 2015 11:48 am

Unable to reach NAS Web from home network using My DDNS

Post by yeemp » Tue Oct 12, 2021 3:58 am

Greetings Everyone,

Thank you ahead of time for your patience as I try to articulate the issue and I'm not a network expert.

Current Setup
+ My QNAP device is a TVS-672N. It is connected to my home router with two physical adapters (NIC)
+ physical adapter 1 (5 GbE NIC) - static IP address 192.168.1.204
+ physical adapter 2 (1 GbE NIC) - static IP address 192.168.1.202

+ ROCK is the QNAP Server Name (not the real name of my server)

Issue
I am unable to reach the NAS Web service when connected to my home network using My DDNS (e.g. https://rock.myqnapcloud.com:44301). In Chrome the message is "This site cannot be reached. rock.myqnapcloud.com took too long to respond

When on my home network, I can connect using the local IP Address. e.g. https://192.168.1.204:44301 or https://192.168.1.202:44301 However when I use the local IP address, chrome displays "your connection isn't private". I can click on "Advanced" and then the link "Continue to https://192.168.1.204 (unsafe)" and the NAS login screens appears.

This is inconvenient as many of my mobile devices access and sync to the QNAP server using rock.myqnapcloud.com and cannot do so when I am on my home network.


Data Points
+ I am able to successfully access the NAS Web service using My DDNS, https://rock.myqnapcloud.com:44301, when I am not on my home network. Example: connected to a hot spot on my phone, at home using a VPN, connected to the WiFi in a coffee shop.
+ My Window 10 machine does see ROCK on the network. I can connect to a network drive via \\ROCK\share (see notes below)


What I've done so far,
+ In myqnapcloud I did replace the SSL certificate - I use Let's Encrypt. No changes to the symptoms above. When I am not my home network I can reach the NAS Web Service using My DDNS (e.g. https://rock.myqnapcloud.com:44301), but when I'm on my home network I can only use the local IP address
+ During troubleshooting this, I've stopped Virtualization Station. Virtualization Station was using a Virtual Switch going to a physical adapter (1 GbE NIC).
+ When I disconnect physical adapter 1 (5 GbE NIC) - static IP address 192.168.1.204 - my Windows 10 machine can no longer see ROCK on the network. As soon as that is plugged back in, the shared folders for ROCK are visible and accessible and QFInder can see ROCK.
+ Note when both NICs are connected Qfinder can see both 192.168.1.202 and 192.168.1.204. When connecting to ROCK from Qfinder it uses the respected IP Address.

+ When I disconnect physical adapter 2 (1 GbE NIC) - static IP address 192.168.1.202 - a machine not on my home network CANNOT access the NAS Web service (QNAP QTS login screen) using https://rock.myqnapcloud.com:44301). As soon as that is plugged back in a machine not on my home network CAN access the NAS Web service (QNAP QTS login screen) using https://rock.myqnapcloud.com:44301)


Guidance and additional questions are welcome!

User avatar
OneCD
Ask me anything
Posts: 9375
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: Unable to reach NAS Web from home network using My DDNS

Post by OneCD » Tue Oct 12, 2021 4:29 am

It sounds like your router doesn't support NAT loopback: https://en.wikipedia.org/wiki/Hairpinning

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

yeemp
New here
Posts: 4
Joined: Sun Oct 18, 2015 11:48 am

Re: Unable to reach NAS Web from home network using My DDNS

Post by yeemp » Tue Oct 12, 2021 4:40 am

Thank you OneCD for that suggestion. I should have pointed out that up until last week I was able to access the NAS Web service using My DDNS (e.g. https://rock.myqnapcloud.com:44301) from my home network. That said I will check into the router and see if something changed.

Cheers!

yeemp
New here
Posts: 4
Joined: Sun Oct 18, 2015 11:48 am

Re: Unable to reach NAS Web from home network using My DDNS

Post by yeemp » Wed Oct 13, 2021 9:45 am

quick update: still having the same issue. Tried a few more things on the NAS --> no improvements and not gotten worse.

I did turn my attention to the router. My router is an asus rt-ac3100. I updated to the most current firmware (and rebooted). I doubled checked the WAN settings and "Enable NAT" is set to "Yes". I do still think it's the router. I'll have to weigh if this is important enough to warrant a new router...

Post Reply

Return to “myQNAPcloud service”