Let’s Encrypt - Authentication fails. Please check the DNS server or if the port 80 is working

Post your questions about myQNAPcloud service here.
Post Reply
smssoleimani
New here
Posts: 2
Joined: Thu Jan 06, 2022 10:30 am

Let’s Encrypt - Authentication fails. Please check the DNS server or if the port 80 is working

Post by smssoleimani » Fri Jan 07, 2022 11:09 am

Hi QNAP community,

I recently purchased a new QNAP NAS - It’s my first QNAP, I am new to the QNAP landscape but familiar with NAS as I've owned a Synology for a few years now. I need some help configuring Let's Encrypt so I can leverage SSL/HTTPS. Initially I tried doing this via network and file services > network and virtual switch > ddns. This is all fine if I want to use myQNAPcloud domain which I don't. I purchased a new domain that I'd like to use and I've configured it as a secondary DDNS, so there's two now, myQNAPcloud and my other domain hosted via Google Domains. I initially had SSL setup on myQNAPcloud but since removed that as I want to use my custom domain. Within DDNS there's a SSL certificate tab and there I can configure Let's Encrypt but it only lets you do it for the myQNAPcloud domain, quite annoying. So I did some research and came across a few hopeful forum posts [1] so I tried a few things. First I tried going to control panel > security > ssl certificate and private key. There is an option to replace certificate here so I tried doing that and selecting 'get from let's encrypt.' Initially I tried my own domain and email and I received the message "A domain validation challenge was net received from the ACME Server, Ensure that your router and QNAP device both accept inbound traffic on ports 80 and 443." I am 99.9% sure those ports are open, if someone would like to provide me a way to validate for certain I am happy to make sure. I tried enabling the web server on port 80 as well and port forwarding within ddns settings shows web server 80 as ok. I tried deleting the ".well-known" directory. I did something (forget what) that resulted in the error message changing from what I said above to now saying "Authentication fails. Please check the DNS server or if the port 80 is working." So I guess that's some progress :). Below are the various things I've tried and I am at my wits end. I tried sshing in and playing around with LEgo and other suggestions but no luck.

Any ideas would be greatly appreciated, thanks in advance!

NAS Model: TVS-872XT
Firmware version: 4.5.4.1892

[1]:
viewtopic.php?f=320&t=132911
https://github.com/Yannik/qnap-letsencrypt
viewtopic.php?f=313&t=129872#p617329
viewtopic.php?f=313&t=144434
Screen Shot 2022-01-06 at 8.20.46 PM.png
Screen Shot 2022-01-06 at 8.42.32 PM.png
Screen Shot 2022-01-06 at 10.04.18 PM.png
Screen Shot 2022-01-06 at 10.04.39 PM.png
Screen Shot 2022-01-06 at 10.05.47 PM.png
Screen Shot 2022-01-06 at 10.06.51 PM.png
You do not have the required permissions to view the files attached to this post.

Post Reply

Return to “myQNAPcloud service”