Cannot log into NAS with Qsync

Post your questions about myQNAPcloud service here.
keeztha
New here
Posts: 9
Joined: Tue Sep 20, 2016 12:38 pm

Re: Cannot log into NAS with Qsync

Post by keeztha » Sun Sep 25, 2016 1:01 pm

to degrade QSync client, it seems to work well at first, but QSync does not work now...
3 days have passed since the last synchronization. and QSync client still continues to repeat scanning.

pbkr1964
Starting out
Posts: 24
Joined: Sat Sep 19, 2015 4:48 am

Re: Cannot log into NAS with Qsync

Post by pbkr1964 » Sat Oct 01, 2016 7:37 am

Support did another reset of the databases..seems to have solved the issue now. Since tuesday til today all ok.

Verstuurd vanaf mijn SM-T810 met Tapatalk

keeztha
New here
Posts: 9
Joined: Tue Sep 20, 2016 12:38 pm

Re: Cannot log into NAS with Qsync

Post by keeztha » Sat Oct 01, 2016 1:08 pm

Hi pbkr1964,

How did you reset?
remove "/share/MD0_DATA/homes/<username>/.Qsync/.qsync/" directory?
i want to try it.

and would you tell me your firmware version?
my qnap model and firmware version is "TS-220/4.2.2".

Regards.

pbkr1964
Starting out
Posts: 24
Joined: Sat Sep 19, 2015 4:48 am

Re: Cannot log into NAS with Qsync

Post by pbkr1964 » Sun Oct 02, 2016 6:48 am

I let qnap support do that, because i have no knowledge in that area. But the issue returned. I did now a roll back of the firmware to 4.2.1. Qsync immediately connected and synched again. Will watch it for a couple of days and let you know

Verstuurd vanaf mijn SM-T810 met Tapatalk

keeztha
New here
Posts: 9
Joined: Tue Sep 20, 2016 12:38 pm

Re: Cannot log into NAS with Qsync

Post by keeztha » Sun Oct 02, 2016 2:43 pm

Hi pbkr1964,
Thanks for your reply and watch!

hmm...
i will try to rollback the firmware too...

pbkr1964
Starting out
Posts: 24
Joined: Sat Sep 19, 2015 4:48 am

Re: Cannot log into NAS with Qsync

Post by pbkr1964 » Tue Oct 04, 2016 4:45 pm

Qsynch still working....

Verstuurd vanaf mijn SM-T810 met Tapatalk

ratnick66
New here
Posts: 3
Joined: Thu Jul 28, 2016 4:12 pm

Re: Cannot log into NAS with Qsync

Post by ratnick66 » Wed Oct 05, 2016 2:42 am

Same problem here. Just posting to get notified when I can use my QNAP again.

rwanwork
Starting out
Posts: 11
Joined: Wed Aug 31, 2016 10:17 pm

Re: Cannot log into NAS with Qsync

Post by rwanwork » Wed Oct 05, 2016 12:01 pm

Dear all,

Just to update all of you that the problem has been solved. I did need to report the problem to QNAP technical support and then organised a meeting via TeamViewer (basically similar to Windows Remote Desktop). So, they had to ssh into the NAS and ran some commands. I'm not clear what they did (I wasn't watching very carefully) but they said the database wasn't started correctly and had to be started manually. And if it happens again, I need to report it to them again.

This was just yesterday and so far, so good.

I think if you are seeing this problem (i.e., see my messages before that describe the problem), you should report it to QNAP's technical team. Perhaps if this problem affects more people, they might consider a future firmware upgrade -- but this wasn't mentioned yesterday to me.

Thank you all for the useful discussion!

Ray

pbkr1964
Starting out
Posts: 24
Joined: Sat Sep 19, 2015 4:48 am

Re: Cannot log into NAS with Qsync

Post by pbkr1964 » Fri Oct 07, 2016 4:25 pm

Had done that too, but after restart of nas issue returned, i did a roll back to 4.2.1 and now no problems anymore.

Verstuurd vanaf mijn SM-T810 met Tapatalk

keeztha
New here
Posts: 9
Joined: Tue Sep 20, 2016 12:38 pm

Re: Cannot log into NAS with Qsync

Post by keeztha » Mon Oct 10, 2016 12:32 pm

Hi all,

Just now, I've finished downgrade of the firmware '4.2.2 Build 20160901' -> '4.2.1 build 20160601' (TS-220).
QSync client has started to synchronize and i get first success since Sep 19th!

Meanwhile, i reported the trouble to the technical team. the downgrade is not desirable, and i hope the trouble is settled on the next firmware version...

michelv
New here
Posts: 7
Joined: Sat Jan 22, 2011 6:53 pm

Re: Cannot log into NAS with Qsync

Post by michelv » Mon Oct 10, 2016 2:30 pm

Any updates on this? I just updated the firmware and experience this bug as well. Update also reset the MAC address again, and broke SSH. So many issues, and not the first time.

But QSync is really what I need working now. And real solutions, instead of having them login and me spending loads of time allowing that?

rwanwork
Starting out
Posts: 11
Joined: Wed Aug 31, 2016 10:17 pm

Re: Cannot log into NAS with Qsync

Post by rwanwork » Mon Oct 10, 2016 11:18 pm

Hi,

Other than contacting the technical team yourself (which worked for me...so far), there is nothing else I could suggest.

Perhaps it is related to the firmware (I personally think it is, but that's just my opinion) and it will be "solved" in the next release; but they may not do that if they think the problem affects just one or two people. So, reporting it is perhaps the only way to get a more lasting fix. (I'm still worried as I don't know if the problem will come up again.)

Ray

michelv
New here
Posts: 7
Joined: Sat Jan 22, 2011 6:53 pm

Re: Cannot log into NAS with Qsync

Post by michelv » Tue Oct 11, 2016 9:16 pm

I got the following reply, posting it tested.
On my box, I got SSH certificate errors (ignore) and had to find out what is the correct name for $def_vol. That refers to a drive name, I had to ls -a to find it out.

Michel

___
Could you please try to clean the database of qsync :


Please follow this procedure :

Connect the NAS by SSH port 22, login as admin password admin

download here http://the.earth.li/~sgtatham/putty/lat ... /putty.exe

(you can right click you mouse to paste commands in putty)



NAS DB Fixed Step.
1. backup qsync db
/etc/init.d/qbox.sh backup_db /share/Public/qbox.db

2. stop mysql
/etc/init.d/mariadb.sh stop

3. remove mysql data
rm -r /share/$def_vol/.system/data

4. start mysql
/etc/init.d/mariadb.sh start

5. start qsync service
/etc/init.d/qbox.sh restart

6. restore qsync db
/etc/init.d/qbox.sh restore_db /share/Public/qbox.db (doesnt work yet so use next line till then )

/etc/init.d/qbox.sh clean_all_db

7. restart qsync service
/etc/init.d/qbox.sh restart

rwanwork
Starting out
Posts: 11
Joined: Wed Aug 31, 2016 10:17 pm

Re: Cannot log into NAS with Qsync

Post by rwanwork » Wed Oct 12, 2016 8:50 am

Thanks for posting the instructions! In my case, I enabled TeamViewer (i.e., like Windows Remote Desktop) and they did it for me. Not sure if it's exactly the same instructions, but they also didn't explain to me what they were doing. I think they only said that the database wasn't started. I presume they meant the Qsync database; they were not very clear about that.

I'm sure what you've posted can help many others (and me, if it happens again). Thank you!

Ray

macko79
New here
Posts: 2
Joined: Tue Sep 13, 2016 12:24 am

Re: Cannot log into NAS with Qsync

Post by macko79 » Wed Oct 12, 2016 10:41 pm

Hi,

I had my qsync database restored today via TeamViewer. Everything works since morning with the latest QNAP firmware and Qsync client. Talking to the support is the only option for those who do not know how to manage mysql database files.

good luck to others
Macko

Post Reply

Return to “myQNAPcloud service”