Can I disable UPnP requests from my QNAP NAS to the router?

Post your questions about myQNAPcloud service here.
Post Reply
bruno.dal
New here
Posts: 4
Joined: Tue Feb 28, 2017 6:07 pm

Can I disable UPnP requests from my QNAP NAS to the router?

Post by bruno.dal » Sat May 12, 2018 6:18 pm

Hello,
In my router (MikroTik) I need to keep the UPnP support enabled because a device in my network sometimes sends to it an UPnP request asking for mapping, for few seconds only, the port 80 to the device, but in my network I have a QNAP TS-253A NAS also and when it discovers that theUPnP service is active in the router, it get four ports mapped to it, including the 80, so this port cannot be mapped to my device.
My problem is the opposite as the usually ones, I don't need the ports mapped to the NAS (I manage it remotelly with the 443 port only, with a static rule set in the router) and in the NAS I cannot find a menu to disable these UPnP requests.
I know, in the "Network & File Services" of the control panel I have the "Service Discovery" section with the "Enable UPnP Discovery Service" setting, but disabling it the NAS gets the mapped ports in the router for it at the same way because this setting acts in the NAS enabling or not the "UPnP server" service, permitting or not to other devices to discover the NAS. It doesn't acts enabling or not the "UPnP client" service. Is there such a setting in the control panel?
Thank you,
Bruno

User avatar
schumaku
Guru
Posts: 43633
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Can I disable UPnP requests from my QNAP NAS to the router?

Post by schumaku » Fri Jun 22, 2018 2:24 am

Bruno,

It's in myQNAPcloud App - Automatic Router Configuration - here you can check the ports (if any) to be covered and forwarded:

myQNAPcloud Auto Router Configuration.JPG


Regards,
-Kurt.
You do not have the required permissions to view the files attached to this post.

bruno.dal
New here
Posts: 4
Joined: Tue Feb 28, 2017 6:07 pm

Re: Can I disable UPnP requests from my QNAP NAS to the router?

Post by bruno.dal » Tue Aug 07, 2018 3:37 pm

Hi Kurt,
thank you very much, you're right, I haven't noted this setting before.
Thinking to have not solution for my issue, I haven't more followed the thread and I solved in another way:
thanks to flexibility of MikroTik, I've created another VLAN an I put my device in this VLAN (but outside of the switch this is simply a LAN in another network for my device) and in the router I've enabled the UPnP support for this VLAN only.
Best regards,
Bruno

Post Reply

Return to “myQNAPcloud service”