need help for file sharing links/folders for remote access

Post your questions about myQNAPcloud service here.
User avatar
Moogle Stiltzkin
Ask me anything
Posts: 5923
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

need help for file sharing links/folders for remote access

Postby Moogle Stiltzkin » Fri May 25, 2018 11:14 am

I want to share folders/files via filestation.

So i share a sub directory, but when i tried using myqnapcloud, it didn't work.

but when using the smartlink method it works, why is that? Any ideas why the myqnapcloud method using dyndns does not work? yes i already port forwarded 443 to the correct NAS lan ip on router.

does anyone have a guide for this? i tried the video guides but they don't troubleshoot these types of issues i'm having :S


Yes i did get sharing to work via smartlink method, but i want to try getting the myqnapcloud dyndns method to work as well.

also what is the recommended setting to safely share? will people you share with be able to access the link, if it's set to private? i refrain from public, i don't want my page to be searchable :?


*update

for the smartlink, that worked when i added friend to customized access control in cloudlink.

though earlier there was a status abnormal for cloudlink, had to reconnect cloudlink and update the dyndns to myqnapcloud, and that seemed to fix it.


Wheeljack77 wrote:That's probably because your VPN is likely using the same port 443 to transfer data as myqnapcloud. Not sure if it is possible, but one way you could get around the issue is to see if you have a port triggering setting on your router and set your router to access port 443 (just add it to the rules). Port triggering is better that port forwarding because it allows multiple devices or apps to use the setting while port forwarding only forwards one specific port to one specific device.

is this the reason? :'

i did test disabling qvpn, but it still didn't work. but then again i did not reboot the qnap or router after disabling qvpn if that was required.

Port Trigger allows you to temporarily open data ports when LAN devices require unrestricted access to the Internet. There are two methods for opening incoming data ports: port forwarding and port trigger. Port forwarding opens the specified data ports all the time and devices must use static IP addresses. Port trigger only opens the incoming port when a LAN device requests access to the trigger port. Unlike port forwarding, port trigger does not require static IP addresses for LAN devices. Port forwarding allows multiple devices to share a single open port and port trigger only allows one client at a time to access the open port.


found a guide here
viewtopic.php?f=11&t=141386&p=671731#p671731


by the way this guide here, does not mention anything about port forwarding... which ought to be crucial for use by the myqnapcloud dynsdns for your link to even work.
https://www.qnap.com/en/how-to/tutorial ... le-station
NAS
[Main Server] QNAP TS-877 w. 4x HGST Deskstar NAS (HDN724040ALE640) EXT4 Raid5 & 2 x m.2 Samsung 850 Evo raid1 cache acceleration read only
[Backup] QNAP TS-653A w. 5x 2TB Samsung EcoGreen F3 (HD203WI) EXT4 Raid5
[Backup] QNAP TS-659 Pro
[Backup] QNAP TS-509 Pro w. 4x 1TB Western Digital RE3 (WD1002FBYS) EXT4 Raid5
[Backup] QNAP TS-228
[Backup] QNAP TS-128 w. 1x 1TB Western Digital RE3 (WD1002FBYS)

Network
Asus AC68U Router|100mbps dl/50mbps ul FTTH Internet | Windows 10 Enterprise, Water Cooled PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides and articles by me
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review
[Megathread] Qnap Frequently asked questions V2, click to read here

https://www.patreon.com/mooglestiltzkin

User avatar
MooChoo2
Know my way around
Posts: 197
Joined: Sun Jun 05, 2016 8:58 am
Location: Australia

Re: need help for file sharing links/folders for remote access

Postby MooChoo2 » Wed Jun 06, 2018 9:14 pm

Have you had any success?

I'm behind a double NAT :-(

I also use QVPN with ProtonVPN

One suggestion for me was to put my second router into the DMZ of the first in order for the for DynDNS to work and use MYQnapCloud, but from the sounds of things even if I do that and forward port 443 (or port trigger) I'm still going to run into troubles.
QNAP TS-253Be 8GB WD Red 6TB x 2 QTS 4.3.4.0644, WD 4TB External - Plex, PlexPy, Radarr, Sonarr, Lidarr, NZB Hydra 2, NZBGet, QVPN, Download Station, Hybrid Desk Station, Container Station, and IFTTT.

iMac 27" 5K i5 3.2Ghz 32GB, ATV 4K 32GB, ROKU 3 & 4, iPhone X 256GB iOS 12 Beta, iPad Pro 12.9 64GB with Apple Keyboard & Apple Pencil iOS 12 Beta, Apple Watch Series 3 LTE, ASUS RT-AC87U - ASUS-WRT Merlin, Apple AirPort Time Machine, Belkin Wemo (Lights, Switch, Motion), Homeboy Security Camera, Dell Desktop i5 Quadcore 3.4Ghz 12GB 240GB SSD Windows 10 Pro, & Debian.


Return to “myQNAPcloud service”

Who is online

Users browsing this forum: No registered users and 18 guests