[EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Post your questions about myQNAPcloud service here.
blackshine
Starting out
Posts: 20
Joined: Fri Apr 06, 2018 8:45 pm

[EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby blackshine » Thu Jun 28, 2018 3:03 pm

Nowadays, i'm getting this error message everyday. I've not made anything. I've nothing changed.

Code: Select all

Downgrade QcloudSSLCertificate from 2.1.13 to 2.1.12 is not allowed. If you still want to use QcloudSSLCertificate 2.1.12, please uninstall the QPKG first.   


I'm using Lets Encyrpt SSL from the beginning.

I'm worrying to a nas virus or like something. What can i do ? Please help me

NAS: TS-451a
Ver: 4.3.4.0537 build 20180331
You do not have the required permissions to view the files attached to this post.
Last edited by blackshine on Thu Jun 28, 2018 3:09 pm, edited 1 time in total.

User avatar
OneCD
Experience counts
Posts: 4657
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby OneCD » Thu Jun 28, 2018 3:05 pm

Have you installed and run the Malware Remover app?

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

I'm also on GitHub
To contact me: one.cd.only@gmail.com

blackshine
Starting out
Posts: 20
Joined: Fri Apr 06, 2018 8:45 pm

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby blackshine » Thu Jun 28, 2018 3:10 pm

OneCD wrote:Have you installed and run the Malware Remover app?


Yes have been installed. but nothing found.

User avatar
OneCD
Experience counts
Posts: 4657
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby OneCD » Thu Jun 28, 2018 3:17 pm

Current version of QTS SSL Certificate package in the App Center is 2.1.12.

I wonder if QNAP have removed a previously posted later version? After yours was upgraded? :S

Even then, yours shouldn’t be trying to install an earlier version automatically.

Suggest you uninstall your current QTS SSL Certificate package, then install the 2.1.12 version from the App Center.

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

I'm also on GitHub
To contact me: one.cd.only@gmail.com

blackshine
Starting out
Posts: 20
Joined: Fri Apr 06, 2018 8:45 pm

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby blackshine » Thu Jun 28, 2018 3:28 pm

OneCD wrote:Current version in the App Center is 2.1.12.

I wonder if QNAP have removed a previously posted later version? :S

Suggest you uninstall your current QTS SSL Certificate package, then install the 2.1.12 version from the App Center.


When i try to uninstall package, i could not click the button. Its un-clickable.
If it can be done via another manual method, i dont know it.
You do not have the required permissions to view the files attached to this post.

User avatar
OneCD
Experience counts
Posts: 4657
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby OneCD » Thu Jun 28, 2018 3:55 pm

To remove this package manually, please SSH into your NAS as the 'admin' user and run the following commands (copy & paste them into your terminal):

Code: Select all

$(getcfg QcloudSSLCertificate Install_Path -f /etc/config/qpkg.conf)/.uninstall.sh; rmcfg QcloudSSLCertificate -f /etc/config/qpkg.conf

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

I'm also on GitHub
To contact me: one.cd.only@gmail.com

blackshine
Starting out
Posts: 20
Joined: Fri Apr 06, 2018 8:45 pm

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby blackshine » Thu Jun 28, 2018 10:20 pm

OneCD wrote:To remove this package manually, please SSH into your NAS as the 'admin' user and run the following commands (copy & paste them into your terminal):

Code: Select all

$(getcfg QcloudSSLCertificate Install_Path -f /etc/config/qpkg.conf)/.uninstall.sh; rmcfg QcloudSSLCertificate -f /etc/config/qpkg.conf


I think it's worked :)
Hope to never see any downgrade error message on tomorrow.

Thank you.

blackshine
Starting out
Posts: 20
Joined: Fri Apr 06, 2018 8:45 pm

Re: [EMERGENCY] Downgrade QcloudSSLCertificate ERROR

Postby blackshine » Thu Jun 28, 2018 10:34 pm

Qnap Support returned me the solution as below.
I've completed their license update as well.

There is a bug on latest License Center v 1.0.2 which released on the App Center last week.

It caused all licenses disappear after update the License Center, or license failed to install.

Please install the fixed version of License Center 1.0.2 to resolve this issue:

https://drive.google.com/open?id=1t5-J6 ... Mm8E0jIMu1

Note:

arm_ms = x31 series
arm_al = x31+/P/X, x28/28A, x35 series


Return to “myQNAPcloud service”

Who is online

Users browsing this forum: No registered users and 17 guests